Virtual terminals don't work on kernels newer than 5.15

I’m trying to get virtual terminals working on my computer, that is, the ability to hit ctrl-alt-f3 and get a nice text-mode terminal. On kernel 5.15.120-1, this is exactly what happens! Problem solved!

On newer terminals, from 6.0 through 6.3, this does not happen. It returns me to the boot log screen which is displaying the /dev/nvme0n1p2: clean, message. Hitting enter does nothing; changing to other terminals does nothing; with the exception of ctrl-alt-f2 which cheerily drops me back in the GUI.

I would like actual virtual terminals.

I’m not sure what information here might be useful. In the absence of good ideas, here’s an inxi dump:

> inxi -Fazy                                                                                                                                                                                                                  
  Kernel: 5.15.120-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=5c10c4bd-3163-4c75-87aa-2ca4d0df4d05 rw quiet
    udev.log_priority=3 iommu=pt
  Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Gigabyte product: B650M AORUS ELITE AX v: -CF
    serial: <superuser required>
  Mobo: Gigabyte model: B650M AORUS ELITE AX v: x.x
    serial: <superuser required> UEFI: American Megatrends LLC. v: F6a
    date: 05/18/2023
  Info: model: AMD Ryzen 9 7950X bits: 64 type: MT MCP arch: Zen 4 gen: 5
    level: v4 note: check built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25)
    model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
  Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
    L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 16 MiB desc: 16x1024 KiB
    L3: 64 MiB desc: 2x32 MiB
  Speed (MHz): avg: 3014 high: 4981 min/max: 3000/5880 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 4981 2: 2857
    3: 2754 4: 2812 5: 2880 6: 2778 7: 2758 8: 2775 9: 2994 10: 2994 11: 2992
    12: 2994 13: 2994 14: 2992 15: 2993 16: 2994 17: 3755 18: 2867 19: 3019
    20: 2907 21: 2865 22: 2874 23: 2834 24: 2871 25: 2994 26: 2993 27: 2984
    28: 2994 29: 2992 30: 2987 31: 2993 32: 2998 bogomips: 287572
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA TU104 [GeForce RTX 2080 SUPER] vendor:
    driver: nvidia v: 535.54.03 alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-07) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1e81 class-ID: 0300
  Device-2: AMD Raphael vendor: Gigabyte driver: N/A arch: RDNA-2
    code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4
    speed: 16 GT/s lanes: 16 bus-ID: 10:00.0 chip-ID: 1002:164e class-ID: 0300
  Device-3: Valve 3D Camera driver: uvcvideo type: USB rev: 3.2 speed: 5 Gb/s
    lanes: 1 mode: 3.2 gen-1x1 bus-ID: 2-2.1:3 chip-ID: 28de:2400 class-ID: 0e02
    serial: <filter>
  Device-4: Logitech HD Pro Webcam C920 driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-4.2.2:15
    chip-ID: 046d:082d class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 5760x2680 s-dpi: 86 s-size: 1702x792mm (67.01x31.18")
    s-diag: 1877mm (73.91")
  Monitor-1: DP-3 pos: bottom-l res: 1920x1080 hz: 60 dpi: 94
    size: 521x293mm (20.51x11.54") diag: 598mm (23.53") modes: N/A
  Monitor-2: DP-4 pos: primary,top-center res: 2560x1600 hz: 60 dpi: 101
    size: 641x400mm (25.24x15.75") diag: 756mm (29.75") modes: N/A
  Monitor-3: HDMI-0 pos: bottom-r res: 1280x1024 hz: 60 dpi: 86
    size: 376x301mm (14.8x11.85") diag: 482mm (18.96") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 535.54.03 renderer: NVIDIA GeForce RTX 2080
    SUPER/PCIe/SSE2 direct-render: Yes
  Device-1: NVIDIA TU104 HD Audio vendor: driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:10f8 class-ID: 0403
  Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 10:00.1
    chip-ID: 1002:1640 class-ID: 0403
  Device-3: AMD Family 17h/19h HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 10:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Device-4: Valve VR Radio driver: cdc_acm,hid-generic,usbhid type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-2.3.2:5
    chip-ID: 28de:2102 class-ID: 0a00 serial: <filter>
  Device-5: Valve VR Radio & HMD Mic driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-2.3.3:6
    chip-ID: 28de:2102 class-ID: 0102 serial: <filter>
  Device-6: Logitech HD Pro Webcam C920 driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-4.2.2:15
    chip-ID: 046d:082d class-ID: 0102 serial: <filter>
  API: ALSA v: k5.15.120-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.73 status: active with: 1: pipewire-pulse
    status: active 2: pipewire-media-session status: active 3: pipewire-alsa
    type: plugin tools: pactl,pw-cat,pw-cli
  Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 0c:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp12s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    driver: N/A modules: mt7921e pcie: gen: 2 speed: 5 GT/s lanes: 1
    bus-ID: 0d:00.0 chip-ID: 14c3:0616 class-ID: 0280
  IF-ID-1: br-003f6cfda017 state: down mac: <filter>
  IF-ID-2: br-14c0a2a1859a state: down mac: <filter>
  IF-ID-3: br-329d1eb5f232 state: down mac: <filter>
  IF-ID-4: br-632c89a21363 state: down mac: <filter>
  IF-ID-5: br-b0b038dd53df state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IF-ID-6: br-b8ec5c39e582 state: down mac: <filter>
  IF-ID-7: br0 state: down mac: <filter>
  IF-ID-8: docker0 state: up speed: 10000 Mbps duplex: unknown mac: <filter>
  IF-ID-9: veth0cfc5bf state: up speed: 10000 Mbps duplex: full mac: <filter>
  IF-ID-10: veth24383d7 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-11: virbr0 state: down mac: <filter>
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
    v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1
    bus-ID: 3-4.4.1:14 chip-ID: 0a12:0001 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 20.01 TiB used: 7.59 TiB (37.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: PNY model: CS3140 4TB SSD
    size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: CS314314 temp: 39.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST4000DM000-1F2168
    size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5900 serial: <filter> fw-rev: CC52 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD140EDGZ-11B1PA0 size: 12.73 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: 0A85 scheme: GPT
  ID-1: / raw-size: 3.64 TiB size: 3.58 TiB (98.40%) used: 885.52 GiB (24.2%)
    fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 32 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile32g
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 47 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 580 Uptime: 6m wakeups: 2 Memory: total: 64 GiB
  available: 61.96 GiB used: 5.74 GiB (9.3%) Init: systemd v: 253
  default: graphical tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7
  Packages: 1783 pm: pacman pkgs: 1730 libs: 470 tools: pamac pm: flatpak
  pkgs: 39 pm: snap pkgs: 14 Shell: Zsh v: 5.9 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.28

I’ve looked through dmesg and boy is there a lot of stuff in there but nothing that seems applicable. Suggestions welcome, though!

As an addendum, and the reason I’m coming back to this, Wayland exhibits behavior that may be related; on 5.15 it simply appears to crash and return to user login, on versions above it drops straight into to the same boot log screen. In that case I can’t figure out a way to return to anything usable and end up having to hard-reboot the computer, which I always hate doing. In this case, the one suspicious thing is that dmesg suggests that wayland is using the amdgpu driver, which it should not be using. I’m not sure how to fix this, nor am I entirely sure this is the same problem.

I have neither wayland nor amd (there are a lot of topics about it), but terminals 2 to 6 work, at least on xfce and kernel 6.x. 1 is bootlog, 7 is gui.

Alright, a rubber-duck debugging update I guess:

It occurred to me that if Linux was seizing on the integrated GPU, maybe I could fix this just by disabling the integrated GPU. Turns out the answer is “yes, I can”.

I guess I now get to figure out how to convince Linux to use the discrete GPU preferentially over the integrated GPU, but anyway, immediate problem solved.

This is likely local to your system.

I am and have been using Wayland for quite a while - as I recall it - more than 12 months.

I am using the latest stable kernel (with a 6.1 backup) and I cannot replicate what you describe.

I only have one system with a dual gpu (Intel/Nvidia) - a Thinkpad T550 - using Wayland session on Plasma.

You mention the F3 combo - have you tried the other keys as well?

On my workstation I have the boot screen at TTY1 and desktop at TTY2 (runing rootless)

On my Thinkpad I have desktop at TTY1 and login screen at TTY2 (default)

If it’s of any use, on my machine (using Wayland w. Plasma) TTY1 is my usual GUI, TTY2 presents me with a GUI login prompt which doesn’t respond to any input (maybe it’s intended so you will also be able to easily run an x-session alongside your Wayland session? New upcoming feature? The choice is presented visually) and the rest offer a regular TTY.

Kernel: 6.1.38-1-MANJARO (linux61)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.