Virtual consoles not working (Ctrl+Alt+F1-6)

mate
xfce

#1

This question was not clear and did not get any proper answer. However, the issue is an important one and I will give it a go.

Moderators, please forget the Arch attitude and be more open to questions. The forum is filled with unecessary flak toward newcomers, I suppose the Manjaro community would benefit of a little more tolerance.

Coming from Ubuntu 14.04, using virtual consoles are very useful. For instance, when an app misbehaves, one can Ctrl+Alt+F1 and kill the misbehaving app from there. In Manjaro, however, the key combination takes us to a black screen. Any of the virtual consoles work (1 to 6).

I suppose is something related to systemd, not sure though. If this is the expected behaviour, how to proceed in such circumstances, where lightdm is stuck or buggy?

Or is there a way of activating the virtual consoles.

Using manjaro mate, but it seems the same behaviour happens in XFCE.


Can't access tty using Ctrl+Alt+F1,F2,F3 etc
#2

I don’t understand why so many people seem to be having this issue… CTRL+ALT+F1 takes me to my graphic desktop, CTRL+ALT+F2-7 take me to the other ttys. I’ve never had any of them take me to a black screen.

It may not be “standard” to have F1 being the X environment, and 2-7 being ttys, but I’ve never had it not work, once I got used to that quirk…


#3

It works fine for me (using OpenRC).


#4

Ditto, but sometime i lost only the first one (ctrl+alt+F1), so my first choice is generaly with F2 (& F7 back to graphic).


#5

This sounds a serious issue.

I have no good ideas to fix this, but:

  • systemd does not start virtual consoles before you try to use them. It should start one when you press ctrl+alt+f* though.
  • how systemd handles ttys can be configured in settings files located in /etc/systemd. I’d start searching for answers there.

#6

Btw, how long do you wait in one tty before switching to next? I have sometimes had significant delay in tty starting.


#7

As a workaround, you could autostart a few tty’s by default by editing /etc/systemd/logind.conf

The line you should put there is

 NAutoVTs=3

Source: http://unix.stackexchange.com/questions/56531/how-to-get-fewer-ttys-with-systemd


#8

It might also be related to your graphics driver. On some systems, this causes similar issues:

https://bbs.archlinux.org/viewtopic.php?id=168564

Solution was to add nomodeset kernel parameter


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.