Virtual box extention will not install

When i downloaded the extension for virtual box, and opened it told me to put in my password. When i did it told me it was incorrect even though that was my password

Edit: I got it from the AUR and it gives me this

VBoxManage: error: Too many extension pack names given to “extpack uninstall”

VBox installer ask for root pass - if I remember correct.

It still give me the Too many extension pack names given to “extpack uninstall”

You really shouldn’t install the extension pack from anywhere but directly from virtualbox (the reason it isn’t in the official repositories and is separate to begin with has to do with the way it is licensed). What you should do is uninstall the AUR version. Then just follow this link (this is the official link from Basically just click the link and when it asks what to do with the file tell it to open with “Oracle VM VirtualBox” That will install it correctly. You basically have to do this everytime virtualbox updates the extension pack. If you save the file to your system then you can always just double click it to launch it with VirtualBox.

Virtual Box 6.1.14 Oracle VM VirtualBox Extension Pack

For future reference the latest version is always available on their download page located here:

@cbDejaVu couldnt install the one for the virtual box website or aur version

Give this link a try. Looks like there is a way to force the upgrade.

@cbDejaVu it gives me

VBoxManage: error: Too many extension pack names given to “extpack uninstall”


VBoxManage extpack install [–replace] [–accept-license=sha256]

what are the results of this command?

vboxmanage list extpacks

@cbDejaVu extensionpacks 0


vboxmanage extpack cleanup

Then change to the directory where you downloaded the extension pack to:

Then type:

VBoxManage extpack install --replace ./Oracle_VM_VirtualBox_Extension_Pack-6.1.14.vbox-extpack

when i run the first command it tells me to put my password in and when i put it in its says it’s the wrong password

Do you type in your password every time to log into your system or do you have it autologon so that you don’t type your password each time you log into your computer?

i type it everytime i log in

Im gonna run the command as root to see if that would work
It worked with root

ok cool, yeah I think you need to use sudo to install that. So is it installed and working now?

the second command gives me this

VBoxManage: error: ‘/home/fishman/Oracle_VM_VirtualBox_Extension_Pack-6.1.14.vbox-extpack’ file not found
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component ExtPackFileWrap, interface IExtPackFile, callee nsISupports
VBoxManage: error: Context: “Install(fReplace, __null, ptrProgress.asOutParam())” at line 1422 of file VBoxManageMisc.cpp

where did you download the extension pack to? your download directory?

idk i just ran the command

did you download the extension pack from the link above? (here it is again)

go ahead and save that to your downloads directory or wherever you’d like to store it.

eyyyy it worked

cool, in the future just go to the virtualbox download page and download the latest version there. The reason it just isnt’ part of the virtualbox package is that you have to license it for commercial use so they don’t just include it all together.