Virt-Manager is not working in Mnajaro 21.1.0 Pahvo

I have been having too many issues with Virt-Manager recently.

About mid 2020 I tried this for the first time. I used Foxlet’s macOS-Simple-KVM to start a macOS Catalina VM using PopOS, which worked fine. Later on I got more interested in the Linux community and decided I really wanted to use Manjaro. Specifically with the LXLE desktop environment, as it was lightweight and speedy. I loved it!

And so I decided to build a new macOS VM. I did some research, and installed everything needed…
~$ sudo pacman -Syu (to update everything)
~$ sudo pacman -S qemu python python-pip python-wheel (from the guide; Arch version)
~$ sudo macman -S virt-manager
~$ git clone
~$ ./ --catalina
~$ ./ --add

These are the commands I use to get up and running, but for some reason it does not work in Manjaro. I even tried the following…
~$ systemctl enable libvirtd
~$ systemctl start libvirtd

At first it complained about the network. I then changed that to a bridge. Next complaint was the fact that it didn’t have permission to read ESP.qcow2. W.H.Y?

I really do apologise if I seem a bit snarky. I’ve been busy for the past day trying to move all of my stuff to my new Linux install (from Windows).

Thanks for looking. Hope someone can help me!

Is there problem just in case when you try MacOS-Simple-KVM or the same issues are there when you try any other OSes?
If I am correct,

is due to the fact that you cloned the git repo in your home directory, but generally .qcow2 images are supposed to be stored in /var/lib/libvirt/images/

I had followed this tutorial a month ago and MacOS KVM installed and worked just fine (though bottle-necked by my potato laptop :sneezing_face:)

@Shirshendu trying that now, but doesn’t look too good…
~$ su
su: Authentication failure

Hmmm…any ideas?

That’s wanting your root password, not user password. Did you set a different root password other than user password during installation of Manjaro?
In case you forgot the root password somehow,

Managed to sort out the root thing. I did the following…
~$ sudo xfce4-terminal

Thankfully I managed to get it to boot! Only issue is that it is complaining about the network now. It’s on “Virtual network ‘default’ : NAT (Inactive)”. Somehow I need to get it active. Not sure how to do so.

Just to be sure,you don’t do a sudo git clone ... ? Is the only thing I can think about it about the permission issue.

Go to edit in the virt-manager window > Connection Details > in the default connection,press the play below to activate it,be sure to check on boot to enable on startup.

1 Like

You can try -

sudo virsh net-list --all

and then

sudo virsh net-start default

Tried that, but it’s still giving me issues…
“Error starting network ‘default’: internal error: Failed to initialize a valid firewall backend”

Same issue as mentioned above^^^

You may refer to this:

I thought for sure this was going to work! It exactly described my situation, and explained a pretty good solution. But nada. Nothing.

It still shows the exact same issue. I installed firewalld…
~$ sudo pacman -S firewalld

That did not work. It showed the exact same issue. So I installed dnsmasq, even though it was not needed…
~$ sudo pacman -S dnsmasq

I restarted vibvirtd. Killed it. Enabled and started it up again, and again, with no luck.

This is a darn shame.

I even disconnected my laptop from WiFi and used Ethernet instead, still with absolutely zero luck.

All works fine, except networking for some reason.

According to the arch wiki

You just need to install dnsmasq and iptables-nft from the official repositories,then restart libvirtd

sudo systemctl restart libvirtd

that pretty much it,there is no need for firewalld.


Thank you! This did the trick!

Works perfectly well now!

1 Like

I have ebtables installed from AUR, should I uninstall that and install iptables-nft?

Thats what i had too,I just tested on my VMs and don’t see any differences,so I think you will be good with iptables-nft,plus is a official repository package instead of AUR.

1 Like

OK. Just installed iptables-nft, restarted libvirt and VMs are running fine. Thanks a lot. :grin:.

1 Like

@Zilch510 An out of context question though, are you talking about LXDE? :thinking:

Seems I was not looking right :joy:

I have the XFCE one. Here…

Also, I realise that I marked one reply as the solution, but for some reason despite there being a bridge, macOS is not actually reading an internet connection.

macOS-Simple-KVM only downloads the bare minimum to install macOS, and the rest is downloaded inside the virtual environment. But every time I click on “Install”, it says an internet connection is required, despite everything working and booting fine.