Video-Nvidia drivers stopped working after trying bumblebee hybrid drivers


Hi all! :slight_smile:

First troubleshooting post here! I’m on manjaro since january 20th and browsing the forum for a while now. Will try to get more involved in the community if I can find some time! :wink: Sorry in advance for bad English!

So, I’ve been trying to get VFIO working for a GPU passthrough for a windows VM. While doing some tweaking in my bios, it triggered Manjaro to list new drivers for both my IGP Intel HD 630 and my GPU Nvidia GTX 1070: video-hybrid-Intel-nvidia-bumblebee (prime and nouveau-bumblebee too). I decided to give it a go and uninstall video-nvidia in favor of video-hybrid-Intel-nvidia-bumblebee. After a lot of time and effort, I was able to have something barely working, but when I want to go back to only video-nvidia drivers, I can’t boot pass this error:

[FAILED] Failed to start lightdm.service

Fortunately I was able to access TTY, so I started logging everything I found interesting. I tried a lot of fixes, but nothing work. Let’s start with my logs:

From systemctl status lightdm:

● lightdm.service - Light Display Manager   
   Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
   Active: failed (Result: core-dump) since Thu 2018-02-15 20:39:36 EST; 14min ago
     Docs: man:lightdm(1)
  Process: 977 ExecStart=/usr/bin/lightdm (code=dumped, signal=SEGV)
 Main PID: 977 (code=dumped, signal=SEGV)

Feb 15 20:39:36 Main-PC systemd[1]: lightdm.service: Service hold-off time over, scheduling restart.
Feb 15 20:39:36 Main-PC systemd[1]: lightdm.service: Scheduled restart job, restart counter is at 5.
Feb 15 20:39:36 Main-PC systemd[1]: Stopped Light Display Manager.
Feb 15 20:39:36 Main-PC systemd[1]: lightdm.service: Start request repeated too quickly.
Feb 15 20:39:36 Main-PC systemd[1]: lightdm.service: Failed with result 'core-dump'.
Feb 15 20:39:36 Main-PC systemd[1]: Failed to start Light Display Manager.

Next step, I tried to run debug on lightdm:
lightdm --test-mode --debug:

[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.24.0, UID=0 PID=1361
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Registered seat module local
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Registered seat module unity
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: Monitoring logind for seats
[+0.00s] DEBUG: New seat added from logind: seat0
[+0.00s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.00s] DEBUG: Seat seat0: Starting
[+0.00s] DEBUG: Seat seat0: Creating greeter session
[+0.00s] DEBUG: Seat seat0: Creating display server of type x
[+0.00s] DEBUG: Could not run plymouth --ping: Failed to execute child process ?plymouth? (No such file or directory)
[+0.00s] DEBUG: Using VT 7
[+0.00s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.00s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+0.00s] DEBUG: XServer 0: Writing X server authority to /run/lightdm/root/:0
[+0.00s] DEBUG: XServer 0: Launching X Server
[+0.00s] DEBUG: Launching process 1366: /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.00s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.00s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.00s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.00s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+0.05s] DEBUG: Seat seat0 changes active session to 
[+0.12s] DEBUG: Process 1366 exited with return value 1
[+0.12s] DEBUG: XServer 0: X server stopped
[+0.12s] DEBUG: Releasing VT 7
[+0.12s] DEBUG: XServer 0: Removing X server authority /run/lightdm/root/:0
[+0.12s] DEBUG: Seat seat0: Display server stopped
[+0.12s] DEBUG: Seat seat0: Stopping session
[+0.12s] DEBUG: Seat seat0: Session stopped
[+0.12s] DEBUG: Seat seat0: Stopping display server, no sessions require it
[+0.12s] DEBUG: Seat seat0: Stopping; greeter display server failed to start
[+0.12s] DEBUG: Seat seat0: Stopping
[+0.12s] DEBUG: Seat seat0: Stopped
[+0.12s] DEBUG: Required seat has stopped
[+0.12s] DEBUG: Stopping display manager
[+0.12s] DEBUG: Display manager stopped
[+0.12s] DEBUG: Stopping daemon
Segmentation fault: core dumped

And this is what dmesg shows about lightdm (I’ve only pasted this line since they are all the same, the full dmesg is available on pastebin):

[    5.514851] traps: lightdm[632] general protection ip:563b92bd420b sp:7ffd4849f210 error:0 in lightdm[563b92bc1000+40000]

From there, I’ve also run down a few greps on logs, and also find something interesting from dmesg:

[    1.998565] NVRM: The NVIDIA probe routine was not called for 1 device(s).
[    1.998566] NVRM: This can occur when a driver such as: 
               NVRM: nouveau, rivafb, nvidiafb or rivatv 
               NVRM: was loaded and obtained ownership of the NVIDIA device(s).
[    1.998566] NVRM: Try unloading the conflicting kernel module (and/or
               NVRM: reconfigure your kernel without the conflicting
               NVRM: driver(s)), then try loading the NVIDIA kernel module
               NVRM: again.
[    1.998566] NVRM: No NVIDIA graphics adapter probed!

Which repeats itself 5 times, again, see full dmesg on pastebin.

I’ve tried:

systemctl enable lightdm.service
mkinitcpio -P

I can’t see nothing of interest being blacklisted in modprobe.d, my xorg.conf from mhwd are all OK
and mhwd-gpu --check and --status all are OK. It does feel like some older drivers were not correctly uninstall (so conflicting kernel module?). I think the more important error message is the NVRM one in dmesg, but I can’t find much on the interwebs and I’m starting to run out of ressources… ! Is it me or every post I find online while looking for solutions are from 2010-issh…? I rarely find more recent threads… I think I also have a problem with my web searches. It’s been like this since I’m on duckduckgo (even with using !g)…

So for now, the only thing working reliably is uninstalling every video drivers. Only my monitors connected to my IGP works though, so nothing from my GPU.

My specs right now (with default drivers):

System:    Host: Main-PC Kernel: 4.15.0-1-MANJARO x86_64 bits: 64 gcc: 7.2.1
           Desktop: N/A Distro: Manjaro Linux
Machine:   Device: desktop Mobo: Gigabyte model: H270-Gaming 3 v: x.x serial: N/A
           UEFI: American Megatrends v: F9b date: 01/10/2018
CPU:       Quad core Intel Core i7-7700 (-MT-MCP-) 
           arch: Skylake rev.9 cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 28808
           clock speeds: max: 4200 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz
           4: 800 MHz 5: 800 MHz 6: 800 MHz 7: 800 MHz 8: 800 MHz
Graphics:  Card-1: Intel HD Graphics 630 bus-ID: 00:02.0
           Card-2: NVIDIA GP104 [GeForce GTX 1070] bus-ID: 01:00.0
           Display Server: N/A driver: modesetting tty size: 80x24
Audio:     Card-1 NVIDIA GP104 High Def. Audio Controller
           driver: vfio-pci bus-ID: 01:00.1
           Card-2 Intel 200 Series PCH HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.15.0-1-MANJARO
Network:   Card: Qualcomm Atheros Killer E2500 Gigabit Ethernet Controller
           driver: alx port: d000 bus-ID: 06:00.0
           IF: enp6s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 3525.7GB (55.2% used)
           ID-1: /dev/sdb model: ST1000DM010 size: 1000.2GB
           ID-2: /dev/sda model: Crucial_CT525MX3 size: 525.1GB
           ID-3: USB /dev/sdc model: My_Passport_0820 size: 2000.4GB
Partition: ID-1: / size: 96G used: 8.1G (9%) fs: ext4 dev: /dev/sda3
           ID-2: /home size: 48G used: 4.7G (11%) fs: ext4 dev: /dev/sda1
           ID-3: /var size: 48G used: 6.3G (14%) fs: ext4 dev: /dev/sdb1
           ID-4: swap-1 size: 33.55GB used: 0.00GB (0%)
           fs: swap dev: /dev/sdb3
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 244 Uptime: 2:13 Memory: 2805.6/15990.5MB
           Init: systemd Gcc sys: 7.2.1
           Client: Shell (bash 4.4.121) inxi: 2.3.56 

If you think you need them: my dmesg log (but I removed a lot of UFW audit) and my Xorg log: “No screen found”

I’ll be able to continue troubleshooting tomorrow night, but I wanted to share the logs right now so people who are willing to help can have them (because I’m guessing this is mostly how we troubleshoot?) I’m still learning, but I learn fast!

Thank you very much in advance


Bumblebee should be what you want for your setup. Specifically intel-nvidia.
(PRIME will only work with nouveau, and the proprietary nvidia is superior)
What I can see between the logs and your inxi is that however youve gotten there, you are only loading the modesetting driver (intended for your intel) … but your nvidia card is using it. Yet nvidia module is expected.

These should get you back to a working bumblebee

sudo mhwd -r pci video-nvidia
sudo mhwd -i -pci video-hybrid-intel-nvidia-bumblebee

Please post output if it isnt a sweeping success.
(also note I am assuming you havent compiled anything manually, and used mhwd for previous installs)

[thanks for catching that @petsam]


I agree with @cscs and also first make X work and then try to work with your VM setup. You have a couple of Kernel parameters set for VM that might cause the problem or not.
Have you read this and that?
Also, you should make sure after proper re-installation of driver that you have nouveau blacklisted.

PS: @cscs you have a typo in the driver command (I => i)



Skylake and newer REQUIRED these grub flags:
acpi_osi=! acpi_osi="Windows 2009"
Otherwise did not boot/work properly.


Ok, so I’m back home and have all the evening to work on this.

First of all thank you for confirming I’m better off with intel-nvidia bumblebee drivers. On that matter I already did figure out how to make it barely work, but my issue was about going back. Since this is not my goal anymore, the problem becomes to properly set my bumblebee setup.

So I installed back the drivers using the auto command of mhwd, the only error being:

modprobe: ERROR: could not insert 'bbswitch': No such device

But since I’m not on a laptop using primus, I don’t need bbswitch, right? Because bumblebee will make it so my GPU will always be running, but not automatically sollicitated so I can eventually dedicate it to a VM for example?

The only thing I did differently than in the last days is adding the grub flags for acpi_osi (don’t see anything different yet, but I’ll keep it for now).

Bumblebeed status atm:

● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
   Active: active (running) since Fri 2018-02-16 17:40:36 EST; 35min ago
 Main PID: 598 (bumblebeed)
    Tasks: 3 (limit: 4915)
   CGroup: /system.slice/bumblebeed.service
           ├─ 598 /usr/bin/bumblebeed --use-syslog
           └─2147 /usr/lib/xorg-server/Xorg :8 -config /etc/bumblebee/xorg.conf.nvidia -configdir /etc/bumblebee/xorg.conf.d -sharevts -nolisten tcp -noreset -verbose 3 -isolateDevice PCI:01:00:0 -modulepath /usr/lib/nvidia/xorg,/usr/lib/xorg/modules

Feb 16 17:43:36 Main-PC bumblebeed[598]: [XORG] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
Feb 16 17:43:36 Main-PC bumblebeed[598]: [XORG] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
Feb 16 17:43:36 Main-PC bumblebeed[598]: [XORG] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
Feb 16 17:43:36 Main-PC bumblebeed[598]: [XORG] (WW) NVIDIA(0): Option "NoLogo" is not used
Feb 16 17:43:36 Main-PC bumblebeed[598]: [XORG] (EE) kbd: <default keyboard>: failed to set us as foreground pgrp (Inappropriate ioctl for device)
Feb 16 17:53:44 Main-PC bumblebeed[598]: [XORG] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
Feb 16 17:53:44 Main-PC bumblebeed[598]: [XORG] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
Feb 16 17:53:44 Main-PC bumblebeed[598]: [XORG] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
Feb 16 17:53:44 Main-PC bumblebeed[598]: [XORG] (WW) NVIDIA(0): Option "NoLogo" is not used
Feb 16 17:53:44 Main-PC bumblebeed[598]: [XORG] (EE) kbd: <default keyboard>: failed to set us as foreground pgrp (Inappropriate ioctl for device)

Using optirun -b none nvidia-settings -c :8, nvidia server settings open fine, the gl tests are working fine with both intel and nvidia cards. It even triggers my monitor on, but it can’t “connect” to the GPU (only trying to look for the input).

So here we are now:
So, the two monitors from my HDMI and DVI output of my intel IGP are working fine.

The problem is connected monitors to my GPU (right now I’m trying with a Samsung Syncmaster on DVI port) do not work natively:
EDIT 1: Following this, I got nvidia drivers to fully detect the monitor, but I still need to use intel-virtual-output and set the resolution and all.

I’m going to try to make it work with my main monitor now (the Asus one).

EDIT 2: I just realize the only input nvidia-settings makes me choose is “DVI-D-0”, so that is why nothing happens with my DP/HDMI monitor on my GPU. I hope it is possible to tell it to also check other ports (HDMI and DP). Because I find it a bit laggy using intel-virtual-input and a hdmi to DVI adapter for my high-end monitor… xD. And it also makes things like “redshift” apps not working on that monitor (an app to reduce screen color temperature automatically to not hurt my eyes when working in the dark (this screen is soooo bright!)).

That is for all those little tweaks that I wished to go back to video-nvidia, but if this setting is the best one (performances, easier for GPU passthrough for a windows VM friendly and all), I’m willing to make it work, but only if I have nothing to do once booted (not like right now where I need like two mins of config to have basic monitor output)

I’ve red a lot of posts suggesting editing xorg.conf but as I understand, it is obsolete now. I’m trying different combinations of file settings editing right now. Will keep this post updated.


What do you mean by that?
As of bumblebee, when you start any program with optirun it uses nvidia. It doesn’t matter on which monitor. The engine is nvidia. Do you then have a problem?
It sounds like you are fine. Or not?
Do you have separate outputs from Intel and nvidia and want to use them both? Or which exactly are your Graphics outputs?



To illustrate what I want:

Intel HD 630:
DVI = Monitor 0 (Dell, on the left)

Nvidia GTX 1070
DP1= Monitor 1 (Asus - My Main, in the center)
DVI= Monitor 2 (Samsung, on the right)

But on my GTX, I can currently only use the DVI port. I did figured out now that only plugged-in monitors in my GPU DVI-D port work. Hence, my other GPU ports (HDMI and DP) can’t be use to plugin my monitor. Right now, my PC detects nothing else than what is connected in the DVI port on my GPU. Only then I need to start intel-virtual-input and then configure the monitor to use it.


Can’t understand for sure, you don’t use unique names in your comment.
You have DVI on both GPUs and HDMI also.
Which of the outputs with monitors are working?
The default OOTB solution is to have all monitors connected on the Intel GPU outputs.
If you want something more you have to make custom xorg.conf files on /etc/X11/xorg.conf.d/ and a lot of reading, patience, pills and a lot of luck.
Good luck!! :upside_down_face::roll_eyes::sunglasses: