Video glitching 3400g

Thanks! I don’t see anything out of the ordinary in terms of hardware specs.

You could try to upgrade the BIOS from F50 to F51 perhaps.

And in your first post it said amdgpu FAILED, it doesn’t say so now.

actually id rather resolve my most pressing issue first, before updating bios
forum.manjaro(dot)org/t/dual-boot-issue/18073/3
im going to be in deep stuff if i still cant boot my windows drive for work tomorrow.
:frowning_face:
my life is rapidly deteriorating

I have an idea, but could sent the output of;

lspci -nnk | grep -A3 VGA

to check which gpu you exactly have?

thanks

Well, the solution for now, and this maybe sounds like a hassle, if you don’t need Manjaro/Linux for work tomorrow, remove the drive entirely and see if you are able to boot into Windows.

Well, my suggestion for a quick solution. Solve Manjaro it’s problem, after work, when you have more time perhaps :slight_smile: again, this is a suggestion.

07:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Picasso [1002:15d8] (rev c8)
        Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Picasso [1002:15d8]
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu

The 3400G is an APU, it’s onboard graphics chip is a Raden RX Vega 11 :slight_smile:

(Not trying to patronise of course! Or undermine your knowledge!)

ive already tried disconnecting the manjaro drive, the windows drive still wont boot. i guess a grub issue. Im creating a windows installation with WOEusb . maybe it can repair the boot? Maybe i can just reinstall windows and recover most of my stuff from backups? holy moses this is a mess.

To point you in the right direction… (Off Topic) you need to find someone who can help you remove the GRUB files/folders from your Windows 10 drive.

I unfortunately don’t know how to do it myself :frowning:

You could try is this:

It enables some features, which are not present by default.

Or it could be frequency problem:

https://wiki.archlinux.org/index.php/AMDGPU#Screen_artifacts_and_frequency_problem
set the gpu to high:

sudo echo "high" > /sys/class/drm/card0/device/power_dpm_force_performance_level

set the gpu to low:

sudo echo "low" > /sys/class/drm/card0/device/power_dpm_force_performance_level

with

watch -n 1 cat /sys/class/drm/card0/device/hwmon/hwmon*/temp1_input

you cant watch the temperatur of the gpu directly.

thanks guys i will try these and report back

I found the solution on ubuntuforums.
All i had to do is disable IOMMU in BIOS and no more artifacts!
thanks for you help, though!
:smiley:

1 Like