Very unresponsive GUIs on Thinkpad X1 Carbon Gen 7


The issue:

I just got an X1 carbon Gen 7 solely for use with linux, specifically the manjaro i3 edition. But when using certain GUI apps, they would be very unresponsive:

  • I wouldn't see any response when clicking on an object
  • making the the app fullscreen (and then reverting it) would show me the results of my click
  • some visual elements would flicker when hovering over them

Here are the apps in which I noticed this problem:

  • Chromium (and the brave browser)
  • Protonmail Bridge
  • Spotify
  • kde (explained in how I tried to resolve)

How I tried to resolve the issue

I then installed the official manjaro kde edition to see if there was a lack of support on the i3 edition.
Doing so resulted in the entire os (which is a gui) to behave like the issues I was describing previously.

I also installed the Urxvt edition to see if there was a problem with the kde edition. Urxvt did respond correctly but the apps themselves did not (chrome showed the same errors).

I checked with this arch wiki article what were the kernel modules needed for my system and verified if they were loaded ($module being the module I am checking) :

lsmod | grep $module

All the modules were loaded.

What should I do next?

P.S.
I reverted to manjaro i3 after the fact to continue my system configuration...
And if it can be of any help, here are my system specs:

$ inxi -Fz
System:
  Host: workbook Kernel: 5.4.6-2-MANJARO x86_64 bits: 64
  Desktop: i3 4.16.1-184-g00181678 Distro: Manjaro Linux
Machine:
  Type: Laptop System: LENOVO product: 20R1S04100 v: ThinkPad X1 Carbon 7th
  serial: <filter>
  Mobo: LENOVO model: 20R1S04100 v: SDK0J40697 WIN serial: <filter> UEFI: LENOVO
  v: N2QET15W (1.09 ) date: 10/18/2019
Battery:
  ID-1: BAT0 charge: 19.8 Wh condition: 52.9/51.0 Wh (104%)
CPU:
  Topology: 6-Core model: Intel Core i7-10710U bits: 64 type: MT MCP
  L2 cache: 12.0 MiB
  Speed: 1231 MHz min/max: 400/4700 MHz Core speeds (MHz): 1: 2098 2: 1566
  3: 1702 4: 1742 5: 1732 6: 1546 7: 1698 8: 1553 9: 1657 10: 1659 11: 1699
  12: 1688
Graphics:
  Device-1: Intel driver: i915 v: kernel
  Display: x11 server: X.Org 1.20.6 driver: intel unloaded: modesetting tty: N/A
  OpenGL: renderer: Mesa DRI Intel UHD Graphics (Comet Lake 3x8 GT2)
  v: 4.6 Mesa 19.3.1
Audio:
  Device-1: Intel driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.6-2-MANJARO
Network:
  Device-1: Intel driver: iwlwifi
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Intel Ethernet I219-V driver: N/A
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Drives:
  Local Storage: total: 953.87 GiB used: 96.92 GiB (10.2%)
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKKF010T8L size: 953.87 GiB
Partition:
  ID-1: / size: 921.03 GiB used: 96.92 GiB (10.5%) fs: ext4 dev: /dev/nvme0n1p2
  ID-2: swap-1 size: 16.84 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p3
Sensors:
  System Temperatures: cpu: 54.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 256 Uptime: 54m Memory: 15.31 GiB used: 2.10 GiB (13.7%) Shell: zsh
  inxi: 3.0.37

And the results of sudo journalctl -b0 -p4can be found here:
https://pastebin.com/dxXAX37Z
Also here is the result from sudo hw-probe:
https://linux-hardware.org/?probe=3422ea392b

have you also checked in log ( or any else .session.log , etc ... )

sudo journalctl -b0 -p4

Please provide system specs as output of "inxi -Fz"

Just updated my original post, thanks!

Here is the log from the command you gave me:
https://pastebin.com/dxXAX37Z

What other logs logs do you suggest I consult?

the newer intel onboard graphics work better with modesetting driver rather than the intel one.

post output:

ls -la /etc/X11/xorg.conf.d/ ; cat /etc/X11/xorg.conf.d/*.conf
mhwd -li
pacman -Qs xf86-video

this is a new generation cpu and motherboard ,

  • all acpi is not recognized
  • irq is not all taken ( add irqpoll on boot kernel command )
  • intel-spi not recognized
  • firmware ilwifi is ko

you should add on boot command
pci=noacpi acpi_enforce_resources=lax pstate=disable irqpoll

and read also this
https://wiki.archlinux.org/index.php/Lenovo_ThinkPad_X1_Carbon_(Gen_7)

maybe also try to report with

sudo hw-probe

I just added the link to the uploaded hw-probe command in my original post.
I will run it again once I configure my kernel parameters like you suggested.

from theses logs


all is not works ( detected do not means works )

trouble come from irq31 ( 100000 ...)

decode acpi is very low

loader is very long

and many errors in Xorg ( not recognized )

have you checked any update bios ?

Thanks for that!
I just checked for a bios update doing the following:

# pacman -S fwupd && mkdir -p /boot/efi/EFI
# systemctl restart fwupd.service
# fwupdmgr get-devices
20R1S04100
│
├─Thunderbolt Controller:
│     Device ID:           eb6da7e96a74ac20813c0e484d0c64977f384ba3
│     Summary:             Unmatched performance for high-speed I/O
│     Current version:     43.00
│     Vendor:              Lenovo (TBT:0x0109)
│     GUIDs:               0f11f23b-ccfc-5bac-9a41-405429734903 ← TBT-01091801
│                          7cd686e2-04fd-5868-aec9-65c2dc6eff2b ← TBT-01091801-0000:07:00.0
│     Device Flags:        • Internal device
│                          • Updatable
│                          • Requires AC power
│                          • Supported on remote server
│                          • Device stages updates
│   
├─INTEL SSDPEKKF010T8L:
│     Device ID:           3743975ad7f64f8d6575a9ae49fb3a8856fe186f
│     Summary:             NVM Express Solid State Drive
│     Current version:     L12P
│     Vendor:              Intel Corporation (NVME:0x8086)
│     Serial Number:       PHHP9376026J1P0D
│     GUIDs:               79517f86-8df8-5d6e-a18b-33f0b36a78e9 ← NVME\VEN_8086&DEV_F1A6&REV_03
│                          68db11e5-b0cf-5bc9-a94e-17e28496e505 ← NVME\VEN_8086&DEV_F1A6
│                          691bd9e3-7825-50b0-837e-2cfe70fe7e87 ← INTEL SSDPEKKF010T8L
│     Device Flags:        • Internal device
│                          • Updatable
│                          • Requires AC power
│                          • Needs a reboot after installation
│                          • Device is usable for the duration of the update
│   
├─System Firmware:
│     Device ID:           123fd4143619569d8ddb6ea47d1d3911eb5ef07a
│     Current version:     N2QET15W (1.09 )
│     Vendor:              LENOVO
│     Update Error:        UEFI Capsule updates not available or enabled
│     GUID:                230c8b18-8d9b-53ec-838b-6cfc0383493a ← main-system-firmware
│     Device Flags:        • Internal device
│                          • Requires AC power
│                          • Needs a reboot after installation
│   
└─Touchpad:
      Device ID:           2bd025a21741529fac39d6f088b9debfee7d4c9a
      Current version:     1.3.3013337
      Bootloader Version:  8.0
      Vendor:              Synaptics Inc (HIDRAW:0x06CB)
      GUIDs:               4150912a-f249-5f7e-bfa7-2d49e9c9de8c ← HIDRAW\VEN_06CB&DEV_CD8B&REV_00
                           9c27eba7-52a4-5e6f-b28c-b5d9a3991e35 ← HIDRAW\VEN_06CB&DEV_CD8B
                           19326b41-711b-5b64-89a0-6c86f3139bf1 ← SYNAPTICS_RMI\TM3467-010
                           54ed5b90-c4f7-5551-a4cc-e6ac9957a4a8 ← SYNAPTICS_RMI\TM3467
      Device Flags:        • Internal device
                           • Updatable
                           • Supported on remote server
    
# fwupdmgr get-updates
No upgrades for Thunderbolt Controller, current is 43.00: 43.00=same
No upgrades for Touchpad, current is 1.3.3013337: 1.3.3013337=same
# fwupdmgr update
No upgrades for Thunderbolt Controller, current is 43.00: 43.00=same
No upgrades for Touchpad, current is 1.3.3013337: 1.3.3013337=same

Also, I have now configured the kernel parameters like you suggested. pci=noacpi caused my keyboard to stop responding (I then proceeded to reinstall manjaro) and irqpoll disabled my wifi... I am currently running with the other two parameters (acpi_enforce_resources=lax and pstate=disable) enabled. Here is the new hw-probe report: https://linux-hardware.org/?probe=c8b365a275

part drivers video is not all solved with xorg
see https://linux-hardware.org/index.php?probe=c8b365a275&log=xorg.log

can your returns

mhwd -li
pacman -Qs xf86-video

@dglt
see https://linux-hardware.org/index.php?probe=c8b365a275&log=xorg.conf.d

the xorg.conf.d configuration files shown in the hwprobe are from /usr/share/X11/xorg.conf.d/, it threw me off at first but those outputs look normal since video-linux also installs a bunch of drivers that are not needed like amdgpu on an intel system.

@ChausseBenjamin post the outputs that @stephane requested along with this one

ls -laR /etc/X11/ ; cat /etc/X11/xorg.conf.d/*.conf

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by