Very slow after waking up pc from suspend mode. Balooo_file_extractor taking 90%+ ram

I did read those older posts but none had this baloo being slow after waking up error. And it's not a one-time thing, it happens every time I wake computer after leaving it untouched for half an hour or so.

As you can see, baloo thingy is taking 90%+ ram. and even if I kill this service, computer still stays totally unusable and had to log out to make this post.

Here is my inxi -Fxxxz output.

System:    Host: evilspark-pe627rd Kernel: 5.6.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: KDE Plasma 5.18.4 
           tk: Qt 5.14.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Micro-Star product: PE62 7RD v: REV:1.0 serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Micro-Star model: MS-16J9 v: REV:1.0 serial: <filter> UEFI: American Megatrends v: E16J9IMS.320 
           date: 02/08/2018 
Battery:   ID-1: BAT1 charge: 36.9 Wh condition: 36.9/42.4 Wh (87%) volts: 12.3/10.8 model: MSI BIF0_9 type: Li-ion 
           serial: N/A status: Full 
CPU:       Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44817 
           Speed: 3479 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 3477 2: 3433 3: 3453 4: 3492 5: 3563 6: 3442 7: 3469 
           8: 3568 
Graphics:  Device-1: Intel HD Graphics 630 vendor: Micro-Star MSI driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:591b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Micro-Star MSI driver: nvidia v: 440.82 bus ID: 01:00.0 
           chip ID: 10de:1c8d 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa 
           compositor: kwin_x11 tty: N/A 
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.0.5 direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a171 
           Sound Server: ALSA v: k5.6.7-1-MANJARO 
Network:   Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: e000 bus ID: 02:00.0 
           chip ID: 8086:24fb 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros QCA8171 Gigabit Ethernet vendor: Micro-Star MSI driver: alx v: kernel port: d000 
           bus ID: 03:00.0 chip ID: 1969:10a1 
           IF: enp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 93.74 GiB (10.1%) 
           ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: A3U0 scheme: GPT 
Partition: ID-1: / size: 191.25 GiB used: 20.79 GiB (10.9%) fs: ext4 dev: /dev/sda2 
           ID-2: /home size: 690.96 GiB used: 58.43 GiB (8.5%) fs: ext4 dev: /dev/sda4 
           ID-3: swap-1 size: 31.25 GiB used: 14.53 GiB (46.5%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 92.0 C mobo: 27.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 307 Uptime: 5h 56m Memory: 15.56 GiB used: 14.82 GiB (95.3%) Init: systemd v: 244 Compilers: gcc: 9.3.0 
           clang: 10.0.0 Shell: zsh v: 5.8 running in: yakuake inxi: 3.0.37 

My power settings are default.

Output of inxi -Fxxxz after logging out

System:    Host: evilspark-pe627rd Kernel: 5.6.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: KDE Plasma 5.18.4 
           tk: Qt 5.14.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Micro-Star product: PE62 7RD v: REV:1.0 serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Micro-Star model: MS-16J9 v: REV:1.0 serial: <filter> UEFI: American Megatrends v: E16J9IMS.320 
           date: 02/08/2018 
Battery:   ID-1: BAT1 charge: 36.9 Wh condition: 36.9/42.4 Wh (87%) volts: 12.3/10.8 model: MSI BIF0_9 type: Li-ion 
           serial: N/A status: Full 
CPU:       Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44817 
           Speed: 1600 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 1600 2: 1600 3: 1600 4: 1600 5: 1600 6: 1600 7: 1600 
           8: 1600 
Graphics:  Device-1: Intel HD Graphics 630 vendor: Micro-Star MSI driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:591b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Micro-Star MSI driver: nvidia v: 440.82 bus ID: 01:00.0 
           chip ID: 10de:1c8d 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa 
           compositor: kwin_x11 tty: N/A 
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.0.5 direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a171 
           Sound Server: ALSA v: k5.6.7-1-MANJARO 
Network:   Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: e000 bus ID: 02:00.0 
           chip ID: 8086:24fb 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros QCA8171 Gigabit Ethernet vendor: Micro-Star MSI driver: alx v: kernel port: d000 
           bus ID: 03:00.0 chip ID: 1969:10a1 
           IF: enp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 79.31 GiB (8.5%) 
           ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: A3U0 scheme: GPT 
Partition: ID-1: / size: 191.25 GiB used: 20.77 GiB (10.9%) fs: ext4 dev: /dev/sda2 
           ID-2: /home size: 690.96 GiB used: 58.43 GiB (8.5%) fs: ext4 dev: /dev/sda4 
           ID-3: swap-1 size: 31.25 GiB used: 111.5 MiB (0.3%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 62.0 C mobo: 27.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 291 Uptime: 6h 21m Memory: 15.56 GiB used: 2.91 GiB (18.7%) Init: systemd v: 244 Compilers: gcc: 9.3.0 
           clang: 10.0.0 Shell: zsh v: 5.8 running in: yakuake inxi: 3.0.37 

Hi,

I'm a kde user, but I don't use baloo, to avoid some problem like your actual problem.

I hope it will be helpful, first to know the statu, second point to disable baloo, and last reboot your device

(lifebook-wu2) $ balooctl status
Baloo is currently disabled. To enable, please run balooctl enable (on my computer)

lifebook-wu2) $ balooctl disable
Disabling the File Indexer, then reboot and launch balooctl status

Look in the kde system settings, disable some option, see below

1 Like
balooctl disable

I was hoping for the solution which don't require disabling baloo. But found none. So I totally disabled it.

Here's the guide on how to totally disable it.

How To Completely Disable Baloo.

Disable baloo in System Settings -> Search -> Uncheck Enable File Search

Then issue these commands:

balooctl stop
balooctl suspend
balooctl disable

edit the following file:

~/.config/baloofilerc 

Add these lines:

[Basic Settings]
Indexing-Enabled=false

Remove all unneeded baloo index files if they weren’t deleted automatically when baloo was disabled.

They are stored at:

 ~/.local/share/baloo/

From the ArchWiki:

Removing baloo_file

Baloo_file uses a lot of resources and slows down computers. It also increases power consumption on laptops. While it cannot be removed due to dependencies issues, it is however possible to deactivate it until the next update. As root, type:

killall baloo_file ; mv /usr/bin/baloo_file /usr/bin/baloo_file.bak ; echo '#!/bin/sh' > /usr/bin/baloo_file

Add this line to a pacman hook file, to disable baloo after every update so it is not automatically re-enabled.

The baloo file search feature has been much improved in KDE. However, it is still not my favorite search engine and I would rather have it permanently disabled. According to the ArchWiki baloo cant be uninstalled, and it may be automatically re-enabled during a system upgrade.

I have written a pacman hook to automatically disable baloo again after every system upgrade.

Here is the pacman hook:

/usr/share/libalpm/hooks/disable-baloo.hook


[Trigger]
Type = Package
Operation = Upgrade
Target = /usr/bin/baloo_file

[Action]
Description = Disable baloo file indexer after every upgrade operation
When = PostTransaction
Exec = /bin/sh -c 'killall baloo_file ; mv /usr/bin/baloo_file /usr/bin/baloo_file.bak ; echo '#!/bin/sh' > /usr/bin/baloo_file'

Install the recoll search engine (or any other suitable alternative) in place of baloo once baloo is fully disabled.

I've marked the below answer as the solution to your question as it is by far the best answer you'll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

:innocent:
P.S. In the future, please mark a solution like this:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well.
P.P.S. I've also removed "Solved" from the title after doing that as our forum software works just a bit more efficient than most of them out there!

Thanks for the help. My first time here so was not much clear on how everything works.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by