Very new to Manjaro. Need help with text and HDD issues

Hello, I got Manjaro a few days ago which is my first ever Linux distro and I’m loving it. Though, I got some issues:

  1. I have a 1TB HDD, and I need to mount it every time I boot the computer else I can’t access it. I also would like to make the 1TB HDD show up under the “devices” section in Dolphin. I only see my 2 SSD partitions under devices and that’s it. Do I need to set up auto mounting?

  2. Some text is weird and squished from the sides. On Discord for example, the whole program just feels horizontally squished and it really throws me off. Desktop text is also weird. Again, with Discord, the text below the desktop icon is in italic and jagged. This isn’t really critical, but it just annoys me that the text is all over the place. Another example of this is the start menu. Certain options are also just “squished” and jagged there.
    I really hope I’m posting in the right place. Bear with me, I’m super new to Linux overall so I might not understand some stuff :slight_smile:

1 Like

In System Settings there are various sub-menus. For the HDD try going into Removable Storage > Removable Devices and setting automount options. Remember to hit “apply” at bottom right. For your Font issues go into the Fonts sub-menu and choose your preferred fonts from the options there. Go through this section thoroughly, there are lots of options for fonts, regular, italic etc etc. Also there make sure anti-aliasing is enabled and sub-pixel rendering is set to RGB with slight hinting and 96dpi setting. Play around and see how you get on. Good luck! :grin:


Can you check your fstab and see if your hdd is mounted there? I had a similar issue with a ssd and hdd drive combo. My 1tb hdd was still formatted ntfs so I had to format it ext 4 and then I named it “data” and added it to my fstab so it gets mounted as data at every boot



I know that Thunar will show partitions mounted to /media/* under Devices, i suppose Dolphin does the same.

1 Like

Just checked it. Kinda doubt it but at the same time no idea at all. I have a /boot/efi NTFS and just a “/” with ext4. Maybe the NTFS is the HDD? There’s also a “tmpfs” but no idea what that is.

It worked, but it still doesn’t show under “Devices”.

Just checking: what directory do you make your partition mount to?

Suppose the same directory as on the guide. The data backup one.

If you strictly followed the tutorial, right.
But as i mentioned, you may need to have it mounted to /media/* in order for it to show under Devices, rather than under /data/*.

Yup, I strictly followed the guide to have at least a temporary band-aid fix for the problem.

Not sure I follow. I did some digging, is /run/media what you have in mind? It’s in the 90GB partition of my SSD and it’s not the “/” partition. And if it is the case, do I follow the tutorial but change the directories in the commands accordingly? :slight_smile:

No, i do mean /media. By convention, /run/media is usually for non-automated mount points, like USB sticks.
Instead of /data/backup, mount to /media/backup.

Alright, I replicated the commands of the tutorial but replaced /data/backup with /media/backup. It worked just fine with another directory, but it seems like the HDD still isn’t under “devices” in the sidebar on Dolphin.