Very Long Start up time

I really have very long boot time and it seems getting longer and longer, maybe someone can assist me about this. I tried to seek solutions over the past forum questions but nothing help.


    Startup finished in 3.065s (firmware) + 11.556s (loader) + 20.103s 
    (kernel) + 37.838s (userspace) = 1min 12.564s reached after 37.320s in userspace

systemd-analyze blame

      14min 32.691s pkgfile-update.service                                                   
      7min 7.868s updatedb.service                                                         
      53.090s man-db.service                                                           
      17.614s systemd-journal-flush.service                                            
      13.296s lvm2-monitor.service                                                     
      12.424s dev-sda2.device                                                          
      10.265s dev-loop6.device                                                         
       7.706s polkit.service                                                           
       7.558s snapd.service                                                            
       5.896s systemd-rfkill.service                                                   
       5.150s avahi-daemon.service                                                     
       5.150s bluetooth.service                                                        
       4.976s systemd-logind.service                                                   
       4.301s systemd-udevd.service                                                    
       2.969s ModemManager.service                                                     
       2.852s ldconfig.service                                                         
       2.372s NetworkManager.service                                                   
       2.144s systemd-tmpfiles-setup-dev.service                                       
       2.015s systemd-sysusers.service                                                 
       2.014s apparmor.service                                                         
       2.012s dev-disk-by\x2duuid-012b2228\x2dda15\x2d4a81\x2d861d\x2df61455e3e0d2.swap
       1.883s logrotate.service                                                        
       1.794s var-lib-snapd-snap-core18-1988.mount                                     
       1.722s var-lib-snapd-snap-core18-1997.mount                                     
       1.584s systemd-tmpfiles-clean.service                                           
       1.535s systemd-fsck@dev-disk-by\x2duuid-75A5\x2d8B67.service                    
       1.510s udisks2.service                                                          
       1.423s var-lib-snapd-snap-flutter-62.mount                                      
       1.099s systemd-modules-load.service                                             
        908ms user@1000.service                                                        
        906ms dev-loop5.device                                                         
        906ms NetworkManager-wait-online.service                                       
        875ms snapd.apparmor.service                                                   
        588ms systemd-random-seed.service                                              
        556ms systemd-journal-catalog-update.service                                   
        537ms wpa_supplicant.service                                                   
        520ms systemd-tmpfiles-setup.service                                           
        514ms tlp.service                                                              
        454ms systemd-timesyncd.service                                                
        453ms dev-hugepages.mount                                                      
        451ms dev-mqueue.mount                                                         
        449ms sys-kernel-debug.mount                                                   
        447ms sys-kernel-tracing.mount                                                 
        447ms modprobe@drm.service                                                     
        446ms lm_sensors.service                                                       
        431ms kmod-static-nodes.service                                                
        428ms modprobe@configfs.service                                                
        425ms modprobe@fuse.service 

inxi -Fazy

  Kernel: 5.4.105-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=8d3c71fe-2d9a-4aa7-9fd0-0de4dae0023e rw quiet acpi_backlight=none 
  apparmor=1 security=apparmor 
  resume=UUID=012b2228-da15-4a81-861d-f61455e3e0d2 udev.log_priority=3 
  Desktop: KDE Plasma 5.21.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Hewlett-Packard product: HP EliteBook 8470p 
  v: A1029D1102 serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: Hewlett-Packard model: 179B v: KBC Version 42.38 serial: <filter> 
  UEFI: Hewlett-Packard v: 68ICF Ver. F.74 date: 04/11/2019 
  Info: Dual Core model: Intel Core i5-3320M bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  cache: L2: 3 MiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20760 
  Speed: 1197 MHz min/max: 1200/3300 MHz Core speeds (MHz): 1: 1197 2: 1198 
  3: 1197 4: 1196 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Vulnerable: No microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Thames [Radeon HD 7550M/7570M/7650M] vendor: Hewlett-Packard 
  driver: radeon v: kernel bus-ID: 01:00.0 chip-ID: 1002:6841 class-ID: 0300 
  Device-2: Primax HP HD Webcam [Fixed] type: USB driver: uvcvideo 
  bus-ID: 1-1.3:4 chip-ID: 0461:4dfe class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: ati,radeon unloaded: modesetting alternate: fbdev,vesa 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4") 
  s-diag: 485mm (19.1") 
  Monitor-1: LVDS res: 1600x900 hz: 60 dpi: 131 size: 310x174mm (12.2x6.9") 
  diag: 355mm (14") 
  OpenGL: renderer: AMD TURKS (DRM 2.50.0 / 5.4.105-1-MANJARO LLVM 11.1.0) 
  v: 3.3 Mesa 20.3.4 compat-v: 3.1 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
  chip-ID: 8086:1e20 class-ID: 0403 
  Device-2: AMD Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series] 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
  chip-ID: 1002:aa90 class-ID: 0403 
  Sound Server-1: ALSA v: k5.4.105-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.23 running: no 
  Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard 
  driver: e1000e v: 3.8.7-NAPI port: 5020 bus-ID: 00:19.0 chip-ID: 8086:1502 
  class-ID: 0200 
  IF: eth0 state: down mac: <filter> 
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi 
  v: kernel port: 4000 bus-ID: 25:00.0 chip-ID: 8086:0085 class-ID: 0280 
  IF: wlan0 state: up mac: <filter> 
  Device-1: Broadcom HP Portable SoftSailing type: USB driver: btusb v: 0.8 
  bus-ID: 3-1.6:3 chip-ID: 0a5c:21e1 class-ID: fe01 serial: <filter> 
  Report: This feature requires one of these tools: hciconfig/bt-adapter 
  Local Storage: total: 298.09 GiB used: 65.28 GiB (21.9%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital 
  model: WD3200LPVX-22V0TT0 size: 298.09 GiB block-size: physical: 4096 B 
  logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A01 
  scheme: GPT 
  ID-1: / raw-size: 289.49 GiB size: 283.94 GiB (98.09%) 
  used: 64.92 GiB (22.9%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.31 GiB used: 363.4 MiB (4.3%) 
  priority: -2 dev: /dev/sda3 maj-min: 8:3 
  System Temperatures: cpu: 58.0 C mobo: 53.0 C gpu: radeon temp: 53.5 C 
  Fan Speeds (RPM): N/A 
  Processes: 198 Uptime: 7h 40m wakeups: 1 Memory: 3.78 GiB 
  used: 1.21 GiB (32.1%) Init: systemd v: 247 tool: systemctl Compilers: 
  gcc: 10.2.0 clang: 11.1.0 Packages: 1529 pacman: 1519 lib: 431 flatpak: 6 
  snap: 4 Shell: Bash v: 5.1.0 running-in: konsole inxi: 3.3.03 

Any Commands I needed to do so, will do it right away.

You have a lot of services active that you might not need.

  1. Start by disabling the updatedb.service and doing a sudo updatedb whenever you need to use the locate command and you’re not finding what you need:

    systemctl stop updatedb
    systemctl disable updatedb
  2. Then go through your services and use the same system as above to disable any services you don’t need. (E.G. If you don’t use LVM2, disable that, if no modem, disable ModemManager etc etc)

  3. The reason I migrated from Ubuntu to Manjaro are the snaps: If you have a choice, don’t install the snap version of an application but use the native one instead and remove anything snap from your system! :angry:


1 Like

Thank Boss, I’ll take a look on any improvements from disabling them. Thanks a lot.

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.