Vertical mouse not recognized



I purchased a generic vertical USB mouse, but it is not being recognized when I run lsusb on Manjaro XFCE. I tried installing xf86-input-synaptics, but that did not help. Does anyone have any suggestions? Thanks in advance.


I’d recommend you open a terminal and run something like

journalctl -ef

And watch what messages flow by while you plug it in. Being a mouse, you shouldn’t need to plug it into anything other than a usb 2.x port. Don’t waste a sub 3.x port on it.

Try it in another machine just to be sure it works.


Thanks for your reply, jsamyth. I tried doing as you instructed but all I get are a stream of UFW Audits. There doesn’t appear to be any recognition of the mouse when I plug it in. I have also tried it on a system running deepinOS, and deepin didn’t recognize it either. According to the ad, it has Linux support, but I’m beginning to think that may not be the case. I’m going to test it later today when I have access to a Windows machine. That’ll help. Will write more when I have more info.


I have this mouse: Anker Optical Vertical Wired USB mouse
regardless of the vertical bit, any generic mouse should just work

Hope it will fail on Windows too and spare you any problems getting it replaced!