Veracrypt wxwidgets - assertion failed

On actual Manjaro XFCE (stable) VeraCrypt 1.25.9-3 issues repeated messages “An assertion failed” as soon as I start “creating a volume”. Before the last update such messages also appeared immediately upon “mounting a volume”. This is related to Español “Problema Veracrypt” (19.Jul.2022).

Message: An assertion failed!
/usr/src/debug/wxWidgets-3.2.0/src/common/sizer.cpp(2267): assert "CheckSizerFlags(!((flags) & (wxALIGN_RIGHT)))" failed in DoInsert(): wxALIGN_RIGHT will be ignored in this sizer: only vertical alignment flags can be used in horizontal sizers


If you're an end user running a program not developed by you, please ignore this message, it is harmless, and please try reporting the problem to the program developers.

You may also set WXSUPPRESS_SIZER_FLAGS_CHECK environment variable to suppress all such checks when running this program.

If you're the developer, simply remove this flag from your code to avoid getting this message. You can also call wxSizerFlags::DisableConsistencyChecks() to globally disable all such checks, but this is strongly not recommended.

[1] wxBoxSizer::DoInsert(unsigned long, wxSizerItem*)
[2] wxEvtHandler::ProcessEventIfMatchesId(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&)
[3] wxEvtHandler::SearchDynamicEventTable(wxEvent&)
[4] wxEvtHandler::TryHereOnly(wxEvent&)
[5] wxEvtHandler::ProcessEventLocally(wxEvent&)
[6] wxEvtHandler::ProcessEvent(wxEvent&)
[7] wxEvtHandler::SafelyProcessEvent(wxEvent&)
[8] g_signal_emit_valist
[9] g_signal_emit
[10] g_closure_invoke
[11] g_signal_emit_valist
[12] g_signal_emit
[13] g_signal_emit_valist
[14] g_signal_emit
[15] g_cclosure_marshal_VOID__BOXEDv
[16] g_signal_emit_valist
[17] g_signal_emit
[18] gtk_event_controller_handle_event
[19] g_closure_invoke
[20] g_signal_emit_valist
[21] g_signal_emit
[22] gtk_main_do_event
[23] g_main_context_dispatch
[24] g_main_loop_run
[25] gtk_main
[26] wxGUIEventLoop::DoRun()
[27] wxEventLoopBase::Run()
[28] wxAppConsoleBase::MainLoop()
[29] wxEntry(int&, wchar_t**)
[30] __libc_start_main

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text


There are posts here already, dealing with wxwidgets update.

There is also this info on the Arch site re the same issue:

Arch Linux - News: wxWidgets 3.2 update may need manual intervention

right now the top message from July 14th

Dear Nachlese,

it is a fresh installation from media manjaro_xfce_21.3.2 - no wxgtk2 was ever present. I have another older installation also kept updated, on that I noticed recently the error popup described on

As I am rather a user and not building Veracrypt, I’m trying to report: Like cfinnberg on the spanish thread I noticed that the initially appearing message pop-up did not appear any more after a Veracrypt package (community) update to 1.25.9-3.

Now I find that not only upon the first hit function “Mount” (where it meanwhile disappeared) but also on the second important “Create Volume” such a message is displayed.

Please, be more specific what I am to do: I see on a distinct package a message advising to notify the developers upon invocing function 1, after the update it’s gone, but appears upon starting function 2, which I had not tried before…
To me this looks as if something was already done on the Veracrypt package, but not all occurrences fixed. Do I need to write to the Veracrypt developer, or to the packer who provides the Manjaro package?

Thank you,

I don’t know really - the package is imported as is from Arch - and they use whatever source they use.
So, there is no packager for the Manjaro package … it’s the same as in Arch.

If you're an end user running a program not developed by you, please ignore this message, it is harmless, and please try reporting the problem to the program developers.

so they would be the people to talk to

I didn’t catch that - I thought there was a problem with wxwidgets.
Can’t help.

(Moderator edit)

Sorry, it came as a gui pop-up window - providing a function “copy to clipboard” - I did not really have a clue how to present that. A screenshot from a full HD monitor easily could have gone beyond all borders… Your formatting is definitely more conclusive, thanks.

There is a bug filed for the archlinux veracrypt package pending it’s solution. If I look at the message that I got displayed, it tells me - the user - that I may ignore it, as the suggested solution is to disable certain checks, which trigger these messages.

The message dialogue itself offers a checkbox for disabling them for me.

I have the same error message on Manjaro KDE, when i click “select device”.
But with a click on continue button, atleast it let me still use the GUI.

Im using the normal English client… why you think this is related to Espanol Language?

See if this works in the meantime.


  1. First, unmount all volumes and completely exit VeraCrypt (including the tray icon.)

  2. Next, apply the following:

cp -v /usr/share/applications/veracrypt.desktop ~/.local/share/applications

sed -i 's/Exec=veracrypt/Exec=env\ WXSUPPRESS_SIZER_FLAGS_CHECK=1\ veracrypt/g' ~/.local/share/applications/veracrypt.desktop

update-desktop-database -q
  1. Then try opening VeraCrypt from your application launcher again.

Modified from this bug report. Hopefully it should permanently suppress the (harmless) message until there is a legitimate patch/bugfix applied.

1 Like

In my case I don’t get any message when mounting (maybe it depends on the type of the volume being mounted), but I still get messages on volume creation and Select Device dialogs/buttons.

The developers haven’t still reacted to the bug report a month ago. From what I can see, the main developer has not made any commits or changes to the project from the end of March (and before that there were commits every few days).

So probably this is not going to get a solution soon if the packager doesn’t add patches without waiting for upstream.

He is referring to a post in the Spanish speaking forum part, where there is almost the same problem. It is not that the problem is related to the Spanish language somehow.

Did you try the above workaround?

No, I don’t need it. I use only one volume and I don’t get any errors mounting it.

I’m sure that workaround works, but it’s a workaround, not a solution. The Veracrypt developers have to fix the source code so no workaround is needed. That is what I meant in my message, when talking about the solution.

1 Like

Your Work around is not needed… there is a easy suppress this error option in the GUI.


I just hope, there is a fix coming soon… even its not a big issue, it should be fixed… i donated alot money to this developers, they should get their stuff together.

If checking that option works, what is the point of this thread? :thinking: It sounds like this issue is “solved” by choosing “suppress this message”. No more redundant warning message when using VeraCrypt.

There is still a error in background… to suppress it, shouldnt be the right way.

That’s why I wrote:

It’s a harmless (but annoying) message, according to other users. This can hide it until the issue is resolved upstream.

The alternative is to keep dismissing this annoying message when you try to use VeraCrypt normally, which isn’t a permanent solution either. :person_shrugging: