Vega 64 installation problems

drivers
amdgpu
#41

from arch wiki:

/etc/X11/xorg.conf.d/20-amdgpu.conf
Section "Device"
     Identifier "AMD"
     Driver "amdgpu"
 EndSection
/etc/X11/xorg.conf.d/10-screen.conf
Section "Screen"
       Identifier     "Screen"
       DefaultDepth    24
       SubSection      "Display"
               Depth   24
       EndSubSection
EndSection

are these not necessary for amdgpu? did you reinstall free drivers yet?

0 Likes

#42

I have installed the free drivers, rebooted, and nothing new.

0 Likes

#43

Found at least 2 other guys who had that screen stuck at 640x480 out of the blue …

https://rog.asus.com/forum/showthread.php?86754-PG278Q-stuck-at-640x480

that won’t hurt, but it will most likely also not solve anything as those parts are already working.

I would try to use another Display port cable and/or try to temporarily get another screen to check if that one works.

0 Likes

#44

Please check your BIOS for any relevant option, or maybe reset BIOS to default settings. If you do, you may need to boot from Live ISO installer to get into your installation.

1 Like

#45

Connecting to my tv with hdmi it works perfectly

1920x1080

0 Likes

#46

that is good and bad at the same time.
The card and driver work fine.
Your screen or display port cable seem to cause the problem. Do you have any settings on your screen that you can change to see if it makes a difference?

0 Likes

#47

found a post with someone able to get it working by adding the mode manually with xrandr
make sure this matches your dp designation

xrandr --newmode "2560x1440" 241.5 2560 2608 2640 2720 1440 1443 1448 1481 -hsync +vsync
xrandr --addmode DisplayPort-1 2560x1440
xrandr --output DisplayPort-1 --mode 2560x1440

https://ubuntuforums.org/showthread.php?t=2365956

NOTE: your original output of xrandr --props it shows you were connected to displayport1, if you moved the connection then you would have to edit the commands to match

1 Like

#48

Where is Xrandr located, or how do you edit it.

0 Likes

#49

you can simply enter those commands in terminal anywhere but make sure to use the complete lines.

you should just make sure that the Display Port number is the same that is shown in xrandr --props as connected.

0 Likes

#50

Holy sh*t, you guys are the absolute best. I absolutely love this community, and appreciate all the help I got today.

1 Like

#51

Though it resets after I rebooted. Any permanent xrandr fix?

0 Likes

#52

hey, even a blind squirrel can find a nut, eventually… :sunglasses: (im speaking of myself)

glad to hear it worked out for you.

yep, display setup script.

sudo nano /usr/share/sddm/scripts/Xsetup
add these contents

#!/bin/sh

xrandr --newmode "2560x1440" 241.5 2560 2608 2640 2720 1440 1443 1448 1481 -hsync +vsync
xrandr --addmode DisplayPort-1 2560x1440
xrandr --output DisplayPort-1 --mode 2560x1440

save/exit, that should set it on each boot.

@BS86 , would it be necessary to add the mode every boot or is adding it once enough and then having it just set to
xrandr --output DisplayPort-1 --mode 2560x1440
at boot? would the mode then also be listed in monitor settings and set as default eliminating the need for a script?

0 Likes

#53

Thanks a bunch

1 Like

#54

By xrandr using Xorg conf with a monitor section only should do.
Properly finding correct data

First we run gtf or cvt to get the Modeline for the resolution we want

If you use this, you won’t/shouldn’t need the xrandr Xsetup script.

2 Likes

closed #55

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes