Vega 64 installation problems

drivers
amdgpu

#1

So I just got my Vega 64, and set it up correctly. But when I started my computer and booted into Manjaro (Dualboot with Windows 10) my resolution is locked to
640x480
I have also clicked auto-install open-source drivers in hardware configuration.

I have followed this thread

But I cannot get it to work.

Here is my gpu configuration.

Graphics:
Device-1: AMD Vega 10 XL/XT [Radeon RX Vega 56/64] driver: amdgpu
v: kernel
Display: x11 server: X.Org 1.20.3 driver: amdgpu,ati
unloaded: modesetting resolution: 640x480~60Hz
OpenGL:
renderer: Radeon RX Vega (VEGA10 DRM 3.27.0 4.20.7-1-MANJARO LLVM 7.0.1)
v: 4.5 Mesa 18.3.2


#2

what are the exact steps that you did on your system?

As long as you run Kernel 4.19 or newer, you should not have to do anything special to get it working like intended. (My Vega64 runs well with a default Manjaro installation)


#3

Before I installed my Vega 64, I uninstalled the drivers from my old gtx 960. Shut down my pc. Installed the new Vega 64, booted it up as normal. Saw that my resolution was small, and went to hardware manager, clicked auto install open-source drivers. Rebooted. Did not change a thing. Looked up “Manjaro vega 64 drivers”, found the other post. Used this command
sudo pacman -S xf86-video-amdgpu

Rebooted, did not work

Ran the command that you suggested
sudo pacman -S linux-amd-staging linux-amd-staging-headers

And it said this
error: target not found: linux-amd-staging
error: target not found: linux-amd-staging-headers

And then I made this post.


#4

good, that did not “destroy” anything.

go to /etc/X11/ and check for a file named xorg.conf.
If it is there, delete it.
Go into /etc/X11/xorg.conf.d/ and check if there are graphical configs there that still reference Nvidia - if there are, post them here for instructions.


#5

xorg.conf does not exist. And no reference of Nvidia in xorg.conf.d. Only a keyboard conf


#6

how do you connect the screen?

Do you set any non-default parameters in grub?
What is the full inxi output for your system?


#7

I have my screen connected with Displayport

I did not change Grub from what I can remember


#8

can you try to boot from a Manjaro KDE 18.0.2 Live USB Stick and check if it works there?

and please post the inxi as text here in the forum. It should never be 500kB big - this looks fishy.


#9

Live USB goes up to 1024x768.
I wrote ‘inxi --debug 20’ in the terminal.
Do you just want the ‘inxi’ output?

CPU: 6-Core AMD Ryzen 5 2600X (-MT MCP-)
speed/min/max: 3809/2200/3600 MHz Kernel: 4.20.7-1-MANJARO x86_64 Up: N/A
Mem: 1350.5/16053.4 MiB (8.4%) Storage: 4.81 TiB (21.3% used) Procs: 337
Shell: bash 5.0.0 inxi: 3.0.30


#10

and you used a 18.0.2 Live Boot? Older ones don’t have the required kernel and mesa.
When the 18.0.2 Live version also does not work, it looks like an issue with the screen or the display port cable.
If 18.0.2 live version would work, it would be an issue with a configuration on your installed version.

or maybe @Tids knows more.


#11

Yes, I used 18.0.2 Live USB


#12

those packages are not in manjaro’s repo, these 2 are in AUR

linux-amd-staging-drm-next-git
linux-amd-staging-drm-next-git-headers

which i would think you wouldnt need?

can you post full output of
pacman -Qs nvidia
(remove any nvidia packages if listed, do not remove any that start with mhwd-*)
pacman -Qs amdgpu
inxi -FGxxxz
xrandr --listmonitors
mhwd -li
ls -la /etc/X11/mhwd.d
ls -la /etc/X11/xorg.conf.d


#13

I removed all the Nvidia packeges, exept those I should not remove.

Here is my output.

 pacman -Qs amdgpu
local/mhwd-amdgpu 1.2.1-1
    MHWD module-ids for amdgpu
local/xf86-video-amdgpu 18.1.0-1 (xorg-drivers)
    X.org amdgpu video driver
[nikolai@nikolai-pc ~]$ inxi -FGxxxz
System:
  Host: nikolai-pc Kernel: 4.20.7-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: KDE Plasma 5.14.5 tk: Qt 5.12.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: Micro-Star model: B450 GAMING PLUS (MS-7B86) v: 1.0 
  serial: <filter> UEFI: American Megatrends v: 1.40 date: 12/21/2018 
CPU:
  Topology: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP 
  arch: Zen+ rev: 2 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 86420 
  Speed: 2397 MHz min/max: 2200/3600 MHz boost: enabled 
  Core speeds (MHz): 1: 2923 2: 2608 3: 1908 4: 2054 5: 2778 6: 2996 
  7: 1803 8: 1724 9: 1891 10: 2000 11: 2004 12: 2194 
Graphics:
  Device-1: AMD Vega 10 XL/XT [Radeon RX Vega 56/64] 
  vendor: Sapphire Limited driver: amdgpu v: kernel bus ID: 1e:00.0 
  chip ID: 1002:687f 
  Display: x11 server: X.Org 1.20.3 driver: amdgpu,ati 
  unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 
  resolution: 640x480~60Hz 
  OpenGL: 
  renderer: Radeon RX Vega (VEGA10 DRM 3.27.0 4.20.7-1-MANJARO LLVM 7.0.1) 
  v: 4.5 Mesa 18.3.2 direct render: Yes 
Audio:
  Device-1: AMD driver: snd_hda_intel v: kernel bus ID: 1e:00.1 
  chip ID: 1002:aaf8 
  Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 20:00.3 chip ID: 1022:1457 
  Device-3: Corsair type: USB driver: hid-generic,snd-usb-audio,usbhid 
  bus ID: 1-1:2 chip ID: 1b1c:0a18 serial: <filter> 
  Sound Server: ALSA v: k4.20.7-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8168 v: 8.045.08-NAPI port: f000 
  bus ID: 18:00.0 chip ID: 10ec:8168 
  IF: enp24s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 4.81 TiB used: 1.04 TiB (21.7%) 
  ID-1: /dev/sda vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB 
  speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 0001 
  scheme: GPT 
  ID-2: /dev/sdb type: USB model: General USB Flash Disk size: 30.02 GiB 
  serial: <filter> rev: 1100 scheme: MBR 
  ID-3: /dev/sdc vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB 
  speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 0001 
  scheme: GPT 
  ID-4: /dev/sdd vendor: Samsung model: SSD 850 EVO 1TB size: 931.51 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: 2B6Q scheme: GPT 
  ID-5: /dev/sde vendor: Samsung model: SSD 850 EVO 250GB 
  size: 232.89 GiB speed: 6.0 Gb/s serial: <filter> rev: 2B6Q scheme: GPT 
RAID:
  Supported md-raid types: raid0 
  Device-1: md0 type: mdraid status: active Components: 
  online: sdc1~c1 sda1~c0 
  Info: raid: raid-0 blocks: 3906764800 report: N/A chunk size: 512k 
  super blocks: 1.2 
Partition:
  ID-1: / size: 219.28 GiB used: 56.16 GiB (25.6%) fs: ext4 
  dev: /dev/sde2 
  ID-2: swap-1 size: 8.80 GiB used: 10.5 MiB (0.1%) fs: swap 
  dev: /dev/sde3 
Sensors:
  System Temperatures: cpu: 39.6 C mobo: N/A gpu: amdgpu temp: 31 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1170 
Info:
  Processes: 322 Uptime: 1h 01m Memory: 15.68 GiB used: 3.64 GiB (23.2%) 
  Init: systemd v: 239 Compilers: gcc: 8.2.1 clang: 7.0.1 Shell: bash 
  v: 5.0.0 running in: konsole inxi: 3.0.30 
[nikolai@nikolai-pc ~]$ xrandr --listmonitors
Monitors: 1
 0: +*DisplayPort-1 640/169x480/127+0+0  DisplayPort-1
[nikolai@nikolai-pc ~]$ mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
         network-r8168            2016.04.20                true            PCI


Warning: No installed USB configs!
[nikolai@nikolai-pc ~]$ ls -la /etc/X11/mhwd.d
totalt 12
drwxr-xr-x 2 root root 4096 11 feb 11:01 .
drwxr-xr-x 5 root root 4096 28 okt 20:46 ..
-rw-r--r-- 1 root root    0 20 dec 11:09 nvidia.conf.nvidia-xconfig-original
[nikolai@nikolai-pc ~]$ ls -la /etc/X11/xorg.conf.d
totalt 16
drwxr-xr-x 2 root root 4096 11 feb 11:01 .
drwxr-xr-x 5 root root 4096 28 okt 20:46 ..
-rw-r--r-- 1 root root  304  5 dec 17:42 00-keyboard.conf

#14

yikes, ok please edit post and put 3 backtics ``` above and below the posted terminal output so its formatted properly


#15

There you go


#16

can you do this and reboot
sudo pacman -S xf86-video-amdgpu amdgpu-experimental

dont reboot if there are errors, post errors


#17

Done, zero errors, but nothing has changed.


#18

ok, please post
ls -la /etc/modprobe.d/
cat /etc/modprobe.d/*
cat /etc/modules-load.d/*


#19
[nikolai@nikolai-pc ~]$ ls -la /etc/modprobe.d/
totalt 28
drwxr-xr-x   2 root root  4096 11 feb 09:40 .
drwxr-xr-x 107 root root 12288 11 feb 16:03 ..
-rw-r--r--   1 root root    58 11 feb 09:40 mhwd-gpu.conf
-rw-r--r--   1 root root    16  5 dec 17:43 r8169_blacklist.conf
[nikolai@nikolai-pc ~]$ cat /etc/modprobe.d/*
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
blacklist r8169
[nikolai@nikolai-pc ~]$ cat /etc/modules-load.d/*
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
# List of modules to load at boot

#20

first please post:
cat /etc/default/grub | grep CMDLINE
then, if nothing related to gpu is listed continue:

do not reboot if errors, post errors.
sudo mhwd -r pci video-linux
sudo rm -rf /etc/modprobe.d/mhwd-gpu.conf
sudo pacman -R xf86-video-amdgpu amdgpu-experimental
sudo pacman -S xf86-video-amdgpu amdgpu-experimental

reboot if no errors and see if other resolutions are available