Vbox bridge loosing net every 30ish minutes

Host: Manjaro running VIrtualbox 6.1.14-1
Guest: windows 7, guest additions installed, no software installed, discovered the problem during download of installation files.

This is a strange issue. After some usage (30ish minutes) the vm looses network connection (all packets gets timeout). The fix for this is to go into vbox network config and set Promiscuous Mode = [something else]. If it was set to Deny, set it to Allow All fixes the problem. Then the next time the network stops working, change it back to Deny fixes the problem. Next time, put it back to Allow All…

Restarting the VM does not help. Restarting Virtualbox, does not help. Restarting the host network does not help. (Haven’t tried restarting host.)

This is my first windows guest in virtualbox on linux host. So far I’ve only tried win7. The issue does not apply to linux guests (manjaro and kali) on the same host.

The setup on the host is probably somewhat unusual. It’s running openvpn (usually tun0) and has a bridge (brm). There are two routing tables, and a rule saying that any packets marked 1, will use table_brm. Iptables handels marking of packets/connections comming in on brm. The vm network is set as bridge using the interface brm. Iptable also handels nat/masqurade of packets going out on tun0.

This works fine for the linux guests. It did not work initially for windows guest. Turned out I needed to run

sysctl net.ipv4.conf.all.forwarding=1

The need for this is strange because net.ipv4.conf.brm.forwarding=1 and net.ipv4.conf.tun0.forwarding=1 was already set, and is enough for the linux guests.

So I wonder two things:

  1. Why is there a need to set net.ipv4.conf.all.forwarding=1 for the windows guest? I don’t like to have forwarding enabled for all interfaces. It should be enough to enable it on those interfaces involved. As far as I can see, no new interfaces are created by vbox.

  2. What could possible cause the connection to drop after a while of usage?
    Guest is using static ip.