Various settings do not take effect

kde

#1

Dear Community!

I am someone who has just started using Manjaro. It seems to work nicely with the exception of one thing: When I alter settings, the alterations do not seem to take effect - for example: if I set the system to shut down upon closing the lid, it won’t shut down, but suspend to RAM (the default setting); if I set the screen never to dim / turn off, it still does as per the default settings. Tell me what I’m doing wrong! =) By the way this problem affects all system settings, not just power management. I’m sure this is not a bug, but something I missed.

Best regards!


#2

I don’t know the KDE power management tool but if it does use systemd for its services then you would need to restart systemd for those changes to have an effect. That would mean either a complete logout or reboot. Have you tried that?


#3

Yes, I did! :slight_smile: Tried logging out, and logging back in, also tried rebooting, yet this problem persists. My only partial solution is disabling power-management alltogether, which prevents the screen from turning off :stuck_out_tongue:


#4

Sorry, do not have KDE on a laptop to test it but you might want to do it by hand with systemd if the KDE power management is not working for you:
https://wiki.archlinux.org/index.php/Power_management#Power_management_with_systemd