Utc time for windows running a dual boot


Hi,

A new windows 10 version was released within the last couple of months and I installed it. I used to add:
HKLM\SYSTEM\CurrentControlSet\Control\TimeZoneInformation /v RealTimeIsUniversal /t REG_QWORD /d 1
to the system registry but this no longer seems to work. Does anyone know of a solution for this?

Thanks

Launch Manjaro Settings Manager → Time and Date →

  • :white_check_mark: Set time and date automatically
  • :white_check_mark: Hardware clock in local time zone
1 Like

Do you really ask a Windows question on a Linux forum? Really?
Join the Windows forum, I’m sure it exists, and ask your questions there.
We use Linux because we want to AND because we don’t like (hate) Windows.

you should only use network time synchronisation on one operating system or your clock will creep forward an hour each time you shutdown.

if you cannot disable it in W10, do so in manjaro using the steps fhdk posted BUT make sure set time and date automatically is not ticked. you may need to do this twice to make the setting stick. I had to when turning it on. I have 3 OS installed to this machine and manjaro is the one that uses network time. the others are set from it via the hardware clock.

I do not use Windows very much - so I run in utc - like most long time nix users, I know the possibility exist to run the clock in local time but have not given much thought to it.

How can such situation rise that the clock creeps forward on every shutdown?

That is an interesting question to me as I thought there was a simple answer. It turns out the answer is not as simple as it seems. From reading up on time on Arch Linux wiki I found the answer to be a little different than expected.

As I understand the article, by changing Manjaro (and Linux in general) to run the clock in local time you remove the point of origin (UTC) and create a floating point where every OS installed see the software clock as point of origin and adjusts the system clock to account for eg. DST or travelling through timezones.

All sorts of weird problems can arise from the systems software clock being set incorrectly, especially when - but not limited to - using remote logins to networks in other timezones.

On the Windows box (64-bit) - in cmd - enter

reg add "HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TimeZoneInformation" /v RealTimeIsUniversal /d 1 /t REG_DWORD /f

Maybe try with dword instead?

see here:

it says use qword instead of dword but the answer below says dword should work in 64bit home edition.

minor correction:
you dont like (hate) Windows, not we

1 Like

I follow this guide everytime I set up a new Linux distro together with Windows 7. It works with Manjaro too.

1 Like

Yours…

Mine. I used this.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
"RealTimeIsUniversal"=dword:00000001

I saved file as utc.reg and if things changed in windows again (update), I copy import that file back to registry.

And I disable ntp in windows. Maybe that helped.

1 Like

Precisely this question - I don’t think users in Windows forum would even bother to answer or to help get solved - for the exact reason you mention - prefix reversed.

I think they wouldn’t know how to it or what to do?

When dual-booting Windows - Linux - I think the only reasonable place to ask is a Linux forum.

Sorry @vetzki I knew you were quoting @DeMus but I copied from your post :slight_smile:
I have corrected the qoute

I don’t hate Windows - I am Microsoft Certified Technology Specialist in a couple of areas.

I think Microsoft is put under too much hate - that is inevitable when they have done so good at pushing their OS to 90% (give or take) of the worlds consumer pc’s.

Admittedly they have their fair share of negative attention but Linux get that too. Just look at some of the posts in the forum.

That negative attention is typically from users (Windows and Linux alike) who are not knowledgeable enough or do not have the persistence to learn or expect that systems are flawless and if not - the developer(s) should prioritize their problem over all other.

That is a selfish attitude which brings up the worst in humans.

After my retirement I decided to pursue my desire for getting to know Linux and - man, what a world I have been missing.

I finally have a system

  • when I feel the need to give it an overhaul (messing with core) it takes me less than 15 minutes to reinstall, get up and running on the latest available software
  • it runs waay better than my Windows equivalents (Win 10)
1 Like

While we can fix the problem by setting linux to rtc instead of utc (and it’s easier).
It’s not a good idea.
There’s more that just DST that’s the issue.

Always best to set windows to utc.

1 Like

Thanks for the helpful replies. For some reason the line command didn’t work but adding it to the system registry manually did the trick. The solution is here:

Also, sorry but the manjaro forum rules say that there is a “topic solved” button in the lower left of the page but I can’t find it. I’m sure my bad eyes don’t help.

It’s more than an eye problem :joy:
You need to click on the “3 dots” button to reveal more options, including “Solved”.

But in the #other-os category - no such checkbox exist :slight_smile:

1 Like

It is not a bug, it is a feature!!! :rofl:

1 Like

When I look at the OP I see a question about Windows, nothing about Linux, nothing about Manjaro, just Windows. That’s why I answered the way I did. When people still use Windows for whatever reason, and they have a problem with it they should not come to a Linux forum for help.
Something changed in a Windows update, then ask on a Windows forum. When the OP had written he now has differences in time between Windows and Linux (dual boot) then it would be different. But, read it again, the original message is only about Windows. So I responded.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark