Using "Places" in menu starts slideshow of media files

Hi mate users,
Discovered this odd quirk recently. I can see all ‘Places’ ok but no matter which one I pick a slideshow of media files in that folder will start. Easy work-around is to pull a caja on the panel but does someone know how to fix it?

Hi @6x12

can you post a sreenshot or a gif? I do not know whether I actually understand your problem but when I open the Places menu and then select Home Folder, caja opens in the home direcory. What do you mean with “a slideshow of media files in that folder will start.”?

It’s quite bizarre; I move the cursor over ‘Places’ and the folder tree opens to the right of it as it should. However, no matter what folder I pick it doesn’t open caja but starts a slideshow of pictures and vids and even ebook covers in that location.
Will try to make a gif.

Sorry, had to remove the gif of the slideshow.

I’d have preferred a video or one or more screenshots. That’s low resolution, are they being opened in mpv? Probably a silly question, certainly looks like it says mpv to me.

Yes, in mpv. Didn’t allow higher res.

I even deactivated ‘show places’ in mate tweaks but it still shows and the bug persists.

Ok that’s in fact really weird. Why are there menu items saying “(null)”, looks like there is something broken anyway. Could you try doing the same with the MATE classic menu?

1 Like

No, no, nothing broken, that’s the ftp servers on my phones, if I move them out of reach it shows ‘null’.

System runs rock-solid for years on my tweaked 2009 mbp. Boots in 14 secs, no issues.

Very strange (not the phone part). Still try one or both of the other menus, and see if it happens with a new user.

Classic menu acts in the same way but it follows the settings in Mate Tweaks, so I first have to activate ‘show places’.

What’s the output of cat ~/.config/mimeapps.list?

I’m guessing you have a line like this inode/directory=mpv.desktop and it should be inode/directory=caja-folder-handler.desktop.



That was it, changed it and now it works as it should.
Many thanks for all the help.


You’re welcome. :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.