Using Nvidia Proprietary Drivers Causes Broken GUI

System Specs:
RTX 2060
Intel Core i3 12100f
16gb DDR4 Memory
Gigabyte H610M

Hello, I am a new(ish) linux user who has just tried switching from Pop-OS to Manjaro, however I have had some crucial issues with Nvidia drivers, making it unusable. Also, please explain everything like I am 5, because this is my first time using an arch based distribution at all.

Anyways, the first driver related issue that I have is when first trying to boot into Manjaro from a live USB. Before putting you in the live environment, it asks if you want to use proprietary drivers, and every time I try, it does not work, and is stuck saying “a start job is running for LiveMedia MHWD Script”.

I don’t know how to log this stuff so bare with me.

To get around this problem, I have to use the open source drivers, and then would have to install the proprietary drivers from there, however, if I install Nvidia drivers on a Manjaro system, I will immediately notice upon trying to reboot, that the reboot button does not work, and I have to do a hard shutdown with the power button. And upon reboot from the hard shutdown, my system will not go to the GUI, and gets stuck on the command saying “audit: type=1334 audit(1675291099.083:42): prog-id=0 op=UNLOAD”

From here I think it is important to mention I do have access to tty2, and doing startx from there freezes the system.

Anyways, I hope you guys can help me figure out how to get Nvidia Drivers working on my system. Sorry if I did not provide enough info, as this is my first time asking for help on the forums.

Finally, I would like to mention that I only care about fixing Nvidia drivers on my actual system, and not the live USB. I just provided that because I think it correlates to the actual system not working as well. Thanks in advance guys!

in tty, add the ibt parameter and see if it helped:
sudo nano /etc/default/grub
and inside this line: GRUB_CMDLINE_LINUX_DEFAULT inside the quotes add this parameter:
dont remove anything, just add it to existing parameters, save the file with ctrl+x, press Y, update grub:
sudo update-grub
systemctl reboot

Woah that was a surprisingy easy fix! I didn’t realize that is all it took. However, the system boots up a lot slower now, is there a way I could fix this?

No. The proprietary nvidia driver has to support ibt, maybe it will be fixed soon.

Alright, that is fine. Thanks for the help you guys though. I finally have Manjaro up and running!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.