Using a vinil cutter over Wine

I´m using a vinyl cutter for my business, but I have to use virtualbox with windows 10 in order to use the programs (cricut design space, and Vinyl Master for a generic chinese-like ploter)
I have been able to install and use the design aspects of both programs without problem in Manjaro using wine, however no matter what I tried I can´t get them to detect any USB device whatsoever.

I have read similar threads in this forum related to USB peripherals not being detected in WINE, but at large it doesn’t seem to be a general solution, I wonder if there is something else I could try.

This is my first forum entry so Idk if i´m being too vague or if this should be posted in a more specific category, but i´m open to learn and try stuff so thanks in advance.

:+1: Welcome to Manjaro! :+1:

:warning: Before you read any further: Do not run wine as root !!!

What you’re running into is that your USB port is only directly accessible by root whereas it’s directly accessible to any user under Windows. As I don’t have neither your hardware, nor your software, you need to read up on rights and permissions under Linux and give the user you want to use your Hardware/Software combo enough rights that they can exclusively access a particular USB port to the exclusion of everyone else and then always plug in that particular hardware in that port.

So I don’t know your Linux experience and / or if the above is making any sense to you, but if you’re a Linux N00b, please read this first:

then let me know which bit of the above still doesn’t make sense…


1 Like