Used windows 11 as main os, dual booted with XFCE and now i cant swap back to windows there is no option in the boot manager for it

I decided to try Manjaro XFCE so i dualbooted using Etcher with a usb stick but when i turn off my pc it auto boots into manjaro and there is no option for windows in the boot loader when i press f12 on boot.

How do i swap back to windows 11 preferably without losing my old files?

1 Like

Hi there & welcome to Manjaro.

Apologies if this sounds like a silly question but when you say you dual booted using a USB stick, are you saying that you were trying out Manjaro & you haven’t installed it, or you have actually installed it on your machine? I’m assuming you’ve actually installed Manjaro but just want to clarify.

It’s a bit unclear to me.



1 Like

My aim was to try it out and not actually install it so i clicked on the option to install it onto the usb inside Etcher.

Since i first booted manjaro i have not been able to boot back into windows as no option shows for it.

Okay, so when you shut down your machine, you took out the USB before rebooting, right?

Whatever has happened, your data is still on your machine - it sounds like you might have to look at Grub.


I do take out the usb, i can completely remove the usb from my pc and when i turn it back on with the usb out it still boots straight into manjaro without any options for windows.

I’m about to hit the sack - If you can post the output of “lsblk” here in the meantime, that will help someone to help you. My skills are limited, so I don’t want to give you the wrong advice.

nvme0n1 259:0 0 238.5G 0 disk
├─nvme0n1p1 259:1 0 300M 0 part /boot/efi
└─nvme0n1p2 259:2 0 238.2G 0 part /

OK. Have you tried booting in Manjaro & running the command, sudo update-grub?

Try that & then reboot - maybe that will work. Keep your Manjaro USB handy, just in case you need to boot into that, to fix your system.


Just tried that, still booted straight into manjaro without the usb in.

What is the output of - “os-prober”

It doesnt say anything when i run that as root. It just comes up with a new terminal line for me to enter another comand in

Check your Grub configuration. GRUB (/etc/default/grub)

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

Uncomment the above line (as root user) and update grub (in terminal: sudo update-grub) and reboot

Is that the full output from lsblk?

yes thats all.

Then unfortunately, it seems like you’ve installed over windows.

If i reinstall windows will i still have to pay for a license key or will it keep my old one?

You can reinstall at no cost, that’s for sure. As long as you have the key - it should be on your PC or else you can it back somehow…

Ok, thanks for the help

It’s an easy mistake to make. Firstly, well done for exploring the dual-boot option. It works well for a lot of people. Unfortunately, if you’ve written over Windows then you will need to just get your key & enter it in on re-install. If it came installed on your machine, it is usually on a sticker somewhere. Hopefully you didn’t lose valuable data, have it stored somewhere or whatever.

More power to you.


PS, thanks @dmt & @jrichard326 for helping…

Just checking you didn’t unplug any drives? You’ve only got 1?

It may depend on your license and whether you have a key, better to ask in a windows forum or contact microsoft.