USB Wifi AC 1300 Archer T3U Plus not showing up

Hi all.

I’m new to this so lets hope I can learn to make this easy.

The TP-Link AC 1300 Archer T3U Plus works fine in windows, but its not visible in Manjaro. Some help troubleshooting and/or installing a driver would be great.

> [mjb@optiplex7020kman ~]$ inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=3a3ebf1d-9300-4d7b-9597-67ad95de9e21 ro quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop System: Dell product: OptiPlex 7020 v: 00 serial: <filter> 
  Chassis: type: 6 serial: <filter> 
  Mobo: Dell model: 0F5C5X v: A00 serial: <filter> BIOS: Dell v: A15 
  date: 02/02/2018 
  RAM: total: 7.69 GiB used: 3.45 GiB (44.9%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i5-4690 bits: 64 type: MCP arch: Haswell 
  family: 6 model-id: 3C (60) stepping: 3 microcode: 28 L2 cache: 6 MiB 
  bogomips: 27946 
  Speed: 1181 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 1181 2: 1104 
  3: 1270 4: 1297 
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2 bts 
  clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm 
  dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase 
  fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce md_clear mmx 
  monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm 
  pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdtscp rep_good 
  sdbg sep smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 
  tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xsave 
  xsaveopt xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
  vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0412 
  class ID: 0300 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: intel unloaded: modesetting alternate: fbdev,vesa display ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: VGA1 res: 1920x1080 hz: 60 dpi: 92 size: 530x300mm (20.9x11.8") 
  diag: 609mm (24") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2) 
  v: 4.5 Mesa 20.3.4 compat-v: 3.0 direct render: Yes 
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 chip ID: 8086:0c0c 
  class ID: 0403 
  Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8c20 
  class ID: 0403 
  Device-3: Logitech H600 [Wireless Headset] type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 2-6:4 chip ID: 046d:0a29 
  class ID: 0300 serial: <filter> 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
  Device-1: Intel Ethernet I217-LM vendor: Dell driver: e1000e v: kernel 
  port: f080 bus ID: 00:19.0 chip ID: 8086:153a class ID: 0200 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: TP-Link 802.11ac NIC type: USB driver: usb-network bus ID: 2-3:2 
  chip ID: 2357:0138 class ID: 0000 serial: <filter> 
  WAN IP: <filter> 
  Message: No Bluetooth data was found. 
  Message: No RAID data was found. 
  Local Storage: total: 465.76 GiB used: 79.89 GiB (17.2%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500DM002-1BD142 
  size: 465.76 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: KC45 scheme: MBR 
  Optical-1: /dev/sr0 vendor: PLDS model: DVD+-RW DH-16AES rev: DD11 
  dev-links: cdrom 
  Features: speed: 48 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  ID-1: / raw size: 97.88 GiB size: 95.84 GiB (97.92%) used: 19.86 GiB (20.7%) 
  fs: ext4 dev: /dev/sda7 maj-min: 8:7 label: manjaro 
  uuid: 3a3ebf1d-9300-4d7b-9597-67ad95de9e21 
  ID-2: /run/media/mjb/Win10ntfs raw size: 186.54 GiB 
  size: 186.54 GiB (100.00%) used: 60.04 GiB (32.2%) fs: ntfs dev: /dev/sda2 
  maj-min: 8:2 label: Win10ntfs uuid: 388020998020601C 
  Alert: No Swap data was found. 
  ID-1: /dev/sda1 maj-min: 8:1 size: 549 MiB fs: ntfs label: System Reserved 
  uuid: FE641F9C641F56AD 
  ID-2: /dev/sda10 maj-min: 8:10 size: 9.84 GiB fs: vfat label: FAT32 
  uuid: 9DF6-1654 
  ID-3: /dev/sda11 maj-min: 8:11 size: 32.22 GiB fs: vfat label: IDK 
  uuid: DC9E-1FFC 
  ID-4: /dev/sda12 maj-min: 8:12 size: 48.92 GiB fs: ext4 label: N/A 
  uuid: 28f4a783-caa4-4b40-8462-035dd8f0c037 
  ID-5: /dev/sda3 maj-min: 8:3 size: 538 MiB fs: ntfs label: N/A 
  uuid: D0A2CF03A2CEED52 
  ID-6: /dev/sda4 maj-min: 8:4 size: 1 KiB fs: <superuser required> label: N/A 
  uuid: N/A 
  ID-7: /dev/sda5 maj-min: 8:5 size: 513 MiB fs: vfat label: WIN10SYS 
  uuid: 296D-52D2 
  ID-8: /dev/sda6 maj-min: 8:6 size: 48.82 GiB fs: ext4 label: kubuntu 
  uuid: c4bce986-e80d-4a87-9541-7d4cf80d72ec 
  ID-9: /dev/sda8 maj-min: 8:8 size: 9.77 GiB fs: swap label: N/A 
  uuid: c4d00717-02f1-43b3-8528-d3781a57027a 
  ID-10: /dev/sda9 maj-min: 8:9 size: 30.21 GiB fs: ext4 label: lithium 
  uuid: 3c28fcaa-3307-4603-a07e-62c692129f5e 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 3 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip ID: 8087:8008 class ID: 0900 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 15 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Device-1: 2-3:2 info: TP-Link 802.11ac NIC type: <vendor specific> 
  driver: N/A interfaces: 1 rev: 2.1 speed: 480 Mb/s chip ID: 2357:0138 
  class ID: 0000 serial: <filter> 
  Device-2: 2-5:3 info: Dell KB212-B Quiet Key Keyboard type: Keyboard 
  driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 1.5 Mb/s 
  chip ID: 413c:2107 class ID: 0301 
  Device-3: 2-6:4 info: Logitech H600 [Wireless Headset] type: Audio,HID 
  driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 2.0 
  speed: 12 Mb/s chip ID: 046d:0a29 class ID: 0300 serial: <filter> 
  Device-4: 2-9:5 info: Logitech M105 Optical Mouse type: Mouse 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s 
  chip ID: 046d:c077 class ID: 0301 
  Hub-4: 3-0:1 info: Full speed (or root) Hub ports: 3 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-5: 3-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0 
  speed: 480 Mb/s chip ID: 8087:8000 class ID: 0900 
  Hub-6: 4-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
  Processes: 193 Uptime: 1d 21h 58m wakeups: 20 Init: systemd v: 247 
  Compilers: gcc: N/A Packages: pacman: 1309 lib: 405 flatpak: 0 Shell: Bash 
  v: 5.1.0 running in: konsole inxi: 3.3.01 


Hi, I had the same issue, tried many things but only an answer in the Mint forum worked (I can’t link it for some reason). Last answer there indicates to do this:

sudo apt install git dkms
git clone
sudo dkms add ./rtl88x2bu
sudo dkms install rtl88x2bu/5.6.1

The only thing to change is installing dkms with another package manager.
Hope it helps.

Thanks! The process went exactly as you described, the only difference was dkms was already installed on my system. I also got it working in Arch, which did require dkms and linux-headers. As a side note, the Arch AUR has the driver also, just in case that’s helpful to anyone.

sudo pacman -S dkms

The above replaces:

sudo apt install git dkms

in the reply above for anyone finding this down the road…

Thanks again.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.