USB to device mode in HDMI connection before use USB to connect camera to Laptop

Maybe i am wrong? could it be that I have actually still Xfce but i think i have KDE. I have been wrestling with some incompatibility some time ago, and I really dont know how it got solved. May you please provide me a command to make sure what I am running now?

inxi -S

ok this:

Host: dummysock Kernel: 5.10.109-1-MANJARO arch: x86_64 bits: 64
Desktop: Xfce v: 4.16.0 Distro: Manjaro Linux

ok I correct myself, you did not update your systen for months it seems:

13 GB install size is really huge. Be ready for problems.

Thank you, it look scary, as I really need my computer in next months. I did upgrade fri april 29th about month ago… What happend is that I actually had a problem before when I tried to install HP printer, which unfortunatelly is a slightly bit newer than what the driver was, and therefore i got to state where I could not update anything, untill i learned that I have to update the pacman and then the problem was gone. But now I thing I am getting into new problem. Could it help if I do some Timeshift backup… Is there a way how to remove gnome config files that are calling for gnome libraries?

i am even thinking that thunar is something I did install, as Gui for changing owners permisions for external drives, that I was not able to change via terminal

I also find that only use of gnome-desktop is: pactree -c -d3 -r gnome-desktop
i may remove nautilus I am not using it.

Yes that helps if you make mistakes. Just keep sure only system files are snapshot-ed, and not the home files.

No idea what you mean here. :man_shrugging:

Yepp :+1:

Just try to remove one package, that you don’t need. If it says something like “package X owned by package Y”, then look if package Y is safe to remove and add it to the remove command.

Thunar is needed on XFCE, which your are using. Don’t remove it :smiley:

1 Like

thank you. for a tip, It look I could remove nautilus as it dependeds only on python-nautilus and that depends on:

pactree -c -d3 -s -r python-nautilus

I am doing a removal via add/remove programs for now, I do not remmeber how to remove a package in terminal mode. Do you mind give me a command fro nautilus remove please?

1 Like

If you don’t remember the commands, then all programs have a help parameter:

pamac --help

or more specific:

pamac remove --help

and then:

pamac remove package_name

Also most terminal programs have man(ual) pages:

man pamac

Thank yooou. If I am right now I got pamac updated, nautilus removed, it has still asked to install 1, 9 gB, which I did and now installed the MPV. ANd will try to connect the camera. What I realize I lost image for Zoom calls, from my laptop default camera. COuld that be somehow connected?

I came to this result:

mpv av://v4l2:/dev/video2 --profile=low-latency --untimed --fps=30
(+) Video --vid=1 (rawvideo 1920x1080 30.000fps)
FPS forced to 30.000.
Use --no-correct-pts to force FPS based timing.
[1]+ Stopped mpv av://v4l2:/dev/video2 --profile=low-latency --untimed --fps=30


Yes, that is fully possible.

Please do so:

mpv av://v4l2:/dev/video2 --profile=low-latency --untimed --fps=30 --no-correct-pts

mpv av://v4l2:/dev/video2 --profile=low-latency --untimed --fps=30 --no-correct-pts
[lavf] avformat_open_input() failed
Failed to recognize file format.

Exiting… (Errors when loading file)

hm… ok does not support 30fps?

mpv av://v4l2:/dev/video2 --profile=low-latency --untimed

Something I dont understand happend. It should support 30fps.I will checkit, but i have to restart the laptop. What happend is that for a short time I was able to find the cammera inside the application.
I have the application installed in 3 versions. 2 are on playonlinux, but those seem installed perfectly fine, but no recognition for camera, but the light version of the application that also came with package with .sh file was having a camara recognized now, but I did shut the app down and after restart it is again not there. (Previously I was only able to see the Laptop camera in this application, but not now)

Btw… there is an install script for that sh file:

pamac build touplite

Is easier to manage then.

Yeah that confirms my previous thought:

ok well, you need to add a udev rule, to fix the naming of /dev/video0

thank you. I have some questions on this piece of the software, as I thought maybe over time I will wish to reinstall this version with newer one, but that is something I guess will do via pamac build … is for the moment a bit additional questions.

I tried :

mpv av://v4l2:/dev/video2 --profile=low-latency --untimed --no-correct-pts
[lavf] avformat_open_input() failed
Failed to recognize file format.

Exiting… (Errors when loading file)
[xx@dummysock ~]$ mpv av://v4l2:/dev/video2 --profile=low-latency --untimed
[lavf] avformat_open_input() failed
Failed to recognize file format.

Exiting… (Errors when loading file)

So it look as I have to do some static definitions of Udev. Do you maybe have some howto for me please?

I guess it must like that:

# Webcam -> Realtek Semiconductor Corp
SUBSYSTEM=="video4linux", ENV{ID_BUS}="usb", ATTRS{idVendor}=="0bda", ATTRS{idProduct}=="3031", NAME="video0"
# Touplite Camera -> HD428
SUBSYSTEM=="video4linux", ENV{ID_BUS}="usb", ATTRS{idVendor}=="0547", ATTRS{idProduct}=="ab02", NAME="video1"

Save it as root at


Then run

sudo udevadm trigger 

Check if the name changes:

v4l2-ctl --list-devices

otherwise try a reboot.

v4l2-ctl --list-devices
HD428: HD428 (usb-0000:00:14.0-2):

USB Camera: USB Camera (usb-0000:00:14.0-7):

the definition static paths has worked with the test bench utility . it also seems to have solve the issue, and at least it is possible to the lite version. I love your advices. It would be very good If I may be able to define these udev device for PlayOnLinux to be able to use full version of the program. Iam still in testing the camera mode, despite accordint the test bench utility it seem to have been already solved.
you solved it : :heart_eyes: :joy:

Are you familiar with PlayOnLinux ? I have installed an app from my certifier where I should be recording the soil analyses results, but it seem to have a write permission issue for getting the app working.

here is the out from rules.d]$ ls
40-libsane.rules 99-amcam.rules 99-toupcam.rules
56-hpmud.rules 99-static-webcam.rules S99-2000S1.rules

it look as if Toupcm software has rules also defined here, despite it is actually in my playonLinux I will have a better look on this now.

I have tested the web cam, It has definitely help to be able to use my webcam again.

I have a bit issue with use in the application. Though it stay may still be problem with application, I wish to eliminate the improper hardware behaviour. It look as if the camera is recognised and turns on. It is not possible to focus as it is not responding to sent commands, therefor not communicating and after some time it turns off. Another thing that also happens is that when after some time the usb camera gets disconnected the usb hub is parallelised, even my usb mouse would get blocked, and can not get back even if I change the mouse. Do you recognise something of it? After I have to restart the laptop to get back the usb running.

Well about wine, there no hardware support. If you need to use the microscope in an application which is written for windows and run in wine unter Linux, then you won’t be able to connect to any hardware device directly, thus it is not gonna work. Thats because the libraries of wine are not able to do this and there is no effort to do so.

If you really need this microscope running at this windows application (full version), then you have run windows. In a dualboot or in a virtual machine.

I would recommend gnome-boxes (for simple use) or virt-manager (for advanced use), but virtualbox or vmware is also good. You can passthrough the usb device, use it there like any other device, and save files via integrated webdav or samba on the linux machine.

No idea what the problem here is. There is the SDK ToupTek USB or WLAN Camera Multi-platform SDK (good documentation btw), but there seems only ToupCamLite available.

Since I don’t have such a “webcam”, I cannot reproduce anything.

You might need to adjust the naming at 99-static-webcam.rules, if needed. With # at the beginning of the line, you can ignore a rule.

thank you for tips. I have tried to install Oracle VM virtualBox, but I have got to point where in order to make USB boot working I needed to install some libraries, started to go through the process, but I could not find a way how to continue, when at one point I was to do a magic “make” command.
I am hoping still , I will become more sucessfull with other VM machines, though I am into installing gnome-boxes as it seems will require gnome environment, as I do not feel confident enough with creating a new user with gnome environment.

I can be satisfied with Lite version for some years, as far as the drivers would be responding to what the application is needed. As you indicated that the documentation is quite good for Toup Tek, I want to give it more time, as i did not find the manuals section from quick search over folders.

The other app, I need to run in PlayonLinux is actually simple database, maybe even office Db and excel sheet based application which does not need to command a microscope, and If I manage to get that one working I am just fine. Though for the moment it look it is something on system site, because the windows application is asking a permission to create a folder, and ends with error that it does not have permissions, and I am not able to find where to add those permissions, or to which user to assign those permissions. I did assigned permission to root on those folders that are defined, in wine as default MS shared folders, but no difference. But for that case I would probably create a new topic soon (will have one more with my Manjaro reinstall on the PBP , jejeje to not to be short of work), as this might get just too long.

thanks for tip on 99-static-web… i hope that may help. In Zoom for some reason the webcam is not availbale, but for online version of other programs, webcam look to be working.