USB to device mode in HDMI connection before use USB to connect camera to Laptop

I wish to install my camera for microscope and connect it to my StarLabTop notebook.
This camera comes with 3 options for control.

  1. via USB3.0 When I connect it I do not find the camera in the list of devices inside their application, despite the .sh script for installation has been installed . Do you know how could i install the HW, or checkif it is in my HW list already?
  2. connection via HDMI, in the application I still did not find the camera. The producers told me to set "USB to device mode in HDMI connection before use USB connection to Laptop but I do not know how this could be done in Manjaro. Some ideas what is this advice suggesting?
  3. The camera comes with wifi key, but When I stick it into camera, I cannot find any new networks that I might connect with my computer. Do you have some ideas how to search in wifi networks, when my network default api is not showing anything new?

Please help, any advices…

What camera? How is it connected?

What application?

thanks for asking. The camera is HDMI Multi-output from Amscope 4K 2160P number:HD428.
as described above I am trying to connect it in any of those 3 ways above possible - by a wifi key, USB 3.0 cable or HDMI cable.
The application is TopUpTek application see :Download-CCD & CMOS Camera | Microscope Camera|Astronomy Camera|Micro-spectrometer|Light Sources-ToupTek Photonics

Do I have a chance to see if the USB hardware or HDMI hardware is recognised? Later I would ask bout wifi, because that would be my preferred connection, but for now I wish to find that camaea phisically.

Ok as I understand now, you should be able to view the camera via usb. If you have a “hdmi input adapter” then you connect via hdmi aswell.

Can you plugin your camera, open a terminal and post the output of:

lsusb -vt

According to provided udev rule, it must be vendor id 0547

SUBSYSTEM=="usb", ATTRS{idVendor}=="0547", MODE="0666"

Hi Megavolt,
In this case I am not running Manjaro on pBp and I do have HDMI connector directly on laptop. I am also assuming that any adaptation that I should be needed to have done on HW side is already implemented in the camera itself. At the end it is quite valuable camera.
I understand this command works if I use USB plug on notebook, not when I have it pluged via HDMI. I have tried to plug it with USB and here is a result:

lsusb -vt
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/6p, 10000M
    ID 1d6b:0003 Linux Foundation 3.0 root hub
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/12p, 480M
    ID 1d6b:0002 Linux Foundation 2.0 root hub
    |__ Port 4: Dev 2, If 0, Class=Vendor Specific Class, Driver=rtsx_usb, 480M
        ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
    |__ Port 6: Dev 8, If 0, Class=Human Interface Device, Driver=usbhid, 12M
        ID 25a7:fa61 Areson Technology Corp Elecom Co., Ltd MR-K013 Multicard Reader
    |__ Port 6: Dev 8, If 1, Class=Human Interface Device, Driver=usbhid, 12M
        ID 25a7:fa61 Areson Technology Corp Elecom Co., Ltd MR-K013 Multicard Reader
    |__ Port 7: Dev 4, If 0, Class=Video, Driver=uvcvideo, 480M
        ID 0bda:3031 Realtek Semiconductor Corp. 
    |__ Port 7: Dev 4, If 1, Class=Video, Driver=uvcvideo, 480M
        ID 0bda:3031 Realtek Semiconductor Corp. 
    |__ Port 10: Dev 5, If 0, Class=Wireless, Driver=btusb, 12M
        ID 8087:0026 Intel Corp. AX201 Bluetooth
    |__ Port 10: Dev 5, If 1, Class=Wireless, Driver=btusb, 12M
        ID 8087:0026 Intel Corp. AX201 Bluetooth

here is a result, but I cannot find in it what you wrote it should be there.

Me neither… please run this command to show the kernel messages:

sudo dmesg --follow-new 

Then connect the camera.

So you have an “HDMI Input Port” integrated into your Laptop? Don’t get me wrong, but the HDMI Port at your camera is an output port and if connect it it on a HDMI Output Port, then it is obviously that it doesn’t work. You can connect it to a monitor that way.

Thank, I see that make sense,=> I have then reduced possibilities, what is clarifying something. I can connect via USB or via wifi,(which I still do not know how to get it working) Did you hear something about that option.
I was not able to get out of the messages, because the output (or has a conflict or is too large for display) of messages:

I see I was confused, I thought that the HDMI outputs are actually bidirectional, at least they communicate and actually the device can set or control this communication, but It look that you might be more likely true, that they are simply unidirectional, and then on the camera it is the same

Hm… without it, it is difficult have any idea about what is going when the usb connects. Maybe this is better for you:

sudo dmesg --follow-new | tee -a ~/dmesg.log

No it will write terminal output to a file called dmesg.log at your home folder. Just open if with an editor and copy&paste the content here please.

Usually you should see there messages beginning with usb, which show what is happening at the usb ports in real time.

No, that is not the case. Yeah the cable works bidirectional, but not the hdmi ports.

I have tested the HDMI connection to LCD. first my my LCD did not notice, But after some time the screen came. The think is I need to be able to process my images in computer and specially in application, and so I need to focus on communication via USB. here is an output of the command you recommended:

[36899.197890] usb 2-2: new SuperSpeed Gen 1 USB device number 3 using xhci_hcd
[36899.215293] usb 2-2: New USB device found, idVendor=0547, idProduct=ab02, bcdDevice= 4.09
[36899.215300] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[36899.215304] usb 2-2: Product: HD428
[36899.215307] usb 2-2: Manufacturer: CAMERA
[36899.231439] usb 2-2: Enable of device-initiated U1 failed.
[36899.231642] usb 2-2: Enable of device-initiated U2 failed.
[36899.232070] uvcvideo: Found UVC 1.10 device HD428 (0547:ab02)
[36899.243252] usb 2-2: Enable of device-initiated U1 failed.
[36899.243415] usb 2-2: Enable of device-initiated U2 failed.
[36899.244439] input: HD428: HD428 as /devices/pci0000:00/0000:00:14.0/usb2/2-2/2-2:1.0/input/input34

Does something look familiar to you?

The device has been found here. And has the vendorID 0547, I said here:

So at this point everything is correct.

This is just a warning/info of LPM “Link Power Managment” of the USB Hub. That has been fixed recently at v5.18rc6 (mainline): usb: remove Link Powermanagement (LPM) disable before port reset. · torvalds/linux@cd36fac · GitHub

So that shouldn’t bother.

Now just for testing to get a video stream, try this:

# Install the packages
pamac install v4l-utils mpv
# List the devices
v4l2-ctl --list-devices
# Try to get a video stream
mpv av://v4l2:/dev/video0 --profile=low-latency --untimed --fps=30
# Replace /dev/video0 with one of the listed devices.

Thnak you for having look at how to solve my case I have v4l-utils installed already.
how to solve I am wondering If I could go around without installing MPV It is asking to download 4.3 GB, as if it is downloading a complete new environment… i sked only to install yt-dlp: for video sharing websites component, but suddenly it is just downloading a lot more…
I see it is also under GPLv3 and I wish to have installed only sw that is responding to GPL v2. Anyway, I have installed it just for progressing to have a look if I may get some more concrete results. here are the results of commands:v4l2-ctl --list-devices
Warning: v4l-utils-1.22.1-1 is up to date – skipping

HD428: HD428 (usb-0000:00:14.0-2):

it asked to install: gnome-desktop-common, Ok I got to same issue as before and I did the same error as before (history is repeating ) as I clicked y to install that gnome environment. but I do not want to get my system broken, but this MPV is wanting to install gnome components.
I stopped it in the middle now, even when I try to repair the database by doing “refresh database” I still end up at wanting to install gnome. Is there a way to When I run

sudo pacman -Syyuu

I recieve:
Total Download Size: 1856,82 MiB
Total Installed Size: 13705,46 MiB
Net Upgrade Size: -262,93 MiB

Could be possible to use a different program?
Could I somehow stop this to be getting on with installing gnome environment?

That is totally normal for a monthly stable upgrade on a rolling release like Manjaro. Pamac installs it because a partially upgraded system result in most cases in a broken system. Don’t install new software before everything is up-to-date.

It is not like Ubuntu etc, which offers just only security updates. The whole system rolls forward and you get security and feature upgrades continuously.

I guess here is one point to mention. Older software just search for /dev/video0, if it is another number than 0, then it cannot find it, at least I believe that is the case at this program of the company.

the situation is that I am running KDE Plasma, as far as I know, but it seems it is asking permissions to install desktop-gnome packages. Is that still ok?

Yes that is okay. If you have installed gnome/gtk apps, then they need the gnome api library to work properly.

is there plz a way how to find which are my gnom/gtk apps?
I remmember installing gtk3/ gtk5 apps, but not genome, except that I startet MPV now. I was doing my best to avoid gnome apps. but It looks I missed some.

Look: GTK2/3/4 is the Windows Framework which is used by Gnome. Therefore Gnome Apps using GTK. It must not be specific Gnome App, it just have to use the GTK Framework.

Here you see which packages depends/needs this package hierarchically:

pactree -c -d3 -r gnome-desktop-common

thanks that is great. i really wouldlove to know where to learn the system that well.
here is a command:

pactree -c -d3 -r gnome-desktop-common
error: package ‘gnome-desktop-common’ not found

This package is is not installed? Please could your paste the whole terminal output of the pamac upgrade?

10y+ only using linux and solving problems… :slight_smile:

sudo pacman -Syyuu
:: Synchronising package databases...
 core                  169,4 KiB   439 KiB/s 00:00 [######################] 100%
 extra                1884,0 KiB  2,49 MiB/s 00:01 [######################] 100%
 community               7,0 MiB  4,11 MiB/s 00:02 [######################] 100%
 multilib              179,0 KiB   688 KiB/s 00:00 [######################] 100%
:: Starting full system upgrade...
:: Replace lib32-sdl with multilib/lib32-sdl12-compat? [Y/n] n
:: Replace sdl with community/sdl12-compat? [Y/n] n
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency
warning: dependency cycle detected:
warning: mesa will be installed before its libglvnd dependency
warning: dependency cycle detected:
warning: nvidia-utils will be installed before its libglvnd dependency
warning: dependency cycle detected:
warning: nvidia-utils will be installed before its libglvnd dependency
warning: dependency cycle detected:
warning: nvidia-utils will be installed before its libglvnd dependency
warning: dependency cycle detected:
warning: smbclient will be installed before its cifs-utils dependency
warning: dependency cycle detected:
warning: lib32-harfbuzz will be installed before its lib32-freetype2 dependency
warning: dependency cycle detected:
warning: lib32-mesa will be installed before its lib32-libglvnd dependency

Packages (778) adwaita-icon-theme-42.0+r1+gc144c3d75-1  akonadi-22.04.0-1
               akonadi-calendar-22.04.0-1  akonadi-contacts-22.04.0-1
               akonadi-import-wizard-22.04.0-1  akonadi-mime-22.04.0-1
               akonadi-notes-22.04.0-1  akonadi-search-22.04.0-1
               alsa-card-profiles-1:0.3.51-1  android-file-transfer-4.2-2
               android-tools-31.0.3-5  appstream-0.15.3-1
               appstream-qt-0.15.3-1  archlinux-appstream-data-20220422-1
               arduino-builder-1.6.1-2  assimp-5.2.3-1  at-spi2-core-2.44.1-1
               attica-5.93.0-1  audit-3.0.8-1  avr-gcc-12.1.0-1
               avrdude-1:7.0-1  baloo-5.93.0-1  binutils-2.38-4  blas-3.10.1-1
               blender-17:3.1.2-2  blinken-22.04.0-1  bluedevil-1:5.24.5-1
               bluez-qt-5.93.0-1  boost-libs-1.78.0-2  brave-browser-1.38.115-1
               breeze-5.24.5-1  breeze-gtk-5.24.5-1  breeze-icons-5.93.0-1
               brotli-1.0.9-8  btrfs-progs-5.17-1
               ca-certificates-mozilla-3.78-1  cairo-1.17.6-2
               calendarsupport-22.04.0-1  calligra-3.2.1-33  cblas-3.10.1-1
               ciano-0.2.4-4  cifs-utils-6.15-1  coreutils-9.1-1
               cronie-1.6.1-1  cuda-11.6.2-1  cups-filters-1.28.15-1
               curl-7.83.0-1  darktable-2:3.8.1-4  dav1d-1.0.0-1
               dbeaver-22.0.4-1  dbus-x11-1.14.0-1  digikam-7.6.0-2
               discover-snap-5.24.5-1  drkonqi-5.24.5-1  elfutils-0.187-1
               enchant-2.3.3-1  eventviews-22.04.0-1  exiv2-0.27.5-3
               faudio-22.05-1  ffmpeg-2:5.0-7  ffmpeg4.4-4.4.1-5
               firefox-100.0-1  firefox-dark-reader-4.9.50-1
               firefox-ublock-origin-1.42.4-1  fluidsynth-2.2.7-1
               frameworkintegration-5.93.0-1  freeglut-3.2.2-2
               freeplane-1.10.2-2  freetype2-2.12.1-1  fribidi-1.0.12-1
               gavl-1.4.0-6  gd-2.3.3-4  gdal-3.4.0-6
               geoip-database-20220419-1  ghostscript-9.56.1-1  gimp-2.10.30-3
               git-2.36.1-1  glew-2.2.0-3  glib2-2.72.1-1  glibmm-2.66.4-1
               glslang-11.9.0-1  glu-9.0.2-3  gmic-3.1.0-1
               gnome-desktop-1:42.1-1  gnome-desktop-4-1:42.1-1
               gnome-desktop-common-1:42.1-1  gnupg-2.2.35-1  gnutls-3.7.4-2
               gpsd-3.24-1  gptfdisk-1.0.9-1  grantleetheme-22.04.0-1
               grub-2.06-6  gsettings-desktop-schemas-42.0-1  gspell-1.10.0-2
               gst-libav-1.20.2-1  gst-plugin-gtk-1.20.2-1
               gst-plugin-pipewire-1:0.3.51-1  gst-plugins-bad-1.20.2-1
               gst-plugins-bad-libs-1.20.2-1  gst-plugins-base-1.20.2-1
               gst-plugins-base-libs-1.20.2-1  gst-plugins-good-1.20.2-1
               gst-plugins-ugly-1.20.2-1  gstreamer-1.20.2-1
               gstreamer-vaapi-1.20.2-1  gtk-update-icon-cache-1:4.6.3-1.0
               gtk3-1:3.24.33-3.0  gtk4-1:4.6.3-1.0  gtkmm3-3.24.6-1
               gvfs-1.50.1-1  gvfs-afc-1.50.1-1  gvfs-gphoto2-1.50.1-1
               gvfs-mtp-1.50.1-1  gvfs-nfs-1.50.1-1  gvfs-smb-1.50.1-1
               gzip-1.12-1  harfbuzz-4.2.1-1  harfbuzz-icu-4.2.1-1
               haskell-aeson-  haskell-aeson-pretty-0.8.9-50
               haskell-asn1-encoding-0.9.6-168  haskell-asn1-parse-0.9.5-168
               haskell-asn1-types-0.3.4-147  haskell-assoc-1.0.2-136
               haskell-async-2.2.4-50  haskell-attoparsec-0.14.4-15
               haskell-bifunctors-5.5.11-61  haskell-blaze-html-
               haskell-citeproc-  haskell-clock-0.8.3-19
               haskell-colour-2.3.6-92  haskell-commonmark-
               haskell-commonmark-pandoc-  haskell-comonad-5.0.8-140
               haskell-conduit-  haskell-conduit-extra-1.3.5-225
               haskell-connection-0.3.1-192  haskell-constraints-0.13.3-10
               haskell-cryptonite-0.30-11  haskell-data-default-
               haskell-data-fix-0.3.2-43  haskell-distributive-
               haskell-dlist-1.0-154  haskell-doclayout-
               haskell-doctest-parallel-0.2.2-6  haskell-emojis-0.1.2-15
               haskell-enclosed-exceptions-1.0.3-194  haskell-extra-1.7.10-47
               haskell-fast-logger-3.1.1-9  haskell-fingertree-
               haskell-fsnotify-  haskell-glob-0.10.2-31
               haskell-haddock-library-1.10.0-117  haskell-hakyll-
               haskell-hashable-  haskell-hinotify-0.4.1-112
               haskell-hourglass-0.2.12-187  haskell-hslua-2.1.0-7
               haskell-hslua-aeson-2.1.0-7  haskell-hslua-classes-2.1.0-7
               haskell-hslua-core-2.1.0-7  haskell-hslua-marshalling-2.1.0-7
               haskell-hslua-packaging-2.1.0-7  haskell-hsyaml-
               haskell-http-client-0.7.11-14  haskell-http-client-tls-
               haskell-http-conduit-2.3.8-181  haskell-http-date-0.0.11-77
               haskell-http-types-0.12.3-227  haskell-http2-3.0.2-104
               haskell-hunit-  haskell-iproute-1.7.12-19
               haskell-ipynb-0.2-8  haskell-jira-wiki-markup-1.4.0-54
               haskell-juicypixels-3.3.7-10  haskell-libyaml-0.1.2-211
               haskell-lifted-base-  haskell-lpeg-1.0.2-5
               haskell-lua-2.1.0-5  haskell-memory-0.17.0-7
               haskell-mono-traversable-  haskell-network-
               haskell-pandoc-types-1.22.2-5  haskell-pem-0.2.4-224
               haskell-primitive-  haskell-psqueues-
               haskell-quickcheck-2.14.2-303  haskell-random-1.2.1-91
               haskell-regex-tdfa-  haskell-resourcet-
               haskell-scientific-  haskell-shelly-1.10.0-6
               haskell-simple-sendfile-0.2.30-269  haskell-skylighting-0.12.3-7
               haskell-skylighting-core-0.12.3-7  haskell-socks-0.6.1-171
               haskell-split-  haskell-splitmix-
               haskell-streaming-commons-  haskell-strict-
               haskell-syb-  haskell-tagsoup-0.14.8-167
               haskell-temporary-1.3-395  haskell-texmath-0.12.5-5
               haskell-text-conversions-0.3.1-124  haskell-text-icu-
               haskell-th-compat-0.1.3-38  haskell-th-lift-instances-0.1.19-27
               haskell-these-  haskell-time-compat-
               haskell-time-manager-0.0.0-235  haskell-tls-1.5.7-24
               haskell-uniplate-1.6.13-116  haskell-unix-time-0.4.7-170
               haskell-utf8-string-1.0.2-91  haskell-uuid-types-1.0.5-58
               haskell-vault-  haskell-vector-
               haskell-vector-algorithms-  haskell-wai-3.2.3-113
               haskell-wai-app-static-  haskell-wai-extra-3.1.10-4
               haskell-wai-logger-2.4.0-35  haskell-warp-3.3.20-25
               haskell-x509-1.7.6-14  haskell-x509-store-1.6.9-21
               haskell-x509-system-1.6.7-24  haskell-x509-validation-1.6.12-26
               haskell-xml-conduit-  haskell-yaml-
               haskell-zip-archive-  haskell-zlib-
               haveged-1.9.18-1  htop-3.2.0-1  hwdata-0.359-1  hwinfo-21.80-2
               iana-etc-20220427-1  ibus-1.5.26-2  icu-71.1-1
               imagemagick-  imlib2-1.9.0-3
               incidenceeditor-22.04.0-1  intel-ucode-20220419-1
               iproute2-5.17.0-3  itinerary-22.04.0-1  jansson-2.14-2
               jasper-2.0.33-2  jdk8-openjdk-8.332.u09-1
               jre-openjdk-  jre-openjdk-headless-
               jre8-openjdk-8.332.u09-1  jre8-openjdk-headless-8.332.u09-1
               json-c-0.16-1  jsoncpp-1.9.5-2  k3b-1:22.04.0-1
               kaccounts-integration-22.04.0-1  kactivities-5.93.0-1
               kactivities-stats-5.93.0-1  kactivitymanagerd-5.24.5-1
               karchive-5.93.0-1  katomic-22.04.0-1  kauth-5.93.0-1
               kbookmarks-5.93.0-1  kcalendarcore-5.93.0-1  kcalutils-22.04.0-2
               kcmutils-5.93.0-1  kcodecs-5.93.0-1  kcompletion-5.93.0-1
               kconfig-5.93.0-1  kconfigwidgets-5.93.0-1  kcontacts-1:5.93.0-1
               kcoreaddons-5.93.0-1  kcrash-5.93.0-1  kdav-1:5.93.0-1
               kdbusaddons-5.93.0-1  kde-cli-tools-5.24.5-1
               kde-gtk-config-5.24.5-1  kdeclarative-5.93.0-1
               kdeconnect-22.04.0-2  kdecoration-5.24.5-1  kded-5.93.0-1
               kdelibs4support-5.93.0-1  kdepim-addons-22.04.0-1
               kdepim-runtime-22.04.0-1  kdeplasma-addons-5.24.5-1
               kdesu-5.93.0-1  kdialog-22.04.0-1  kdnssd-5.93.0-1
               keditbookmarks-22.04.0-1  keepass-2.50-2  kemoticons-5.93.0-1
               kfilemetadata-5.93.0-1  kgamma5-5.24.5-1  kgeography-22.04.0-1
               kglobalaccel-5.93.0-1  kgpg-22.04.0-1  kguiaddons-5.93.0-1
               khealthcertificate-22.04-1  kholidays-1:5.93.0-1
               khotkeys-5.24.5-1  khtml-5.93.0-1  ki18n-5.93.0-1
               kiconthemes-5.93.0-1  kidentitymanagement-22.04.0-1
               kidletime-5.93.0-1  kimagemapeditor-22.04.0-2  kimap-22.04.0-1
               kinfocenter-5.24.5-1  kinit-5.93.0-1  kio-5.93.0-1
               kio-extras-22.04.0-2  kirigami2-5.93.0-1  kitemmodels-5.93.0-1
               kitemviews-5.93.0-1  kitinerary-22.04.0-2  kjobwidgets-5.93.0-1
               kjs-5.93.0-1  kldap-22.04.0-1  kmailtransport-22.04.0-1
               kmbox-22.04.0-1  kmenuedit-5.24.5-1  kmime-22.04.0-1  kmod-29-3
               kmousetool-22.04.0-1  knewstuff-5.93.0-1  knights-22.04.0-2
               knotifications-5.93.0-1  knotifyconfig-5.93.0-1
               kolourpaint-22.04.0-1  kompare-22.04.0-1  konsole-22.04.0-1
               kontactinterface-22.04.0-1  kopeninghours-22.04.0-1
               korganizer-22.04.0-1  kosmindoormap-22.04.0-2  kpackage-5.93.0-1
               kparts-5.93.0-1  kpeople-5.93.0-1  kpimtextedit-22.04.0-1
               kpkpass-22.04.0-1  kplotting-5.93.0-1  kpmcore-22.04.0-1
               kpty-5.93.0-1  kpublictransport-22.04.0-1
               kqtquickcharts-22.04.0-1  kquickcharts-5.93.0-1  krb5-1.19.3-1
               kross-5.93.0-1  krunner-5.93.0-1  kscreen-5.24.5-1
               kscreenlocker-5.24.5-1  kservice-5.93.0-1  ksmtp-22.04.0-1
               ksshaskpass-5.24.5-1  ksystemstats-5.24.5-1
               ktexteditor-5.93.0-1  ktextwidgets-5.93.0-1  ktnef-22.04.0-1
               ktorrent-22.04.0-1  ktouch-22.04.0-1  kunitconversion-5.93.0-1
               kwallet-5.93.0-1  kwallet-pam-5.24.5-1  kwayland-5.93.0-2
               kwayland-integration-5.24.5-1  kwayland-server-5.24.5-1
               kwidgetsaddons-5.93.0-1  kwin-5.24.5-1  kwindowsystem-5.93.0-1
               kwrited-5.24.5-1  kxmlgui-5.93.0-1  lapack-3.10.1-1
               layer-shell-qt-5.24.5-1  lib32-at-spi2-core-2.44.1-1
               lib32-cairo-1.17.6-2  lib32-colord-1.4.6-1  lib32-curl-7.83.0-1
               lib32-faudio-22.05-1  lib32-fluidsynth-2.2.7-1
               lib32-freeglut-3.2.2-2  lib32-freetype2-2.12.1-1
               lib32-fribidi-1.0.12-1  lib32-glew-2.2.0-3  lib32-glib2-2.72.1-1
               lib32-glu-9.0.2-3  lib32-gst-plugins-base-libs-1.20.2-1
               lib32-gstreamer-1.20.2-1  lib32-gtk3-3.24.33-1
               lib32-harfbuzz-4.2.1-1  lib32-icu-71.1-1  lib32-libcap-2.64-1
               lib32-libelf-0.187-1  lib32-libffi-3.4.2-4
               lib32-libglvnd-1.4.0-2  lib32-libgpg-error-1.45-1
               lib32-libnl-3.6.0-1  lib32-librsvg-2:2.54.1-1
               lib32-libtiff-4.3.0-2  lib32-libunistring-1.0-1
               lib32-libva-2.14.0-1  lib32-libva-mesa-driver-22.0.3-1
               lib32-libvdpau-1.5-1  lib32-libx11-1.8-1  lib32-libxcb-1.15-1
               lib32-libxcursor-1.2.1-1  lib32-libxml2-2.9.13-2
               lib32-mesa-22.0.3-1  lib32-mesa-demos-8.4.0-8
               lib32-mesa-vdpau-22.0.3-1  lib32-nspr-4.33-2  lib32-nss-3.78-1
               lib32-openal-1.22.0-1  lib32-pango-1:1.50.7-1
               lib32-sdl2-2.0.22-1  lib32-simplescreenrecorder-0.4.4-1
               lib32-sqlite-3.38.3-1  lib32-systemd-250.5-1  lib32-tdb-1.4.6-1
               lib32-vulkan-icd-loader-1.3.209-1  lib32-vulkan-intel-22.0.3-1
               lib32-vulkan-radeon-22.0.3-1  lib32-zlib-1.2.12-1
               libadwaita-1:1.1.1-1  libaio-0.3.113-1  libakonadi-22.04.0-1
               libappindicator-gtk3-12.10.0.r296-2  libarchive-3.6.1-1
               libavif-0.10.1-1  libbpf-0.7.0-1  libbsd-0.11.6-2  libcap-2.64-1
               libcap-ng-0.8.3-1  libcdr-0.1.7-4  libdbusmenu-glib-16.04.0-5
               libdbusmenu-gtk3-16.04.0-5  libe-book-0.1.3-11  libelf-0.187-1
               libffi-3.4.2-5  libgeotiff-1.6.0-4  libgit2-1:1.4.3-1
               libglvnd-1.4.0-2  libgpg-error-1.45-1  libgravatar-22.04.0-1
               libgudev-237-2  libhandy-1.6.2-1  libibus-1.5.26-2
               libical-3.0.14-3  libindicator-gtk3-12.10.1-10  libinih-55-2
               libinput-1.20.1-1  libkcddb-22.04.0-1  libkdegames-22.04.0-1
               libkdepim-22.04.0-1  libkgapi-22.04.0-1  libkleo-22.04.0-1
               libkomparediff2-22.04.0-1  libksane-22.04.0-1
               libkscreen-5.24.5-1  libksieve-22.04.0-1  libksysguard-5.24.5-1
               libktorrent-22.04.0-1  libmanette-0.2.6-3  libmbim-1.26.4-1
               libmfx-22.3.0-1  libmm-glib-1.18.8-1  libmnl-1.0.5-1
               libmspub-0.1.4-12  libnautilus-extension-42.1.1-1
               libnfnetlink-1.0.2-1  libnice-0.1.19-1  libnl-3.6.0-3
               libnma-1.8.38-1  libnma-common-1.8.38-1  libnotify-0.7.12-0
               libnumbertext-1.0.10-1  libopenmpt-0.6.3-1  libopenraw-0.3.1-1
               libpamac-11.3.0-1  libpamac-flatpak-plugin-11.3.0-1
               libpamac-snap-plugin-11.3.0-1  libpgm-5.3.128-2
               libphonenumber-1:8.12.47-1  libpipeline-1.5.6-1
               libpurple-2.14.9-1  libqalculate-4.1.1-2  libqmi-1.30.6-1
               libqrtr-glib-1.2.2-2  libqxp-0.0.2-8  libreoffice-still-7.2.6-3
               librsvg-2:2.54.1-1  librttopo-1.1.0-4  libsasl-2.1.28-1
               libseccomp-2.5.4-1  libsecret-0.20.5-2  libshout-1:2.4.6-1
               libspatialite-5.0.1-2  libsynctex-2022.62885-1
               libunistring-1.0-1  libusb-1.0.26-1  libva-2.14.0-1
               libva-mesa-driver-22.0.3-1  libvisio-0.1.7-7  libx11-1.8-1
               libx86emu-3.5-2  libxcb-1.15-1  libxml2-2.9.13-2
               libxnvctrl-510.68.02-1  libyuv-r2322+3aebf69d-1  libzmf-0.0.2-12
               linux-firmware-whence-20220411.705f19a-1  linux510-5.10.114-1
               linux510-virtualbox-host-modules-6.1.34-3  linux54-5.4.192-1
               linux54-virtualbox-host-modules-6.1.34-3  lsof-4.95.0-1
               luajit-2.1.0.beta3.r404.g3ee3c9cf-1  luit-20220111-1
               mailcommon-22.04.0-1  mailimporter-22.04.0-1
               manjaro-hello-0.6.7-5  manjaro-settings-manager-0.5.7-3
               marble-common-22.04.0-2  mesa-22.0.3-1  mesa-demos-8.4.0-8
               mesa-utils-8.4.0-8  mesa-vdpau-22.0.3-1  messagelib-22.04.0-1
               mhwd-nvidia-510.68.02-1  mhwd-nvidia-390xx-390.147-6
               milou-5.24.5-1  minizip-1:1.2.12-2  modemmanager-1.18.8-1
               modemmanager-qt-5.93.0-1  mono-  mpg123-1.29.3-2
               nano-6.3-1  nautilus-42.1.1-1  navit-0.5.6-4  ncurses-6.3-3
               ndctl-73-1  networkmanager-qt-5.93.0-1
               nextcloud-app-calendar-1:3.3.0-1  nextcloud-app-deck-1:1.6.2-1
               nextcloud-app-spreed-1:13.0.5-1  noto-fonts-20220502-1
               nspr-4.33-2  nss-3.78-1  nvidia-utils-510.68.02-1
               oniguruma-6.9.8-1  openal-1.22.0-1  opencl-nvidia-510.68.02-1
               openconnect-1:9.01-1  opencv-4.5.5-5  openexr-3.1.5-1
               openimageio-  openssh-9.0p1-1  openssl-1.1.1.o-1
               opensubdiv-3.4.4-10  opusfile-0.12-2  ostree-2022.3-1
               oxygen-5.24.5-1  pacman-6.0.1-7  pamac-cli-10.4.0-1
               pamac-gtk-10.4.0-1  pandoc-  pango-1:1.50.7-1
               papirus-icon-theme-20220508-1  parted-3.5-1
               partitionmanager-22.04.0-1  pavucontrol-1:5.0+r35+g964f298-1
               pciutils-3.8.0-1  pcre2-10.40-1  pdal-2.4.0-1
               perl-file-listing-6.15-1  perl-http-daemon-6.14-1
               perl-libwww-6.60-1  php-8.1.5-2  php-gd-8.1.5-2  pidgin-2.14.9-1
               pimcommon-22.04.0-1  pipewire-1:0.3.51-1  pkcs11-helper-1.29.0-1
               plasma-browser-integration-5.24.5-1  plasma-desktop-5.24.5-1
               plasma-disks-5.24.5-1  plasma-firewall-5.24.5-1
               plasma-framework-5.93.0-4  plasma-integration-5.24.5-1
               plasma-nm-5.24.5-1  plasma-pa-5.24.5-1  plasma-sdk-5.24.5-1
               plasma-systemmonitor-5.24.5-1  plasma-thunderbolt-5.24.5-1
               plasma-vault-5.24.5-1  plasma-workspace-5.24.5-1
               plasma-workspace-wallpapers-5.24.5-1  polkit-gnome-0.105-9
               polkit-kde-agent-5.24.5-1  poppler-22.05.0-1
               poppler-glib-22.05.0-1  poppler-qt5-22.05.0-1
               postgresql-libs-14.2-1  powerdevil-5.24.5-1
               print-manager-22.04.0-1  prison-5.93.0-1  protobuf-3.20.1-1
               protobuf-c-1.4.0-3  purpose-5.93.0-1  pyside6-6.3.0-1
               python-click-8.1.3-1  python-dnspython-1:2.2.1-1
               python-engineio-4.3.2-1  python-flask-2.1.2-1
               python-gdal-3.4.0-6  python-gobject-3.42.1-1
               python-jade-application-kit-3.5.7-6  python-jinja-1:3.0.3-2
               python-manjaro-sdk-0.8-2  python-more-itertools-8.12.0-2
               python-npyscreen-4.10.5-7  python-packaging-21.3-1
               python-psutil-5.9.0-2  python-pygments-2.12.0-1
               python-pyparsing-3.0.8-1  python-pyqt5-sip-12.10.1-1
               python-setproctitle-1.2.3-1  python-setuptools-1:59.7.0-1
               python-socketio-5.6.0-1  python-tldextract-3.3.0-1
               python-ujson-5.2.0-1  python-unidecode-1.3.4-1
               python-websockets-10.3-1  python-werkzeug-2.1.2-1  qgis-3.24.2-1
               qqc2-desktop-style-5.93.0-1  qt5-base-5.15.3+kde+r145-1
               qt5-script-5.15.9-1  qt5-wayland-5.15.3+kde+r44-1
               qt5-webengine-5.15.9-2  qt5-webkit-5.212.0alpha4-13
               qt6-5compat-6.3.0-2  qt6-base-6.3.0-3  qt6-declarative-6.3.0-2
               qt6-imageformats-6.3.0-1  qt6-serialport-6.3.0-1
               qt6-svg-6.3.0-1  qt6-tools-6.3.0-1  qt6-translations-6.3.0-1
               qt6-wayland-6.3.0-1  raptor-2.0.15-19  rsync-3.2.4-1
               ruby-3.0.4-1  samba-4.16.1-3  scenarist-0.7.2.rc15-1
               sddm-kcm-5.24.5-1  sdl2-2.0.22-1  shaderc-2022.1-3
               shiboken6-6.3.0-1  shotcut-22.04.25-1  shotwell-2:0.30.15-1
               signon-kwallet-extension-22.04.0-1  simple-scan-42.1-1
               simplescreenrecorder-0.4.4-1  skanlite-22.04.0-1
               smartdns-36.1-1  smbclient-4.16.1-3  snapd-2.55.4-1
               solid-5.93.0-1  sonnet-5.93.0-1  spectacle-22.04.0-1
               spice-up-1.8.2-4  sqlite-3.38.4-1  sqlite-doc-3.38.4-1
               suitesparse-5.12.0-1  sweeper-22.04.0-1  syndication-5.93.0-1
               syntax-highlighting-5.93.0-1  systemd-250.5-1
               systemd-libs-250.5-1  systemd-sysvcompat-250.5-1
               systemsettings-5.24.5-1  telegram-desktop-3.7.3-1
               telepathy-kde-common-internals-22.04.0-1  tesseract-5.1.0-2
               threadweaver-5.93.0-1  thunar-4.16.11-2
               thunar-archive-plugin-0.5.0-2  thunderbird-91.9.0-1
               timeshift-21.09.1-4  tinyxml-2.6.2-9  tor-
               tracker3-3.3.0-2  tracker3-miners-3.3.0-2  unrar-1:6.1.7-1
               vde2-2.3.2-21  vim-8.2.4827-1  vim-runtime-8.2.4827-1
               virtualbox-6.1.34-2  virtualbox-ext-vnc-6.1.34-2
               virtualbox-guest-iso-6.1.34-1  virtualbox-sdk-6.1.34-2
               vlc-  vmaf-2.3.1-1  vpnc-1:0.5.3.r506.r204-1
               vte-common-0.68.0-2  vte3-0.68.0-2  vulkan-headers-1:1.3.212-1
               vulkan-icd-loader-1.3.209-1  vulkan-intel-22.0.3-1
               vulkan-radeon-22.0.3-1  webkit2gtk-2.36.1-1
               webkit2gtk-4.1-2.36.1-1  wine-7.7-1  wine-mono-7.2.0-1
               winetricks-20220411-1  wireless-regdb-2022.04.08-1
               wpa_supplicant-2:2.10-4  xaos-4.2.1-2  xapian-core-1:1.4.19-2
               xcb-proto-1.15-1  xdg-desktop-portal-1.14.4-1
               xdg-desktop-portal-gnome-42.1-1  xdg-desktop-portal-kde-5.24.5-1
               xerces-c-3.2.3-6  xfce4-panel-4.16.4-1  xfce4-settings-4.16.2-2
               xfce4-taskmanager-  xfce4-terminal-1.0.2-1
               xfsprogs-5.16.0-1  xmlsec-1.2.34-1  xorg-xauth-1.1.2-1
               xorg-xdpyinfo-1.3.3-4  xorgproto-2022.1-1  xz-5.2.5-3
               yaz-5.31.1-2  yelp-42.1-2  zenity-3.42.1-1  zint-2.10.0-2
               zint-qt-2.10.0-2  zlib-1:1.2.12-2  zsh-5.8.1-2

Total Download Size:    1856,82 MiB
Total Installed Size:  13705,46 MiB
Net Upgrade Size:       -262,93 MiB

:: Proceed with installation? [Y/n] n

as far as I understand it for now, it is gona be safe to install what the pamac upgrade is wanting to install , same as you say it. I gona give it a try.

Looks like there was XFCE installed, but not everything was removed. thunar and xfce4- packages still there.