USB Ports stop working

Hello guys,
Im having this Problem in the last month or so that 2 of my USB Ports stopp working for no reason.
whatever is plugged in there stops getting detected. When i run lsusb the devices that are plugged in there arent shown.
I have bought this new Laptop a couple of months ago. I have a thinkpad E590 Quad Core Intel Core i7-8565U, Kernel: 4.19.56-1-MANJARO x86_64.
I first noticed it when i was playing some CS:GO where the mouse started lagging, but today the 2 Ports stopped working completely but it was ok after restarting.
thanks in advance!!

i forgot to mention that im on KDE and uptodate

System: Host: penguin-pc Kernel: 4.19.56-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: KDE Plasma 5.16.2
Distro: Manjaro Linux
Machine: Type: Laptop System: LENOVO product: 20NBCTO1WW v: ThinkPad E590 serial:
Mobo: LENOVO model: 20NBCTO1WW v: SDK0J40709 WIN serial: UEFI: LENOVO v: R0YET25W (1.08 )
date: 11/28/2018
Battery: ID-1: BAT0 charge: 10.7 Wh condition: 44.3/45.0 Wh (99%) model: LGC 01AV445 status: Discharging
CPU: Topology: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP arch: Kaby Lake rev: B L2 cache: 8192 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31880
Speed: 1193 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 1193 2: 958 3: 1436 4: 1198 5: 916 6: 1093 7: 1229
8: 1251
Graphics: Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0
Device-2: Advanced Micro Devices [AMD/ATI] Lexa PRO [Radeon RX 550/550X] vendor: Lenovo driver: amdgpu v: kernel
bus ID: 03:00.0
Display: x11 server: X.Org 1.20.5 driver: amdgpu,intel FAILED: ati unloaded: modesetting resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics (Whiskey Lake 3x8 GT2) v: 4.5 Mesa 19.1.1 direct render: Yes
Audio: Device-1: Intel Cannon Point-LP High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel
bus ID: 00:1f.3
Sound Server: ALSA v: k4.19.56-1-MANJARO
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8168 v: 8.047.01-NAPI
port: 2000 bus ID: 04:00.0
IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: e8:6a:64:aa:e6:43
Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: 2000 bus ID: 05:00.0
IF: wlp5s0 state: up mac: 48:f1:7f:a5:98:03
IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Drives: Local Storage: total: 238.47 GiB used: 120.74 GiB (50.6%)
ID-1: /dev/nvme0n1 vendor: Toshiba model: KBG30ZMT256G size: 238.47 GiB
Partition: ID-1: / size: 233.43 GiB used: 120.74 GiB (51.7%) fs: ext4 dev: /dev/nvme0n1p2
Sensors: System Temperatures: cpu: 48.0 C mobo: N/A gpu: amdgpu temp: 42 C
Fan Speeds (RPM): cpu: 3300
Info: Processes: 252 Uptime: 1h 27m Memory: 15.39 GiB used: 2.18 GiB (14.2%) Init: systemd Compilers: gcc: 9.1.0
Shell: bash v: 5.0.7 inxi: 3.0.34

Have you tried it booting with a live disc? If so did the USB ports work then?

Test newer and older kernels.

Bios update?

i will try to do that, do you have any advice which one should i install?

the ports are working fine, i think the problem is with the mouse and linux, because on windows it worked just fine.

Update: the problem is with the mouse, when it lags the computer stop detecting it and it goes off for no reason although on Windows it did work fine

Please use formatting for your system info for better readability:

If it's a wireless mouse try changing/charging batteries.

1 Like

thanks for the advice,
the problem was just the cable.. when i run dmesg it shows... Cable could be not working.

Wow, Windows also works with defective cables. :smiley:

3 Likes

Lol :sweat_smile:
It turned out to be that the cable was bad and I had to cut some of it..
the cable was fine in the time i ran Windows this is why i thought it could be a problem with the drivers on Linux because it has no drivers in Linux. But anyway Its so cool that you can write here and people try to help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.