Usb ports stop working properly

all the sudden after updates my usb ports stopped working. i tried everything i found searching and the only thing that works is removing TLP which sucks because it helps the battery. i also tried to to disable “USB_AUTOSUSPEND” in tlp settings…it asks for my password to save config but doesn’t hold after reboot? appreciate the help

> System:    Kernel: 5.10.32-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.21.4 Distro: Manjaro Linux 
>            base: Arch Linux 
> Machine:   Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X712DAP_M712DA v: 1.0 serial: <filter> 
>            Mobo: ASUSTeK model: X712DAP v: 1.0 serial: <filter> UEFI: American Megatrends v: X712DAP.301 date: 03/02/2020 
> Battery:   ID-1: BAT0 charge: 22.8 Wh (75.0%) condition: 30.4/32.1 Wh (94.7%) volts: 7.9 min: 7.9 model: ASUSTeK ASUS Battery 
>            status: Discharging 
> CPU:       Info: Dual Core model: AMD Ryzen 3 3250U with Radeon Graphics bits: 64 type: MT MCP arch: Zen/Zen+ note: check 
>            rev: 1 cache: L2: 1024 KiB 
>            flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 20761 
>            Speed: 1235 MHz min/max: 1400/2600 MHz boost: enabled Core speeds (MHz): 1: 1235 2: 1223 3: 1253 4: 1265 
> Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Picasso vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 02:00.0 
>            Display: x11 server: X.Org 1.20.11 driver: loaded: amdgpu,ati unloaded: modesetting resolution: 1920x1080~60Hz 
>            OpenGL: renderer: AMD Radeon Vega 3 Graphics (RAVEN2 DRM 3.40.0 5.10.32-1-MANJARO LLVM 11.1.0) v: 4.6 Mesa 21.0.3 
>            direct render: Yes 
> Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel v: kernel 
>            bus-ID: 02:00.1 
>            Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A bus-ID: 02:00.5 
>            Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
>            bus-ID: 02:00.6 
>            Sound Server-1: ALSA v: k5.10.32-1-MANJARO running: yes 
>            Sound Server-2: JACK v: 0.125.0 running: no 
>            Sound Server-3: PulseAudio v: 14.2 running: yes 
>            Sound Server-4: PipeWire v: 0.3.26 running: no 
> Network:   Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel bus-ID: 01:00.0 
>            IF: wlp1s0 state: up mac: <filter> 
> Drives:    Local Storage: total: 931.51 GiB used: 7.75 GiB (0.8%) 
>            ID-1: /dev/sda vendor: Western Digital model: WDS100T2B0B-00YS70 size: 931.51 GiB 
> Partition: ID-1: / size: 896.48 GiB used: 7.75 GiB (0.9%) fs: ext4 dev: /dev/sda2 
>            ID-2: /boot/efi size: 299.4 MiB used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1 
> Swap:      ID-1: swap-1 type: partition size: 19.35 GiB used: 0 KiB (0.0%) dev: /dev/sda3 
> Sensors:   System Temperatures: cpu: 46.5 C mobo: 46.0 C gpu: amdgpu temp: 46.0 C 
>            Fan Speeds (RPM): cpu: 2400 
> Info:      Processes: 178 Uptime: 2h 59m Memory: 17.59 GiB used: 1.73 GiB (9.8%) Init: systemd Compilers: gcc: N/A 
>            Packages: 1182 Shell: Bash v: 5.1.0 inxi: 3.3.04 

Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE

       video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

Hi @brent .
Welcome to the forum.
I wonder whether you have any experience on Linux before, because my questions could be annoying for you.

Do you have installed manjaro-firmware package and also which is the output of the following terminal command:
Could you please install another kernel like linux54 and see whether you have the same problem?


1 Like

To disable USB autosuspend try this:

In GRUB add to cmdline:

Don’t forget to sudo update-grub afterwards.

to check:
cat /sys/module/usbcore/parameters/autosuspend
should return -1
default was 2

1 Like

hi, thank you and thank you for the reply. i have decent linux experience so i should be ok.
manjaro-firmware is installed by default for me…i’ll try the different kernel…

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 13d3:56dd IMC Networks USB2.0 HD UVC WebCam
Bus 001 Device 004: ID 8087:0a2b Intel Corp. Bluetooth wireless interface
Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 002: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

thank you i’ll try this…

which line do i add it to?

GRUB_CMDLINE_LINUX_DEFAULT=“quiet apparmor=1 security=apparmor resume=UUID=2832392e-24fc-4339-8a83-e586d402e266 udev.log_priority=3”

changing to kernel linux54 didn’t change anything…i thought the amd ryzen do best on the newer kernels?

I think this may work, just want to make sure I add to the correct line before I save and sudo update-grub… appreciate the help :blush:

You want to add to this line:


Just make sure it is within the quotation marks with the other entries.


got you… that did the trick now all ports are working…thank you i appreciate the help from you and j8a. do i mark this as solved?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.