Usb not work All Manjaro aarch64 Raspberry 3B+


#1

Good afternoon!
When the power is connected at the very beginning of the download, it gives an error:

Devices work, but only separately can not.
This is a keyboard and mouse!


On Manjaro for rp2 armv7h there is no such problem

as much as solve the problem?

I apologize for my google translator


#2

So you are saying that USB does not work on aarch64 raspberry pi image?
Is this before or after a kernel update?


#3

I tried from version 18.12, and the current one does not work correctly.


#4

So it did not work in 18.12 either?


#5

The problem I understood is not only manjaro, I tried archlinux-arm-rp3 the same thing.
We’ll have to sit on the armv7 from rp2


#6

It’s probably something in the kernel then. The mainline kernel, which both Arch and Manjaro use for aarch64 has issues with USB on the rock64 too. So it’s not even only on rpi3.


#7

I just created a new image, that contains the new kernel and my Logitech Keyboard+mouse USB wireless combo worked fine out of the box on my 3B.
I don’t have a 3B+, but I don’t think they changed the USB bus from the B to the B+.
So I can’t replicate this issue.


#8

I also have no problems with the logitech keyboard.

The problem is only with the company: A4Tech


#9

Maybe they don’t have drivers in the aarch64 kernel.