USB Headset not working since attempt at Pipewire

I’ve been battling this for 4 to 5 days now and I’m out of ideas on anything to do.

about a week ago I attempted to go to manjaro-pipewire and use that upgrade. Since then, I’ve had nightmares getting my USB headset to work which is an H600 Logitech wireless. The device has worked perfectly when on pulseaudio. I had it down to a reset of pipewire services in systemctl. That work around however stopped working altogether and I was unable to get any audio from the headset. Speakers worked fine in every instance which was 5/16" audio cable speakers.

I gave up on pipewire and attempted to go back into pulse only to have it not work either.

Presently I have a mess of pipewire and pulseaudio files from the manjaro-* packages that are wound into each other. Even including KDE packages in the XFCE system which confuses me anymore.

Presently here’s my situation:

Audio works on the speakers at all times if they are selected.
If USB headset is selected, for example, it will either not play, or if I am using Firefox and YouTube for example, the video will act as if loading and will not resume until I mute the audio.

Audio is stating this for inxi -Fazy

  Device-1: NVIDIA GA104 High Definition Audio vendor: ZOTAC
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0a:00.1 chip-ID: 10de:228b class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: Logitech H600 [Wireless Headset]
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-3:3 chip-ID: 046d:0a29 class-ID: 0300
    serial: <filter>
  API: ALSA v: k5.15.154-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 1.0.3 status: active with: 1: wireplumber
    status: active 2: pipewire-alsa type: plugin tools: pw-cat,pw-cli,wpctl
  Server-4: PulseAudio v: 17.0 status: active
    tools: pacat,pactl,pavucontrol,pulsemixer

Throwing in other things that might help:
lsmod | grep ‘^snd’ | column -t

snd_hrtimer            16384   1   
snd_seq                94208   7   snd_seq_dummy
snd_usb_audio          397312  3   
snd_usbmidi_lib        45056   1   snd_usb_audio
snd_rawmidi            53248   1   snd_usbmidi_lib
snd_seq_device         16384   2   snd_seq,snd_rawmidi
snd_hda_codec_realtek  167936  1   
snd_hda_codec_generic  98304   1   snd_hda_codec_realtek
snd_hda_codec_hdmi     81920   1   
snd_hda_intel          61440   4   
snd_intel_dspcfg       32768   1   snd_hda_intel
snd_intel_sdw_acpi     20480   1   snd_intel_dspcfg
snd_hda_codec          184320  4   snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core           118784  5   snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hwdep              20480   2   snd_usb_audio,snd_hda_codec
snd_aloop              40960   3   
snd_pcm                163840  6   snd_hda_codec_hdmi,snd_hda_intel,snd_usb_audio,snd_hda_codec,snd_aloop,snd_hda_core
snd_timer              49152   4   snd_seq,snd_hrtimer,snd_aloop,snd_pcm
snd                    126976  36  snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_usb_audio,snd_usbmidi_lib,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_aloop,snd_pcm,snd_rawmidi```

ls -l /dev/snd
```total 0
drwxr-xr-x  2 root root       60 May  5  2024 by-id
drwxr-xr-x  2 root root      140 May  5  2024 by-path
crw-rw----+ 1 root audio 116,  6 May  5  2024 controlC0
crw-rw----+ 1 root audio 116, 15 May  5  2024 controlC1
crw-rw----+ 1 root audio 116, 20 May  5  2024 controlC2
crw-rw----+ 1 root audio 116, 23 May  5  2024 controlC3
crw-rw----+ 1 root audio 116, 14 May  5  2024 hwC1D0
crw-rw----+ 1 root audio 116, 19 May  5  2024 hwC2D0
crw-rw----+ 1 root audio 116,  3 May  5  2024 pcmC0D0c
crw-rw----+ 1 root audio 116,  2 May  5  2024 pcmC0D0p
crw-rw----+ 1 root audio 116,  5 May  5  2024 pcmC0D1c
crw-rw----+ 1 root audio 116,  4 May  5  2024 pcmC0D1p
crw-rw----+ 1 root audio 116, 11 May  5  2024 pcmC1D10p
crw-rw----+ 1 root audio 116, 12 May  5  2024 pcmC1D11p
crw-rw----+ 1 root audio 116, 13 May  5  2024 pcmC1D12p
crw-rw----+ 1 root audio 116,  7 May  5  2024 pcmC1D3p
crw-rw----+ 1 root audio 116,  8 May  5  2024 pcmC1D7p
crw-rw----+ 1 root audio 116,  9 May  5  2024 pcmC1D8p
crw-rw----+ 1 root audio 116, 10 May  5  2024 pcmC1D9p
crw-rw----+ 1 root audio 116, 17 May  5  2024 pcmC2D0c
crw-rw----+ 1 root audio 116, 16 May  5  2024 pcmC2D0p
crw-rw----+ 1 root audio 116, 18 May  5  2024 pcmC2D2c
crw-rw----+ 1 root audio 116, 22 May  5 19:04 pcmC3D0c
crw-rw----+ 1 root audio 116, 21 May  5  2024 pcmC3D0p
crw-rw----+ 1 root audio 116,  1 May  5  2024 seq
crw-rw----+ 1 root audio 116, 33 May  5  2024 timer```

```Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 2516:0051 Cooler Master Co., Ltd. AMD SR4 lamplight Control
Bus 001 Device 003: ID 046d:0a29 Logitech, Inc. H600 [Wireless Headset]
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 046d:c31c Logitech, Inc. Keyboard K120
Bus 003 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 006 Device 002: ID 1058:25ee Western Digital Technologies, Inc. My Book 25EE```

udo pactl list short sinks:
```Specify nothing, or one of: modules, sinks, sources, sink-inputs, source-outputs, clients, samples, cards, message-handlers```

cat /proc/asound/pcm
```00-00: Loopback PCM : Loopback PCM : playback 8 : capture 8
00-01: Loopback PCM : Loopback PCM : playback 8 : capture 8
01-03: HDMI 0 : HDMI 0 : playback 1
01-07: HDMI 1 : HDMI 1 : playback 1
01-08: HDMI 2 : HDMI 2 : playback 1
01-09: HDMI 3 : HDMI 3 : playback 1
01-10: HDMI 4 : HDMI 4 : playback 1
01-11: HDMI 5 : HDMI 5 : playback 1
01-12: HDMI 6 : HDMI 6 : playback 1
02-00: ALCS1200A Analog : ALCS1200A Analog : playback 1 : capture 1
02-02: ALCS1200A Alt Analog : ALCS1200A Alt Analog : capture 1
03-00: USB Audio : USB Audio : playback 1 : capture 1```

Let me know what info I can provide

Hi and welcome to manjaro,

What exactly did you do ?

To ‘switch’ to pipewire (and/or ensure you have the right packages):

sudo pacman -Syu manjaro-pipewire

If you are describing a dependency issue when attempting to do the reverse, ie:

sudo pacman -Syu manjaro-pulse

Then that is expected and documented. ex:

Try adding pipewire-pulse and if you do not need jack I would get rid of that as well.
If you do need jack install pipewire-jack and remove manjaro-pulse

Will attempt both in the morning. Thank you both for your responses.
As for what specifically I did I wish I could tell you but it was a mess of dependency chasing to try to cull all pipewire stuff out which ended up in dependency lock. (i.e. can’t pipewire caues it requires a pulsedependency which requires a kde related dependency which requires something else even further that made me hesitant to proceed.)

Let me attempt the:
sudo pacman -Syu manjaro-pulse pulseaudio-bluetooth
and report back.

That failing, I will attempt pipewire-pulse and remove jack. Appreciate it.


No info in this report.

As my posted stated, I am going to attempt it and report back. It was late at night when I posted that. It was to keep the thread alive so it wasn’t idle

sudo pacman -Syu manjaro-pulse pulseaudio-bluetooth

Ran this one and it didn’t seem to yield any results. How it seems to work now is if I reboot, the first time it runs audio it seems to work fine and then youtube (for example) will get stuck loading with no error messages and the audio just stops working on the headset. If I change it to the native speakers on the computer, it seems to work fine.

Seeing as I’ve had nothing but trouble from Pipewire as that was what caused this whole mess I’m avoiding them altogether.

Okay so I have a bit more info on this whole issue.

I attempted to go back to pulseaudio from this using the above commands and rebooting.
Here’s my findings.
It works on reboot but only for ONE play thru of like a YouTube video. After that, all audio for my headset absolutely turns off and YouTube videos for example refuse to play as if they’re loading endlessly (until I mute them then they work fine but obviously without Audio)

It’s like when it plays sound just once then the system breaks until I prompt another command when everything just worked before I touched Pipewire which kinda broke everything.

absolute missmatch
decide what you want

Data in post #1 shows pipewire-alsa installed, to use PipeWire as default output for ALSA devices (onboard audio and USB headset)

If metapackage manjaro-pulse is working as expected it should install 3 packages:

  • pulseaudio to replace pipewire-pulse
  • pulseaudio-alsa to replace pipewire-alsa
  • pulseaudio-bluetooth

To check the default ALSA output

aplay -L

If pulseaudio-alsa is installed response should look like this:

    Default ALSA Output (currently PulseAudio Sound Server)

Response should also show ALSA audio playback devices:
  DEV=0 - nVidia HDMI
  DEV=1 - Onboard Audio
  DEV=2 - Headset

I suggest clear old user configuration settings for PulseAudio in home folder and restart pulseaudio.service

rm ~/.config/pulse/* ; systemctl --user restart pulseaudio

To check audio cards detected in PulseAudio (or pipewire-pulse)

pactl list cards

and audio streams from youtube to PulseAudio (or pipewire-pulse)

pactl list sink-inputs
1 Like

Appreciate it Nikgnomic. I found part of the issue. I stupidly deleted pulseaudio initially before installing Pipewire thinking the two wouldn’t run on with each other. So that’;s the cause of it.

Issue resolved. Went thru /var/log and opened up pacman.log
Found started to reinstall the first components and now it’s working and on the new system then manjaro-pipewire. Seems to be okay now. Thanks every one.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.