Usb drive not mounting automatically

Hello, fora.

I have the following Manjaron runnig using the Deepin DE. Can't get an external USB disk correctly mounted. It nigther appears in the file manager nor creates a new device under /dev directory.

$ lsb_release -a
LSB Version: n/a
Distributor ID: ManjaroLinux
Description: Manjaro Linux
Release: 18.0.4
Codename: Illyria

$ uname -a
Linux lenovogaml 5.1.19-1-MANJARO #1 SMP PREEMPT Sun Jul 21 14:17:15 UTC 2019 x86_64 GNU/Linux

dmesg shows:

[39225.521853] usb 3-2: new SuperSpeed Gen 1 USB device number 5 using xhci_hcd
[39225.540681] usb 3-2: New USB device found, idVendor=0480, idProduct=0900, bcdDevice= 3.15
[39225.540683] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[39225.540685] usb 3-2: Product: External USB 3.0
[39225.540686] usb 3-2: Manufacturer: TOSHIBA
[39225.540687] usb 3-2: SerialNumber: 20180219014631F
[39749.532276] usb 3-2: USB disconnect, device number 5
[39832.321837] usb 3-2: new SuperSpeed Gen 1 USB device number 6 using xhci_hcd
[39832.341230] usb 3-2: New USB device found, idVendor=0480, idProduct=0900, bcdDevice= 3.15
[39832.341238] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[39832.341242] usb 3-2: Product: External USB 3.0
[39832.341245] usb 3-2: Manufacturer: TOSHIBA
[39832.341248] usb 3-2: SerialNumber: 20180219014631F

lsusb -v gets:

Bus 003 Device 006: ID 0480:0900 Toshiba America Inc
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 3.00
bDeviceClass 0
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 9
idVendor 0x0480 Toshiba America Inc
idProduct 0x0900
bcdDevice 3.15
iManufacturer 1 TOSHIBA
iProduct 2 External USB 3.0
iSerial 3 20180219014631F
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 0x002c
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0x80
(Bus Powered)
MaxPower 896mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 2
bInterfaceClass 8 Mass Storage
bInterfaceSubClass 6 SCSI
bInterfaceProtocol 80 Bulk-Only
iInterface 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0400 1x 1024 bytes

udisks2 package is installed and the system itself was installed using the USB port. I don't know what's going on. How can I diagnose the problem in the right way in order to deal with it?

T.I.A.

Kernel 5.1. is EOL

Great @antman.
Changed to 4.19.62 and everything is fine now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark