USB device over current status

My PCs USB 3.0 stopped working, tried restarting, now I get “USB device over current status detected” and shuts down in 15 seconds. Have tried starting with all USB disconnected but same result. My search has yielded very little; anyone have any suggestions?

Your description is very vague… start by figuring out if it is software or hardware. Boot some live distro and test with it.
If it is hardware, it can be computer side of peripheral side. If it happens on the front ports of a desktop - check the cables connecting the front port with the motherboard. Test another port. Test another peripheral.

My personal experience - the periphery device has died and short circuits… I had it with a printer that suffered a power surge.

I found the answer – problem solved when I disconnected the USB ports on the front of the PC. Disconnected at the MB. Did not initially suspect them because there was nothing plugged into them and I do not usually use them. Anyway, problem solved (I can live without the front USB ports).

EDIT: Thanks, Teo. I did not see your response until after I had posted this.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.