Только us раскладка на lockscreen KDE

Всем привет,часто после блокировки экрана раскладка остается русской,что очень неудобно,вводишь пароль и только потом понимаешь,что ввел на русском.Подскажите пожалуйста есть ли возможность принудительно включить только us раскладку на экране блокировки?

редактировать файл
/usr/share/sddm/scripts/Xsetup
и писать
setxkbmap "us"

No, it’s not about SDDM, it’s about lock screen.

@redL1nE_87
Попробуй в системных настройках перенести русскую раскладку ниже английской:

1 Like

Она и так перенесена) В каком конфиге вообще lockscreen настраивается?

Ну, локальные настройки в ~/.config/kscreenlocker, а где глобальные - хз. В локальных настройках именно блокировки экрана нет ни намёка на конфигурацию раскладки.
Можно попробовать посмотреть в plasma-localerc и plasma-locale-settings.sh, которые в тех же папках лежат. Если толку от их редактирования не будет, можно их просто удалить – они восстановятся в дефолтном виде при новом входе в систему. Сложно сказать, что именно может помочь - у меня всё на английском, и локаль так же – всё в бритиш кроме единиц измерения и валюты, а русский только как дополнительная раскладка. Сам не хочу морочиться с такими вопросами, не хватало ещё)

Русская раскладка остается на lockscreen,если я не переключу ее на английский перед блокировкой. К примеру.я печатаю этот текст на русском, блокирую экран - русская раскладка, перед блокировкой меняю на us - английская.

Да я с первого раза понял.
Говорю же, точного рецепта у меня нет. Попробуй то, что Богдан во втором сообщении предложил. Ещё можно вообще убрать все раскладки, установить fcitx и настроить переключение языков через него. Эта штука сбрасывает на дефолтный язык при переключении фокуса на другое приложение. В консоли только работать не будет, или какие-то хитрые настройки нужны.
Я себе так сделал:

What is this language?

Попробовал,не работает метод(

Russian. I don’t speak it, i know a few words, but for writing i have to use a translator :slight_smile:

@redL1nE_87 - Извините, я неправильно понял, в чем проблема

Хорошо,
Создайте файл setxkbmap.sh с этой командой в нем

#!/bin/bash
setxkbmap "us"

сделать его исполняемым и добавить его в уведомления
в Уведомлениях перейдите в Заставку, выберите Экран заблокирован и включите команду запуска и добавьте
Это должно сбросить на макет на английский

En:
Ok,
Make a file called setxkbmap.sh in your home directory, make it executable and add it to notifications in Notifications go to Screen Saver, select Screen locked and enable Run Command and add the setxkbmap.sh
That should reset the layout to US

image

1 Like

Thanks, it works, but after unlocking I can’t switch layouts, only English remains.

You have to right click on it first and then it starts working. This needs a bit more investigating as is just a workaround once i realized what the actually problem was. Sorry for writing back also in english, i exceeded my Russian after the first 3 words :slight_smile:
Probably writing a systemd service is better approach and have one for the unlock procedure too, so it automatically refreshes the layouts.

yes,it starting to work only after right click…

1 Like

how can i get this?)

I have to think about it, but if you change the script to

setxkbmap "us,ru"

or add as many you like in the order you want, the KDE will do the same, so the switch will work.

Works excellent!! i set setxkbmap “us,ru” to unlock notification command.
Thanks,man,you really helped

It can be all on the lock command and only one script. I just made a test as i have
setxkbmap "es,ro,us"
and works in that order, and if i change the order works too respecting that order :slight_smile:
Cheers!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.