URxvt transparency

Hi, the URxvt terminal don't read the alpha set in the .Xresources file. [75]#222D1 change the tone of color but don't set the 75% of transparency. Somebody can help me ?. Thanks!

This might be related to the compositor, which is picom. Recently some adjustments had to be made in order to move from compton to picom, more specifically the config file had to be renamed.

Check if in your home directory you have this file

~/.config/compton.conf

and if yes, rename it to picom.conf, so that it becomes

~/.config/picom.conf

Also, make sure you set the correct color code for the background of the terminal in the ~/.Xresources file.

This is not a valid color code, you're missing a character (number/letter), maybe #222D31 is the one you're referring to, which is the default one.

After that logout/login or reboot your machine and check if the transparency has changed to the value you set.

3 Likes

you also need to set:

URxvt*depth : 32

1 Like

Hi, i do the steps that you show me, but don't work, and when i type sudo picom, i have a fatal error output and say Failed to create a new session.

Please copy and paste the error here. Remember to use the '</>' option for terminal output.

Forum kindly sponsored by