Uplay not connecting (have to use VPN)

Not sure if it is a Steam/Proton issue or manjaro.

When I try to play a game that uses Uplay it does not work. It comes to “initializing” in Uplay and stops as if the servers are not reachable. (The same problem in Bottles).

One user on GamingOnLinux suggested using VPN. And voila… it worked. Why would this make any difference is beyond me. Tried running Steam from CLI but I couldn’t see any information that would explain this.

If I start the games in Win11 (same computer, same network) it works without any problems.

Any suggestions?

P. S. If there is an error log I can access and include please let me know and I will try to do so.

Edit: Added P.S. and Bottles info.

I used Uplay recently again with “Assassin’s Creed Revelation” on Steam directly with proton. I have not such a problem at all.

The only thing what could be a difference in my humble opinion is the response time of the DNS-Server. A VPN has its own DNS-Server which might have a much faster response time.

Install dnsmasq:

pamac install dnsmasq

and use it in NetworkManager:

echo -e "[main]\ndns=dnsmasq" | sudo tee /etc/NetworkManager/conf.d/dns.conf

Then restart it:

sudo systemctl restart NetworkManager && journalctl --boot 0 --unit NetworkManager --follow

Dnsmasq is now used as dns cache, so it will not ask everytime for a IP at the providers DNS-Server, but save the recent result and call it from dnsmasq. That reduces the dns delay.

Unfortunately it does not help.

It takes a while at the Initializing step and then returns: error connection lost (A Ubisoft service is currently unavailable).

As said, the moment I enable VPN it works, if I turn it off the error repeats.

It is funny that Assassins Creed Odyssey worked without problems a while ago. But I did change the motherboard and installed Manjaro again in the mean time. I am not sure if this is a factor or not.

Honestly… do you run a software firewall? Otherwise I would say Ubisoft just blocked your IP…

What is the output of:

cat /etc/resolv.conf 


Thank you for replying.

Output is:

# Generated by NetworkManager
options edns0 trust-ad

The thing is… it works in windows 11, connection and all. If it would be an IP issue I don’t think it would work in Windows.

My guess is the network setup is not to be blamed. Maybe firewall but I don’t think I use one. ufw is inactive… All other games work and connect including Rockstar’s. If it’s a firewall issue I did not change any settings so it may have to do with some default Manjaro options (as said it is a fresh install maybe a month old).


GitHub - ValveSoftware/Proton: Compatibility tool for Steam Play based on Wine and additional components

A log file will be generated in your home folder.

Also start steam on the terminal.

Ok. So, the log is like miles long and it does not tell me much. For now I gave up on finding a solution.

I would also like to add that I tested in Ubuntu 22.10 as well and the problem is also present. So it is not a Manjaro issue it seems.