Upgrading spotify with pamac fails

spotify 1:1.1.72.439-2 (1:1.1.72.439-1) AUR

> pamac upgrade
==> Verifying source file signatures with gpg...
    spotify-1.1.72.439-Release ... FAILED (invalid public key 8FD3D9A8D3800305A9FFF259D1742AD60D811D58)
==> ERROR: One or more PGP signatures could not be verified!
> gpg --delete-key 8FD3D9A8D3800305A9FFF259D1742AD60D811D58
> gpg --keyserver keyserver.ubuntu.com --recv-key 8FD3D9A8D3800305A9FFF259D1742AD60D811D58
gpg: key D1742AD60D811D58: public key "Spotify Public Repository Signing Key <tux@spotify.com>" imported
gpg: Total number processed: 1
gpg:               imported: 1

also tried several other keyservers.

> pamac upgrade
==> Verifying source file signatures with gpg...
    spotify-1.1.72.439-Release ... FAILED (invalid public key 8FD3D9A8D3800305A9FFF259D1742AD60D811D58)
==> ERROR: One or more PGP signatures could not be verified!

any idea how to fix this? or is aur broken?

Try clearing the Pamac build folder and try again as the recent comments on the AUR page suggest.

Example if your username is keevitaja:

sudo rm -rf /var/tmp/pamac-build-keevitaja/spotify/
2 Likes

Thank you.

Clearing the Pamac build folder worked for me.

Well, then…

mark-it-solved

shamlessly stolen from @tbg

Well then.

Need to wait for OP :smirk:

Oh, you’re not the OP. :laughing:

I just wanted an excuse to use that graphic. :grin:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.