upgrade to opengl-5.14.1 broke packages using any widgets (breeze)

I'm using manjaro on the Pinebook Pro (aarch64) with pinefrost/gles.
Since the upgrade to qt 5.14.1 any packages using widgets (and through that breeze.so) are crashing on startup.

Backtrace with gdb:

$ gdb speedcrunch
(gdb) run
Starting program: /usr/bin/speedcrunch
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0xfffff32520f0 (LWP 2870)]
[New Thread 0xffffebf490f0 (LWP 2871)]

Thread 1 "speedcrunch" received signal SIGSEGV, Segmentation fault.
0x0000000000000000 in ?? ()
(gdb) bt
#0  0x0000000000000000 in ?? ()
#1  0x0000fffff29b1bd0 in ?? () from /usr/lib/qt/plugins/styles/breeze.so
#2  0x0000fffff20ae658 in ?? () from /usr/lib/libKF5ConfigWidgets.so.5
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
(gdb)

May or may not be related but telegram and nextcloud-client are both crashing for me on startup (and just generally) since qt 5.14.1, both of which can be managed from the system tray.

Telegram also crashes for me on start up after updating.

Forum kindly sponsored by