Upgrade to 4.19 disables my amdgpu


#21

I thought it was already gone. It’s a leftover from the time when I ported the experimental mhwd work to a clean pacman package.


#22

Seems amdgpu isn’t playing nice at all so I’m back to radeon for the time being.


#23

No, the amdgpu-experimental package takes care of that.


#24

So we should remove it from the repos? Never got a note to do so …


#25

I think thats my bad, because I thought that with the removal of the old amdgpu-experimental package, that was split up into that mhwd-db-amdgpu-experimental as well as amdgpu-experimental it would also remove that package from the repo. A big SORRY for that!

EOL

  • mhwd-db-amdgpu-experimental <- please remove this

still in support:

  • amdgpu-experimental

#26

I must be missing something, because I can’t get this to work at all. Also vulkan seems to be disabled as well, even though I’m sure my R9 290x supports it. Any ideas?


#27

Vulkan only supports AMDGPU, so you need AMDGPU. An I have no Idea why it does not work for you. I’ve tried with a “R9 390” (that is a 290 based card) and it just works with Kernel 4.19 after amdgpu-experimental was installed.


#28

amdvlk is vulkan driver


#29

Ok I got amdgpu-experimental to work by using amdgpu.dc=0
However, I get these errors from dmesg

7.166600] [drm:uvd_v4_2_start [amdgpu]] *ERROR* UVD not responding, trying to reset the VCPU!!!
[    8.186883] [drm:uvd_v4_2_start [amdgpu]] *ERROR* UVD not responding, trying to reset the VCPU!!!
[    9.207140] [drm:uvd_v4_2_start [amdgpu]] *ERROR* UVD not responding, trying to reset the VCPU!!!
[   10.227416] [drm:uvd_v4_2_start [amdgpu]] *ERROR* UVD not responding, trying to reset the VCPU!!!
[   11.247688] [drm:uvd_v4_2_start [amdgpu]] *ERROR* UVD not responding, trying to reset the VCPU!!!
[   12.267966] [drm:uvd_v4_2_start [amdgpu]] *ERROR* UVD not responding, trying to reset the VCPU!!!
[   13.288239] [drm:uvd_v4_2_start [amdgpu]] *ERROR* UVD not responding, trying to reset the VCPU!!!
[   14.308494] [drm:uvd_v4_2_start [amdgpu]] *ERROR* UVD not responding, trying to reset the VCPU!!!
[   15.328771] [drm:uvd_v4_2_start [amdgpu]] *ERROR* UVD not responding, trying to reset the VCPU!!!
[   16.349044] [drm:uvd_v4_2_start [amdgpu]] *ERROR* UVD not responding, trying to reset the VCPU!!!
[   16.369091] [drm:uvd_v4_2_start [amdgpu]] *ERROR* UVD not responding, giving up!!!
[   16.369130] [drm:amdgpu_device_ip_set_powergating_state [amdgpu]] *ERROR* set_powergating_state of IP block <uvd_v4_2> failed -1

also,

System:    Host: emmanuel-pc Kernel: 4.19.6-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.12.4 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: M5A99FX PRO R2.0 v: Rev 1.xx serial: <root required> UEFI: American Megatrends 
           v: 2501 date: 04/07/2014 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Hawaii PRO [Radeon R9 290/390] driver: N/A 
           Display: x11 server: X.Org 1.20.3 driver: vesa unloaded: fbdev,modesetting resolution: 1920x1080~N/A 
           OpenGL: renderer: llvmpipe (LLVM 7.0 128 bits) v: 3.3 Mesa 18.2.6

can’t seem to get the correct Hz for my resolution.


#30

Ok nevermind the previous post, it now works with amdgpu.dpm=0

System:
  Host: emmanuel-pc Kernel: 4.19.6-1-MANJARO x86_64 bits: 64 
  Desktop: Xfce 4.12.4 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: M5A99FX PRO R2.0 v: Rev 1.xx 
  serial: <root required> UEFI: American Megatrends v: 2501 date: 04/07/2014 
Graphics:
  Device-1: AMD Hawaii PRO [Radeon R9 290/390] driver: amdgpu v: kernel 
  Display: x11 server: X.Org 1.20.3 driver: amdgpu 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD Radeon R9 200 Series (HAWAII DRM 3.27.0 
  4.19.6-1-MANJARO LLVM 7.0.0) 
  v: 4.5 Mesa 18.2.6

#31

Have you reported that issue? Because since dc is the new default and provides more features like DisplayPort/HDMI Audio and in future adaptive sync (freesync). It is highly possible that the non-dc path will not be maintained and phased out.


#32

No I haven’t actually. Turns out dc wasn’t my problem. By turning it off I just reverted to vesa, allowing me to get to the desktop and gave me all those errors in dmesg.

My real issue is actually with dpm. So I left dc on and turn off dpm and that allowed me to boot with amdgpu and have vulkan running just fine.

I’m still a noob at this so still not entirely sure what dpm does or if i’ll need it, but I’m not getting any errors now so…

I’m thinking now that might have been my problem from the beginning when I upgraded to 4.19.


#33

DPM is the Dynamic Power Management.
So this could be interesting for you: https://wiki.archlinux.org/index.php/AMDGPU#R9_390_series_Poor_Performance_and/or_Instability


#34

Wow man, thanks alot. I’ve read that page so many times and completely glossed over that last part. Thought it was just specific to the 390 cards.


#35

390 and 290 are the same thing :wink: it’s just a rebranding with some minimal changes, like higher clock times. So often you have the same issues shared across the whole rebranding series.