Upgrade to 4.19 disables my amdgpu


#1

Hi, I am running an AMD FX8320 cpu with AMD R9 290x vid card. Using rEfind bootloader and running kernel 4.18. Everything was running smoothly until I upgraded the kernel to 4.19. Now I get a blank screen on boot.
Alt-F1-7 don’t work, still blank. Have to hit reset button to restart my computer and use nomodeset to get a text login screen on Alt-F2.

seeing EE open /dev/dri/card0: no such file or directory
EE screen 0 deleted because of no maching config
EE Devic(s) detected but non mach those in config file

I’m using video-amdgpu-experimental drivers

I’m a newb at this. Please help.


Can't get my amdgpu drivers to work. Stuck on radeon
#2

ok
you should have 2 kernels installed
linux418 & linux419

on boot Grub , choose details and select kernel 418

if you have put Grub-quiet
press and hold Shift or Esc or F8 on start to see Grub


#3

Thanks for replying, but I don’t have grub. I’m using refind instead. I can boot into 4.18 though.


#4

can you return

sudo pacman -Qs linux418-
sudo pacman -Qs linux419-
sudo journalctl -b -n - p 4
 ( n = 1 boot before , 2 boot before , etc  , when you have tried 419 )

provides also

inxi -SMGxxxz

#5


#6

this is a bug
https://bugs.freedesktop.org/show_bug.cgi?id=108260

STAY on linux 414 or 418
you can add headers

sudo pacman -S linux419-headers

#7


Oh ok. Installed headers but no change. I’ll stick to 418.

Thank you so much for your time.


#8

when patche will coming
you will have to change driver amdgpu --> radeon free for 419


#9

How do I do that?


#10

@tids may be answer for that i hope


#11

What exactly do you use? We do not ship MHWD settings for amdgpu-experimental anymore. If you just use the amdgpu-experimental package, its save to uninstall this one and reboot to go back to radeon.


#12


This is what I have installed


#13

With Sea Islands dont you have to add to options at /etc/default/grub
radeon.cik_support=0 amdgpu.cik_support=1
(and run sudo update-grub)
and add amdgpu to the front of MODULES in /etc/mkinitcpio.conf
(and then run sudo mkinitcpio -P)
[And reboot]

Have you done those things ?


#14

No I haven’t. I’m not using grub. I’m using reFind instead. Everything just worked.


#15

I am gonna assume the amdgpu experimental wasn’t playing well with the new kernel. Should uninstall it and only keep video-linux


#16

If using refind those options go in /boot/refind_linux.conf
(quiet is usually present for you to tell where they go)


#17

It could be related to that amdgpu experimental in mhwd. mhwd-db-amdgpu-experimental That one is not supported since forever and was never ported to the new “how to enable experimental support”. It shouldnt be there anymore for a long time but for some reason it still it.

@neoxjr try to uninstall that from mhwd (if possible):

mhwd -r pci $(mhwd -li | grep "video-" | awk '{print $1}')

if this works (only if), Otherwise please post the output.

pacman -R mhwd-db-amdgpu-experimental

next

mhwd -a pci nonfree 0300

So you’re back at radeon for now.


#18

This worked. Used @Tids option to remove using mhwd. Now I’m on video-linux with 419

I tried this first with reFind config but didn’t do anything

this is my inxi -SMGxxxz output now

Host: emmanuel-pc Kernel: 4.19.1-1-MANJARO x86_64 bits: 64 compiler: gcc
v: 8.2.1 Desktop: Xfce 4.12.4 tk: Gtk 2.24.32 info: xfce4-panel wm: xfwm4
dm: LightDM 1.28.0 Distro: Manjaro Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: M5A99FX PRO R2.0 v: Rev 1.xx
serial: UEFI: American Megatrends v: 2501 date: 04/07/2014
Graphics:
Device-1: AMD Hawaii PRO [Radeon R9 290/390] vendor: ASUSTeK
driver: radeon v: kernel bus ID: 01:00.0 chip ID: 1002:67b1
Display: x11 server: X.Org 1.20.3 driver: ati,radeon
unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: AMD HAWAII (DRM 2.50.0 4.19.1-1-MANJARO LLVM 7.0.0)
v: 4.5 Mesa 18.2.4 compat-v: 4.4 direct render: Yes


#19

Big thank you to everyone for helping me fix this. I know I could have just stayed with 418 but it was just bugging me that the newer one wasn’t working.

Didn’t know about this. I’ve been using it for a while for all my Steam games and now that I can play PC games through Steam I wanted the best performance I could get.


#20

If you’re back on the default radeon and there are no bits left of the mhwd config (hopefully). You should be able to switch to amdgpu with the amdgpu-experimental package.

I couldnt test it with your card, but with a R7 240 and 4.19 it works. :thinking:

If not you can uninstall that package to switch back to radeon.