upgrade issues

Hi,guys.
today,I run “sudo pacman -Syu”,but I can’t update.

sudo pacman -Syu
:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade…
warning: lib32-mesa: local (19.0.1+really+18.3.5-1) is newer than multilib (19.0.1-1)
warning: lib32-mesa-vdpau: local (19.0.1+really+18.3.5-1) is newer than multilib (19.0.1-1)
warning: lib32-vulkan-intel: local (19.0.1+really+18.3.5-1) is newer than multilib (19.0.1-1)
warning: lib32-vulkan-radeon: local (19.0.1+really+18.3.5-1) is newer than multilib (19.0.1-1)
warning: libva-mesa-driver: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: mesa: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: mesa-vdpau: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
:: Replace mlt-python-bindings with extra/python-mlt? [Y/n] n
warning: vulkan-intel: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: vulkan-radeon: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
resolving dependencies…
looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: installing x264 (2:157.r72db4377-1) breaks dependency ‘libx264.so=155-64’ required by ffmpeg2.8

then I tried “sudo pacman -Syyuu”

sudo pacman -Syyuu
:: Synchronizing package databases…
core 149.5 KiB 277K/s 00:01 [######################] 100%
extra 1829.1 KiB 525K/s 00:03 [######################] 100%
community 5.2 MiB 503K/s 00:11 [######################] 100%
multilib 184.2 KiB 581K/s 00:00 [######################] 100%
:: Starting full system upgrade…
warning: lib32-mesa: downgrading from version 19.0.1+really+18.3.5-1 to version 19.0.1-1
warning: lib32-mesa-vdpau: downgrading from version 19.0.1+really+18.3.5-1 to version 19.0.1-1
warning: lib32-vulkan-intel: downgrading from version 19.0.1+really+18.3.5-1 to version 19.0.1-1
warning: lib32-vulkan-radeon: downgrading from version 19.0.1+really+18.3.5-1 to version 19.0.1-1
warning: libva-mesa-driver: downgrading from version 19.0.1+really+18.3.5-1 to version 19.0.1-2
warning: mesa: downgrading from version 19.0.1+really+18.3.5-1 to version 19.0.1-2
warning: mesa-vdpau: downgrading from version 19.0.1+really+18.3.5-1 to version 19.0.1-2
:: Replace mlt-python-bindings with extra/python-mlt? [Y/n] y
warning: vulkan-intel: downgrading from version 19.0.1+really+18.3.5-1 to version 19.0.1-2
warning: vulkan-radeon: downgrading from version 19.0.1+really+18.3.5-1 to version 19.0.1-2
resolving dependencies…
looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: installing x264 (2:157.r72db4377-1) breaks dependency ‘libx264.so=155-64’ required by ffmpeg2.8

Pls help, how can I fix this issue? sorry for my bad english level.
thanks a lot to you all.

Tips for pod sting

Use a “keyword search” to make sure your question has not already been asked. For example “failed to verify key” or “sound is muted”.

Make sure you include enough detail so people know what you are running. A useful command is inxi -Fxz; copy and paste the text and format as “code” (e.g. use the </> button above).

If possible, paste text rather than upload a photo. Text is easier to read, searchable, and takes up less space on the server. Please don’t upload high-resolution photos.

For more information read this post: How to provide good information in your posts

Remember to remove all of this help text before you post.


1 Like

You have ffmpeg2.8 installed…
Do you have a reason for this package? It is not in the repos (is in the aur), and it is breaking your dependencies and not allowing you to update.

( you can see if it is “Required By” anything with pacman -Qi ffmpeg2.8 )

If you dont need it, remove it, and carry on.

( sudo pacman -Rns ffmpeg2.8 && sudo pacman -Syyuu )

PS - you didnt remove the extra help text template from the bottom of your post :wink:

1 Like

yeah,I installed 4k video downloader. this app need ffmpeg2.8.

I knew it!

…Why is everyone obsessed with that silly piece of software :nauseated_face:

If you really need it I guess you could try one of the alternative packages for x264 and ffmpeg…

How about what requires x264?
pacman -Qi x264

(by the way … this all comes from that outdated ffmpeg needing an earlier version of x264 than what is currently available … it might get fixed by the maintainer in a few days … it may never get fixed. who knows)

I got this:
Name : x264
Version : 2:155.r0a84d986-2
Description : Open Source H264/AVC video encoder
Architecture : x86_64
URL : https://www.videolan.org/developers/x264.html
Licenses : GPL
Groups : None
Provides : libx264 libx264.so=155-64
Depends On : libavcodec.so=58-64 libavformat.so=58-64 libavutil.so=56-64
liblsmash.so=2-64 libswscale.so=5-64
Optional Deps : None
Required By : ffmpeg ffmpeg2.8 gst-plugins-ugly libopenshot
libquicktime mplayer
Optional For : None
Conflicts With : libx264 libx264-10bit libx264-all
Replaces : libx264 libx264-10bit libx264-all
Installed Size : 3.70 MiB
Packager : Maxime Gauduin alucryd@archlinux.org
Build Date : 2018年08月07日 星期二 17时59分43秒
Install Date : 2018年08月18日 星期六 19时11分08秒
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

whatever,I know how to fix it now…I can remove it firstly,then update,finally I install ffmpeg2.8 again. haha

1 Like

same situation going on here with another user and that x264 / ffmpeg2.8 package

Thanks for your suggestions. I removed the software and the problem has been solved.

Hi all, i got the same warning when trying to update with pamac, did the update, pamac was showing system was updated but in terminal pacmac was showing this:

warning: libva-mesa-driver: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: mesa: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: mesa-vdpau: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: vulkan-intel: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: vulkan-radeon: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
there is nothing to do

I also had a youtube downloader app installed too… So i did the same thing as the guy above, uninstalled the application then run in terminal " sudo pacman -Syuu" because pamac was still showing that system had nothing to update and then reinstalled the application.

It is my first post and i m a linux newbie also an manjaro newbie since i m coming from ubuntu, so i would like to say thank you to all the active users here since all the problems i had so far (which were just minor details compared to what i had to deal with in my Kubuntu installation) are being mentioned here in this forum.

Thank you Manjaro community! Have a good day all!!!

Hi and welcome.
According to your output the video downloader you had wasnt the problem and isnt related.

You were updating fine, you just had some packages ‘newer’ than repos.
So as far as upgrading there was nothing to do.
The 2 ‘u’ s in your command allow for downgrade, and that is what moved your versions to be in line with the repos.

Good job searching the forums though. If you cant find what you are looking for next time feel free to open a new thread :slightly_smiling_face:

2 Likes

The thing happening here is: some updates where available, you installed them, then it turned out those packages are too unstable (cause breakages for many people, but not for all, so they may be OK for you) so they were pulled down and the older package was restored in the repos.
This creates this warning “is newer than”.

In such cases, it is possible for Manjaro developers to backport newer features and security fixes to the older version of packages if the newer one is still causing troubles. One time this cases serious problem, because such improved, older package was compiled with newer library and when the update hit and that library got updated and people who had this newer package that couldn’t work with that newer library (because it was compiled with the older version) it broke the system completely.

So for the sake of not tempting the fate, it’s better to downgrade packages to the version that is in Manjaro repos. Whenever you see this “is newer than”, just add additional u in update command so:

sudo pacman -Syyuu

This automatically adjusts packages to the version in the repo.

You may ask, why such things happen? Well, Arch is for advanced users so it pushes newest packages even if they may break some user systems. Arch expects people to be knowledgeable enough to handle it. Manjaro, on the other hand, tries to cast safety net and filters out problematic packages till the better, more stable version comes out. This isn’t perfect and sometimes that can create more troubles then it saved from, but Manjaro devs learned from the last issue and do some versioning tricks to not let that situation happen again.

So basically, for most situations you update with:

sudo pacman -Syu

If you want to forcefully refresh your pacman database, you may add another y (mostly useful on testing on unstable branch):

sudo pacman -Syyu

And if you have newer packages and want to downgrade them, add another u:

sudo pacman -Syyuu

I hope that clears it out. Manjaro as a rolling release is a completely different beast than Ubuntu, Manjaro is also different than Arch.

4 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.