Updating with software update gives me "ERROR: One or more PGP signatures could not be verified!"


#1

updating with software update gives me “ERROR: One or more PGP signatures could not be verified!”

==> Verifying source file signatures with gpg…
llvm-5.0.0.src.tar.xz … FAILED (unknown public key 0FC3042E345AD05D)
libcxx-5.0.0.src.tar.xz … FAILED (unknown public key 0FC3042E345AD05D)
libcxxabi-5.0.0.src.tar.xz … FAILED (unknown public key 0FC3042E345AD05D)
==> ERROR: One or more PGP signatures could not be verified!

What to do?


#2

From terminal:
sudo pacman-key --refresh-keys && sudo pacman -Syyu
Also you can have a look here for more info with a related “issue”:


#3

OK thanks. I had searched for PGP keys in the “update” threads on the technical forum, but got no results.


#4

You are trying to update a package that is coming from AUR not from manjaro repo. And it failed because it couldn’t identify the key that signed to those files. You need to receive that key :

gpg --recv-keys --keyserver hkp://pgp.mit.edu 0FC3042E345AD05D

Next time, when you have AUR packages that failed to install/update look up AUR comments for that package…

(Moved this to #technical-issues-and-assistance:aur)


ExpressVPN installation
#5

This did not work. I got this error:

$ sudo pacman-key --refresh-keys && sudo pacman -Syyu
[sudo] password for [REDACTED]:
gpg: refreshing 111 keys from hkp://pool.sks-keyservers.net
gpg: keyserver refresh failed: No route to host
==> ERROR: A specified local key could not be updated from a keyserver.


#7

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.