Updated Kernel, Can't Fully Boot System

Experienced Arch/Manjaro users, would appreciate help:

I’m running Manjaro and after a kernel update I’m unable to boot my system after the message: /dev/sda9: clean, <some-number-A>/<some-number-B> files, <some-number-C>/<some-number-D> blocks. I logged into my system via tty2 and ran updated all of my mirrors + updated all of my packages. It didn’t help.

Can anyone please help me solve this? I’ve never had this issue before.

sddm not ssdm

sudo pacman -S sddm
sudo systemctl enable sddm
sudo systemctl start sddm

Yeah, I really realized it was a typo and went to reinstall it. Am updating the post as the reinstall didn’t help.

I tried re-enabling it then starting it - nothing happened. Also rebooting the machine didn’t change anything.

also, manjaro configures X-Server with the command:

sudo mhwd -a pci free 0300

that would give you the free graphics drivers config.

Hybrid Card with Intel + Nvidia? Try this:

Replace MODULES=() with:


at /etc/mkinitcpio.conf. (i915 → Intel driver)

Then run sudo mkinitcpio -P to update the initramfs and reboot.

No, there wasn’t any output to the enable and start command.

The output of the status command is:

sddm.service - Simple Desktop display Manager
Loaded: loaded (/usr/lib/systemd/sddm.service; enabled; vendor preset: disabled) 
Docs: man: sddm(1)
           man: sddm.conf(5)
Main PID:0913 (sddm) 
Tasks: 2 (limit: 19002)
Memory: 21.6M
CPU: 122ms
Cgroup: /system.slice/sddm.service
               |__913 /usr/bin/sddm

Failed to read display number from pipe
Display server stopping...
Attempt 2 starting the Display server on VT 1 failed
Display server starting... 
Adding cookie to “/var/run/sddm/{4291cb73-3742-491c-b9e3-eba045b879e}"
Running /usr/bin/X -nolisten tcp -background none, - seat seat0 vt1 -auth var/run/sddm/{4291cb73-3742-491c-b9e3-eba045b879e -noreset - displayfd 17
Failed to read display number from pipe
Attempt 3 starting the Display server on vt 1 failed
Could not start Display server on vt1

So it seems to me SDDM is indeed failing to run.

what happens if you ?

sudo systemctl enable sddm
sudo systemctl start sddm

but I think you have a nvidia card, which was installed as nonfree before ?

I get again no output. And yes, I do have an Nvidia card. I don’t know if I was using a free or non-free driver.

yes nonfree would be the drivers form nvidia itself, free drivers are the open source drivers ,
it happens that the card becomes incompatible with the nvidia drivers , because of the kernel update.

So we need to switch over to the free drivers.

Do you know if it’s possible to check somewhere non-free driver GPU compatibility to check if indeed my GPU isn’t supported by the non-free driver?

sudo mhwd -li

what is the output of that? which card do you have ? , : - )and also is this a notebook?

Its output is (reformatted the look to save time - writing on my phone):

Name: video-modesetting
Version: 2020.01.13
Freedriver: true
Type: PCI

Name: video-hybrid-intel-nvidia-prime
Version: 2021.07.28
Freedriver: false
Type: PCI

Warning: no installed USB configs!

I have a dGPU: an Nvidia GTX 780 and I think my CPU has an iGPU.

sudo mhwd -r pci video-hybrid-intel-nvidia-prime

I ran it and it removed the driver, I suppose. Do you think I should try to reinstall it now?

No there is a problem with the hybrid driver, lets try the free driver ?

sudo mhwd -a pci free 0300

Thank you so much, this driver works and I’m able to boot! :smiley:
How could you tell there was a problem with the old driver?

glad it worked :grinning: I had similar problems with my customers computer…

Thanks again for helping me solve this!

Do you know if I can somewhere see GPU driver support for the non-free driver? I’d ideally like to use it for improved performance.

have to search video-hybrid-intel-nvidia-prime Nvidia GTX 780 it is … nonfree drivers manjaro

so probably yes , because it is a new kind of GPU, but there is a lot config to do,
like blacklisting nouveau, and also install a module, that switches between
intel and nividia. It is quite complicated, but possible …

Oh, it’s far from being new, it was released about 8 years ago. :stuck_out_tongue:
Thanks, I’ll try to look that up. :slight_smile: