Updated and now can't open gnome-terminal and remmina

I just did an upgrade today from what appears to be a rogue mirror. I am not sure how it became my primary, but it seems to have upgraded packages locally to a higher version than is in the repos.

I did fix my mirrors, but not my problem, using:
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

I want to note that I did review several posts regarding gnome-terminal not working after update, including this one and this one, and neither fixed the problem: the locale issue was not the problem.

The error I get when starting either remmina or gnome-terminal is this:
error while loading shared libraries: libicuuc.so.68: cannot open shared object file: No such file or directory

Here are my current versions of apps involved (using reference from prior post):
pacman -Qi gnome-terminal remmina icu lib32-icu | grep Version
Version : 3.38.1-4
Version : 1:1.4.13-1
Version : 69.1-1
Version : 69.1-1

(Obviously, I had to install a different terminal app to get that info.).

I did try to downgrade icu, but to no avail.

sudo downgrade libicuuc

unable to downgrade libicuuc

Any solutions out there?

1 Like

The package is called simply icu. But according to branch compare, gnome-terminal should be on version 3.40.0-1. Please check https://repo.manjaro.org/ to see if the mirrors you’re using are up-to-date.

1 Like

Thanks. I think the gnome-terminal issue is that I am actually using gnome-terminal-fedora, but it shows up as gnome-terminal in the terminal for some reason. So the fact that gnome-terminal-fedora is a few iterations back is probably the issue I am having with terminal.

For remmina, though, the link you provided states that the correct version for reminna should be 1:1.4.13-1, which is what I have installed and appears to also conflict with icu-69, wanting instead icu-68.

Does anyone have remmina working with the latest version of icu?

I reverted back to an image I had from a few days ago and upgraded my mirrors … then did a dry run of an update with sudo pacman -Syyu. I confirmed that it is trying to update to icu-69.1-1-x86_64. So I’ll wait to hear back before performing that update.

I just did a full update.
remmina starts without issue - no errors or anything relating to icu
but I have no way to test it

Thanks @Nachlese and @pobrn. I actually have another computer with Manjaro installed that I kept updated (and had better mirrors to start), and I’m having the same exact problem. I tried replacing gnome-terminal-fedora with gnome-terminal, and it too won’t launch.

I also confirmed that on this computer, it is not the locale issue, as I fixed that a few minutes ago. I will try rebooting, but right now no other gnome-like terminals work either (tried: pantheon and byobu). So far only qterminal works. Launching gnome-terminal yields the same error gnome-terminal: error while loading shared libraries: libicuuc.so.68: cannot open shared object file: No such file or directory. Same goes for remmina.

@Nachlese, would you mind posting the versions you have of gnome-terminal, remmina, and icu?

Hoping someone out there has an idea of what is happening here and can help fix it.

[2021-04-29T06:14:00+0000] [ALPM] upgraded icu (68.2-1 -> 69.1-1)
[2021-04-29T05:55:15+0000] [ALPM] installed remmina (1:1.4.13-1)

core/icu 69.1-1 [installed]
community/remmina 1:1.4.13-1 [installed]

I don’t have gnome-terminal at all - this here is Xfce

If you don’t have a working terminal app you can always go to TTY
or install another terminal like rxvt, xterm, … whatever
as a backup
Most are lightweight and the dependencies are already there anyways.

Thanks for that @Nachlese. I have qterminal working for now. Same versions of icu and remmina as you.

Anyone running gnome able to post their updated versions of these apps and confirm remmina and gnome-terminal are working?

all the dependencies where already there - so I just installed it
it works

[2021-04-29T15:09:31+0000] [ALPM] installed gnome-terminal (3.40.0-1)
extra/gnome-terminal 3.40.0-1 (gnome) [installed]

… still not running Gnome :wink:
(not even touching it with a 10 feet pole anymore although I was a fan, years ago …)

Ok, DON’T do this:

I would not call this “solved,” but I have temporary relief by downgrading both icu and raptor – the latter due to conflicts if I tried solely the former.

icu 68.2 1 x86_64 (local)
raptor 2.0.15 15 x86_64 (local)

It leads to an unbootable system. Had to drop to shell and update those two.

Still hoping someone using gnome and recently upgraded can confirm/deny this issue on their machine.

Same here - Remmina and Gnome Terminal (-Fedora) not working. I tried Xfce-Terminal, but it has the same problem. I can live with xterm for now, but I absolutely need Remmina…

1 Like

I’m running gnome, and I have the same problem with gnome-terminal-fedora.

From XTerm I tried to run gnome and obtained a message saying libcuuc.so.68 does not exist.

1 Like

@JohnnyG Do you have remmina installed and/or can you check to see if it works?

I just rebuilt vte3-notification and gnome-terminal-fedora, see if that helps.

1 Like

Just updated my system to pull those in: that fixed it! Both remmina and gnome-terminal.

I’m going to reboot once before closing this out, but thank you @Yochanan!!!

@TheRoark I don’t use remmina but the last update seems to have brought the gnome-terminal back to life! Problem solved?

Thanks for reporting back @JohnnyG. Yes, I marked this solved - the update from @Yochanan fixed it for me too.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.