Update problem, presumably because of some Kernel problems

When I try to update anything I get the following message:
could not satisfy dependencies:

  • removing linux510-rt-bbswitch breaks dependency ‘linux510-rt-bbswitch’ required by linux-rt-lts-manjaro-bbswitch
  • removing linux510-rt-broadcom-wl breaks dependency ‘linux510-rt-broadcom-wl’ required by linux-rt-lts-manjaro-broadcom-wl

My best guess is that something with the old 5.10.90_rt60-1 Kernel is borked. I tried to remove it multiple times, and it won’t budge, giving out the same dependency error.
I tried multiple solutions with my limited knowledge, like removing the specific parts (didn’t work), installing a number of other Kernels, including newer rt Kernels, and switching between those (didn’t work).
It feels a bit like the part was already removed, but the system still thinks it is there, the problem is that it stops everything else from being able to update, which is obviously becoming a problem.

I really hope someone can give me some easy to understand help to fix this problem.
Please be nice.

EDIT: If someone runs into a similar problem, please read the whole thread as multiple steps had to be taken to solve the problem and the solution is only the last step!

I believe the packages linux-rt-lts-manjaro-bbswitch and linux-rt-lts-manjaro-broadcom-wl have been dropped long ago. You should mark their dependencies as explicitly installed, and remove the dropped ones.

sudo pacman -D --asexplicit linux510-rt-bbswitch linux510-rt-broadcom-wl
sudo pacman -R linux-rt-lts-manjaro-bbswitch linux-rt-lts-manjaro-broadcom-wl
1 Like

Thank you for your answer, I managed to remove the second part


but unfortunately I still get an error for


error: target not found: linux-rt-bbswitch
Which leads me to believe that it isn’t actually there but for some reason the system thinks it is.

  • You can check if you have the package installed:
pacman -Q linux-rt-bbswitch
  1. If it returns a version number, you do have it installed. You may need to explicitly remove it.
sudo pacman -R linux-rt-bbswitch linux-rt-lts-manjaro-bbswitch
  1. If it doesn’t return anything, you indeed don’t have it installed. You may need to make your system think it is – it may require a correct (fake) version.
sudo pacman -R --assume-installed linux-rt-bbswitch=1.0 linux-rt-lts-manjaro-bbswitch

Thank you, it was indeed not installed, and I had to take the second solution, and it worked!
I’m very happy that I can finally update my system and programs again!
While I wouldn’t consider myself a complete novice, this problem was certainly way above my knowledge.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.