Update packages failes ('linux510-rt' required by linux-rt-lts-manjaro)

Hi, if I like to install Updates with pacman or yay I get the following error:

:: removing linux510-rt breaks dependency 'linux510-rt' required by linux-rt-lts-manjaro
:: removing linux510-rt-r8168 breaks dependency 'linux510-rt-r8168' required by linux-rt-lts-manjaro-r8168

I don’t even use that kernel, so I tried to uninstall it over the manjaro settings, but it didn’t worked. Why does pacman try to remove it? How can I fix it, so I can get the updates again? Sadly I didn’t find any solution yet.

I just found this error mentioned once in https:// forum. manjaro .org/t/stable-update-2022-02-05-kernels-libreoffice-kde-gear-nvidia-calamares-virtualbox-pipewire-mesa-systemd/101408/62 by @zenaj but the thread is just a confusing collection of people complaining about different errors without a solution.

What is the output of mhwd-kernel -li?

The meta package linux-lts got removed from our repos a while ago. You may remove those packages: sudo pacman -Rdd linux-rt-lts-manjaro linux-rt-lts-manjaro-r8168


Thanks, that fixed the issue. :grinning:

I got an almost identical dependency error. My solution was to simply update to the 5.16.2_rt19-1 kernel. ;-:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.