Update: "invalid or corrupted package"

update
wayland

#1

Hello all, I hope you are doing good.

I’ve been using Ubuntu in the last 3 years and 5 months ago I migrated to Manjaro, which is a very great distro in my opinion. However, on 19.02.19 near to 400 packages showed up in the upgrade manager, and when upgrading I immediately get the message:

pacman -Syuw

:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
warning: could not fully load metadata for package kwayland-5.54.0-1
error: failed to prepare transaction (invalid or corrupted package)

Then I’ve tried upgrading a single package using pamac and I get this warning message before running the upgrade itself:

Warning: anki: ignoring package upgrade (2.1.8-1 => 2.1.8-3)
Warning: ark: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: arpack: ignoring package upgrade (3.6.3-1 => 3.7.0-1)
Warning: attica: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: audit: ignoring package upgrade (2.8.4-2 => 2.8.4-3)
Warning: baloo: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: baloo-widgets: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: bluedevil: ignoring package upgrade (1:5.14.5-1 => 1:5.15.0-1)
Warning: bluez-qt: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: breeze: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: breeze-icons: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: btrfs-progs: ignoring package upgrade (4.19.1-1 => 4.20.1-2)
Warning: ca-certificates-mozilla: ignoring package upgrade (3.41-1 => 3.42.1-1)
Warning: cairo: ignoring package upgrade (1.16.0-1 => 1.16.0-2)
Warning: clazy: ignoring package upgrade (1.4-3 => 1.5-1)
Warning: crda: ignoring package upgrade (4.14-1 => 4.14-2)
Warning: cryptsetup: ignoring package upgrade (2.0.6-1 => 2.1.0-1)
Warning: cups-filters: ignoring package upgrade (1.22.0-1 => 1.22.1-1)
Warning: curl: ignoring package upgrade (7.63.0-4 => 7.64.0-7.1)
Warning: dialog: ignoring package upgrade (1:1.3_20181107-1 => 1:1.3_20190211-1)
Warning: dnsmasq: ignoring package upgrade (2.80-2 => 2.80-3)
Warning: dolphin: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: dolphin-plugins: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: electron: ignoring package upgrade (3.1.1-1 => 3.1.3-1)
Warning: electron2: ignoring package upgrade (2.0.16-1 => 2.0.17-1)
Warning: extra-cmake-modules: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: ffmpeg: ignoring package upgrade (1:4.1-1 => 1:4.1.1-1)
Warning: ffmpegthumbs: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: filelight: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: firefox: ignoring package upgrade (65.0.1-0 => 65.0.1-1)
Warning: firefox-i18n-de: ignoring package upgrade (65.0.1-0 => 65.0.1-1)
Warning: firefox-i18n-en-us: ignoring package upgrade (65.0.1-0 => 65.0.1-1)
Warning: flatpak: ignoring package upgrade (1.1.3-2 => 1.2.3-1)
Warning: fluidsynth: ignoring package upgrade (1.1.11-3 => 2.0.3-1)
Warning: frameworkintegration: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: glibmm: ignoring package upgrade (2.56.0-1 => 2.58.0-1)
Warning: gnupg: ignoring package upgrade (2.2.12-2 => 2.2.13-1)
Warning: gnutls: ignoring package upgrade (3.6.5-4 => 3.6.6-3)
Warning: graphene: ignoring package upgrade (1.8.2-1 => 1.8.4-1)
Warning: grub: ignoring package upgrade (2.03.2-1 => 2.03.3-1)
Warning: gst-plugins-bad: ignoring package upgrade (1.14.4-5 => 1.14.4-8)
Warning: gtk-update-icon-cache: ignoring package upgrade (3.24.4-1 => 3.24.5-1)
Warning: gtk3: ignoring package upgrade (3.24.4-1 => 3.24.5-1)
Warning: gwenview: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: harfbuzz: ignoring package upgrade (2.3.0-1 => 2.3.1-2)
Warning: harfbuzz-icu: ignoring package upgrade (2.3.0-1 => 2.3.1-2)
Warning: haskell-aeson: ignoring package upgrade (1.4.2.0-6 => 1.4.2.0-9)
Warning: haskell-aeson-pretty: ignoring package upgrade (0.8.7-49 => 0.8.7-52)
Warning: haskell-asn1-encoding: ignoring package upgrade (0.9.5-77 => 0.9.5-79)
Warning: haskell-asn1-parse: ignoring package upgrade (0.9.4-88 => 0.9.4-90)
Warning: haskell-asn1-types: ignoring package upgrade (0.3.2-84 => 0.3.2-86)
Warning: haskell-attoparsec: ignoring package upgrade (0.13.2.2-36 => 0.13.2.2-37)
Warning: haskell-basement: ignoring package upgrade (0.0.8-4 => 0.0.10-1)
Warning: haskell-blaze-html: ignoring package upgrade (0.9.1.1-14 => 0.9.1.1-15)
Warning: haskell-blaze-markup: ignoring package upgrade (0.8.2.2-8 => 0.8.2.2-9)
Warning: haskell-conduit: ignoring package upgrade (1.3.1-19 => 1.3.1-22)
Warning: haskell-conduit-extra: ignoring package upgrade (1.3.0-83 => 1.3.0-87)
Warning: haskell-connection: ignoring package upgrade (0.2.8-110 => 0.2.8-113)
Warning: haskell-cryptonite: ignoring package upgrade (0.25-30 => 0.25-32)
Warning: haskell-doctemplates: ignoring package upgrade (0.2.2.1-54 => 0.2.2.1-57)
Warning: haskell-haddock-library: ignoring package upgrade (1.7.0-12 => 1.7.0-15)
Warning: haskell-hourglass: ignoring package upgrade (0.2.12-10 => 0.2.12-11)
Warning: haskell-hslua: ignoring package upgrade (1.0.2-2 => 1.0.2-3)
Warning: haskell-hslua-module-text: ignoring package upgrade (0.2.0-13 => 0.2.0-14)
Warning: haskell-http: ignoring package upgrade (4000.3.12-109 => 4000.3.12-117)
Warning: haskell-http-client: ignoring package upgrade (0.6.1-2 => 0.6.1-5)
Warning: haskell-http-client-tls: ignoring package upgrade (0.3.5.3-94 => 0.3.5.3-97)
Warning: haskell-http-types: ignoring package upgrade (0.12.2-13 => 0.12.2-14)
Warning: haskell-juicypixels: ignoring package upgrade (3.3.3-2 => 3.3.3-3)
Warning: haskell-libyaml: ignoring package upgrade (0.1.0.0-15 => 0.1.1.0-2)
Warning: haskell-memory: ignoring package upgrade (0.14.18-10 => 0.14.18-12)
Warning: haskell-mono-traversable: ignoring package upgrade (1.0.10.0-5 => 1.0.11.0-3)
Warning: haskell-network: ignoring package upgrade (2.7.0.2-18 => 2.8.0.0-2)
Warning: haskell-pandoc-types: ignoring package upgrade (1.17.5.4-9 => 1.17.5.4-12)
Warning: haskell-pem: ignoring package upgrade (0.2.4-36 => 0.2.4-38)
Warning: haskell-resourcet: ignoring package upgrade (1.2.2-8 => 1.2.2-9)
Warning: haskell-skylighting: ignoring package upgrade (0.7.5-8 => 0.7.6-3)
Warning: haskell-skylighting-core: ignoring package upgrade (0.7.5-8 => 0.7.6-3)
Warning: haskell-socks: ignoring package upgrade (0.5.6-45 => 0.5.6-47)
Warning: haskell-streaming-commons: ignoring package upgrade (0.2.1.0-16 => 0.2.1.0-18)
Warning: haskell-temporary: ignoring package upgrade (1.3-18 => 1.3-19)
Warning: haskell-texmath: ignoring package upgrade (0.11.1.2-9 => 0.11.2-4)
Warning: haskell-tls: ignoring package upgrade (1.4.1-55 => 1.4.1-58)
Warning: haskell-typed-process: ignoring package upgrade (0.2.4.0-2 => 0.2.4.0-3)
Warning: haskell-vector: ignoring package upgrade (0.12.0.2-3 => 0.12.0.2-4)
Warning: haskell-vector-algorithms: ignoring package upgrade (0.8.0.1-6 => 0.8.0.1-7)
Warning: haskell-x509: ignoring package upgrade (1.7.5-5 => 1.7.5-7)
Warning: haskell-x509-store: ignoring package upgrade (1.6.7-4 => 1.6.7-6)
Warning: haskell-x509-system: ignoring package upgrade (1.6.6-72 => 1.6.6-74)
Warning: haskell-x509-validation: ignoring package upgrade (1.6.11-4 => 1.6.11-6)
Warning: haskell-xml-conduit: ignoring package upgrade (1.8.0.1-29 => 1.8.0.1-33)
Warning: haskell-yaml: ignoring package upgrade (0.11.0.0-16 => 0.11.0.0-22)
Warning: haskell-zip-archive: ignoring package upgrade (0.3.3-14 => 0.4-2)
Warning: hplip: ignoring package upgrade (1:3.18.12-2 => 1:3.19.1-1)
Warning: hwinfo: ignoring package upgrade (21.58-1 => 21.59-1)
Warning: iana-etc: ignoring package upgrade (20181219-1 => 20190125-1)
Warning: imagemagick: ignoring package upgrade (7.0.8.24-1 => 7.0.8.28-1)
Warning: inkscape: ignoring package upgrade (0.92.4-2 => 0.92.4-3)
Warning: iputils: ignoring package upgrade (20180629.f6aac8d-3 => 20180629.f6aac8d-4)
Warning: iw: ignoring package upgrade (4.14-1 => 5.0.1-1)
Warning: kaccounts-integration: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: kaccounts-providers: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: kactivities: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kactivities-stats: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kactivitymanagerd: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: kamera: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: karchive: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kate: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: kauth: ignoring package upgrade (5.54.0-2 => 5.55.0-1)
Warning: kbookmarks: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kcalc: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: kcharselect: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: kcmutils: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kcodecs: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kcompletion: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kconfig: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kconfigwidgets: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kcoreaddons: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kcrash: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kdbusaddons: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kde-cli-tools: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: kde-gtk-config: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: kdeclarative: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kdecoration: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: kded: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kdegraphics-thumbnailers: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: kdelibs4support: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kdenetwork-filesharing: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: kdeplasma-addons: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: kdesu: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kdialog: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: kdnssd: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kdoctools: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: keditbookmarks: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: kemoticons: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kfilemetadata: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kfind: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: kgamma5: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: kget: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: kglobalaccel: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kguiaddons: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: khelpcenter: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: kholidays: ignoring package upgrade (1:5.54.0-1 => 1:5.55.0-1)
Warning: khotkeys: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: khtml: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: ki18n: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kiconthemes: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kidletime: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kimageformats: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kinfocenter: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: kinit: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kio: ignoring package upgrade (5.54.1-1 => 5.55.0-1)
Warning: kio-extras: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: kirigami2: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kitemmodels: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kitemviews: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kjobwidgets: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kjs: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kjsembed: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kmenuedit: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: kmod: ignoring package upgrade (25-1 => 26-2)
Warning: knetattach: ignoring package upgrade (5.14.5-2 => 5.15.0-1)
Warning: knewstuff: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: knotifications: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: knotifyconfig: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kolourpaint: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: konsole: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: kpackage: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kparts: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kpeople: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kpty: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: krunner: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kscreen: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: kscreenlocker: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: kservice: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: ksshaskpass: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: ksysguard: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: ksystemlog: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: ktexteditor: ignoring package upgrade (5.54.0-2 => 5.55.0-1)
Warning: ktextwidgets: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kunitconversion: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kwallet: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kwallet-pam: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: kwalletmanager: ignoring package upgrade (18.12.1-2 => 18.12.2-1)
Warning: kwayland: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kwayland-integration: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: kwidgetsaddons: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kwin: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: kwindowsystem: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: kwrited: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: kxmlgui: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: ladspa: ignoring package upgrade (1.13-7 => 1.15-1)
Warning: languagetool: ignoring package upgrade (4.4-1 => 4.4-2)
Warning: latte-dock: ignoring package upgrade (0.8.5-1 => 0.8.5.r3.g58887ca7-1)
Warning: lib32-alsa-lib: ignoring package upgrade (1.1.8-1 => 1.1.8-2)
Warning: lib32-expat: ignoring package upgrade (2.2.6-1 => 2.2.6-2)
Warning: lib32-gnutls: ignoring package upgrade (3.6.5-1 => 3.6.6-1)
Warning: lib32-harfbuzz: ignoring package upgrade (2.3.0-1 => 2.3.1-2)
Warning: lib32-libjpeg-turbo: ignoring package upgrade (2.0.1-1 => 2.0.2-1)
Warning: lib32-libltdl: ignoring package upgrade (2.4.6+40+g6ca5e224-4 => 2.4.6+42+gb88cebd5-1)
Warning: lib32-libogg: ignoring package upgrade (1.3.3-2 => 1.3.3-3)
Warning: lib32-libunwind: ignoring package upgrade (1.2.1-2 => 1.3.1-1)
Warning: lib32-libva-mesa-driver: ignoring package upgrade (18.3.2-0 => 18.3.3-1)
Warning: lib32-mesa: ignoring package upgrade (18.3.2-0 => 18.3.3-1)
Warning: lib32-systemd: ignoring package upgrade (239.303+really+239.6-1 => 241.159-1)
Warning: lib32-zstd: ignoring package upgrade (1.3.7-1 => 1.3.8-1)
Warning: libassuan: ignoring package upgrade (2.5.2-1 => 2.5.3-1)
Warning: libbluray: ignoring package upgrade (1.0.2-2 => 1.1.0-1)
Warning: libcdio-paranoia: ignoring package upgrade (10.2+0.94+2-2 => 10.2+2.0.0-1)
Warning: libcerf: ignoring package upgrade (1.11-1 => 1.12-1)
Warning: libfbclient: ignoring package upgrade (2.5.8.27089-3 => 3.0.4.33054-1)
Warning: libgit2: ignoring package upgrade (1:0.27.7-1 => 1:0.27.8-1)
Warning: libgpg-error: ignoring package upgrade (1.34-1 => 1.35-1)
Warning: libheif: ignoring package upgrade (1.3.2-2 => 1.3.2-3)
Warning: libidn2: ignoring package upgrade (2.1.0-1 => 2.1.1-2)
Warning: libjpeg-turbo: ignoring package upgrade (2.0.1-1 => 2.0.2-1)
Warning: libkcddb: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: libkdcraw: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: libkexiv2: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: libkipi: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: libksane: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: libkscreen: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: libksysguard: ignoring package upgrade (5.14.5-2 => 5.15.0-1)
Warning: libmagick: ignoring package upgrade (7.0.8.24-1 => 7.0.8.28-1)
Warning: libmagick6: ignoring package upgrade (6.9.10.17-1 => 6.9.10.27-1)
Warning: libmicrohttpd: ignoring package upgrade (0.9.62-1 => 0.9.63-1)
Warning: libnghttp2: ignoring package upgrade (1.35.1-1 => 1.36.0-1)
Warning: libpipeline: ignoring package upgrade (1.5.0-1 => 1.5.1-1)
Warning: libpsl: ignoring package upgrade (0.20.2-3 => 0.20.2-5)
Warning: libpwquality: ignoring package upgrade (1.4.0-1 => 1.4.0-2)
Warning: libqalculate: ignoring package upgrade (2.8.2-2 => 2.9.0-1)
Warning: libqmi: ignoring package upgrade (1.22.0-1 => 1.22.0-2)
Warning: libreoffice-fresh: ignoring package upgrade (6.1.4-4 => 6.2.0-3)
Warning: libreoffice-fresh-de: ignoring package upgrade (6.1.4-1 => 6.2.0-1)
Warning: librsvg: ignoring package upgrade (2:2.44.12-1 => 2:2.44.13-1)
Warning: libsasl: ignoring package upgrade (2.1.26-16 => 2.1.27-1)
Warning: libsass: ignoring package upgrade (3.5.4-1 => 3.5.5-1)
Warning: libsynctex: ignoring package upgrade (2018.48691-5 => 2018.48691-6)
Warning: libtommath: ignoring package upgrade (1.0.1-1 => 1.1.0-1)
Warning: libuv: ignoring package upgrade (1.25.0-1 => 1.26.0-1)
Warning: libva-mesa-driver: ignoring package upgrade (18.3.2-1 => 18.3.3-2)
Warning: libxau: ignoring package upgrade (1.0.8-3 => 1.0.9-1)
Warning: libxkbcommon: ignoring package upgrade (0.8.2-1 => 0.8.3-1)
Warning: libxkbcommon-x11: ignoring package upgrade (0.8.2-1 => 0.8.3-1)
Warning: linux-firmware: ignoring package upgrade (20190118.a8b75ca-1 => 20190212.28f5f7d-1)
Warning: linux419: ignoring package upgrade (4.19.20-1 => 4.19.23-1)
Warning: linux419-bbswitch: ignoring package upgrade (0.8-16 => 0.8-18)
Warning: linux419-nvidia-390xx: ignoring package upgrade (390.87-17 => 390.87-19)
Warning: linux419-virtualbox-host-modules: ignoring package upgrade (6.0.2-4 => 6.0.4-5)
Warning: lutris: ignoring package upgrade (0.4.23-1 => 0.5.0.1-1)
Warning: man-pages-de: ignoring package upgrade (2.10-1 => 2.11-1)
Warning: manjaro-release: ignoring package upgrade (18.0.2-1 => 18.0.3-1)
Warning: meld: ignoring package upgrade (3.20.0-1 => 3.20.0-2)
Warning: mesa: ignoring package upgrade (18.3.2-1 => 18.3.3-2)
Warning: meson: ignoring package upgrade (0.49.1-1 => 0.49.2-2)
Warning: milou: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: modemmanager-qt: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: mpfr: ignoring package upgrade (4.0.1-1 => 4.0.2-1)
Warning: msmtp: ignoring package upgrade (1.8.2-1 => 1.8.3-1)
Warning: msmtp-mta: ignoring package upgrade (1.8.2-1 => 1.8.3-1)
Warning: ndctl: ignoring package upgrade (63-1 => 64.1-1)
Warning: networkmanager-openconnect: ignoring package upgrade (1.2.4-4 => 1.2.5dev+110+g524a2e0-2)
Warning: networkmanager-openvpn: ignoring package upgrade (1.8.8-2 => 1.8.10-1)
Warning: networkmanager-pptp: ignoring package upgrade (1.2.8-2 => 1.2.9dev+10+gb41b0d0-1)
Warning: networkmanager-qt: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: networkmanager-vpnc: ignoring package upgrade (1.2.6-2 => 1.2.7dev+20+gdca3aea-1)
Warning: ninja: ignoring package upgrade (1.8.2-1 => 1.9.0-1)
Warning: nmap: ignoring package upgrade (7.70-2 => 7.70-3)
Warning: nodejs: ignoring package upgrade (11.8.0-1 => 11.10.0-1)
Warning: npm: ignoring package upgrade (6.7.0-1 => 6.8.0-1)
Warning: nss: ignoring package upgrade (3.41-1 => 3.42.1-1)
Warning: okular: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: openal: ignoring package upgrade (1.19.1-1 => 1.19.1-2)
Warning: openconnect: ignoring package upgrade (1:7.08-2 => 1:8.02-1)
Warning: opencv: ignoring package upgrade (4.0.1-3 => 4.0.1-5)
Warning: openmpi: ignoring package upgrade (3.1.3-1 => 4.0.0-1)
Warning: pambase: ignoring package upgrade (20171006-1 => 20190105.1-1)
Warning: pandoc: ignoring package upgrade (2.5-30 => 2.6-7)
Warning: pandoc-citeproc: ignoring package upgrade (0.15.0.1-31 => 0.16.1-1)
Warning: pandoc-crossref: ignoring package upgrade (0.3.4.0-33 => 0.3.4.0-46)
Warning: perl-file-which: ignoring package upgrade (1.22-2 => 1.23-1)
Warning: perl-xml-libxml: ignoring package upgrade (2.0132-2 => 2.0134-1)
Warning: pixman: ignoring package upgrade (0.36.0-1 => 0.38.0-2)
Warning: plasma-desktop: ignoring package upgrade (5.14.5-2 => 5.15.0-1)
Warning: plasma-framework: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: plasma-integration: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: plasma-nm: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: plasma-pa: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: plasma-workspace: ignoring package upgrade (5.14.5-2 => 5.15.0-1)
Warning: plasma-workspace-wallpapers: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: polkit-kde-agent: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: poppler: ignoring package upgrade (0.73.0-1 => 0.74.0-1)
Warning: poppler-glib: ignoring package upgrade (0.73.0-1 => 0.74.0-1)
Warning: poppler-qt5: ignoring package upgrade (0.73.0-1 => 0.74.0-1)
Warning: powerdevil: ignoring package upgrade (5.14.5-2 => 5.15.0-1)
Warning: print-manager: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: prison: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: purpose: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: pyqt5-common: ignoring package upgrade (5.11.3-2 => 5.12-2)
Warning: python-beaker: ignoring package upgrade (1.10.0-2 => 1.10.0-3)
Warning: python-distro: ignoring package upgrade (1.3.0-2 => 1.4.0-1)
Warning: python-markdown: ignoring package upgrade (2.6.11-2 => 3.0.1-1)
Warning: python-msgpack: ignoring package upgrade (0.6.0-1 => 0.6.1-1)
Warning: python-pyqt5: ignoring package upgrade (5.11.3-2 => 5.12-2)
Warning: python-setuptools: ignoring package upgrade (1:40.6.3-1 => 1:40.8.0-1)
Warning: python-sip-pyqt5: ignoring package upgrade (4.19.13-1 => 4.19.14-1)
Warning: python-soupsieve: ignoring package upgrade (1.7.3-1 => 1.8.0-1)
Warning: python-urllib3: ignoring package upgrade (1.24.1-1 => 1.24.1-2)
Warning: python2-lxml: ignoring package upgrade (4.3.0-1 => 4.3.1-1)
Warning: python2-numpy: ignoring package upgrade (1.16.0-1 => 1.16.1-1)
Warning: python2-setuptools: ignoring package upgrade (1:40.6.3-1 => 1:40.8.0-1)
Warning: qpdf: ignoring package upgrade (8.3.0-1 => 8.4.0-1)
Warning: qqc2-desktop-style: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: qscintilla-qt5: ignoring package upgrade (2.10.8-1 => 2.11.1-1)
Warning: qt5-base: ignoring package upgrade (5.12.0-3.0 => 5.12.1-2.1)
Warning: qt5-declarative: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qt5-graphicaleffects: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qt5-imageformats: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qt5-location: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qt5-multimedia: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qt5-quickcontrols: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qt5-quickcontrols2: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qt5-script: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qt5-sensors: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qt5-speech: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qt5-svg: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qt5-tools: ignoring package upgrade (5.12.0-2 => 5.12.1-1)
Warning: qt5-translations: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qt5-virtualkeyboard: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qt5-webchannel: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qt5-webengine: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qt5-webkit: ignoring package upgrade (5.212.0alpha2-22 => 5.212.0alpha2-23)
Warning: qt5-websockets: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qt5-x11extras: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qt5-xmlpatterns: ignoring package upgrade (5.12.0-1 => 5.12.1-1)
Warning: qtcreator: ignoring package upgrade (4.8.1-1 => 4.8.1-2)
Warning: qtermwidget: ignoring package upgrade (0.9.0-1 => 0.14.0-1)
Warning: rhash: ignoring package upgrade (1.3.7-1 => 1.3.8-1)
Warning: ruby: ignoring package upgrade (2.6.0-5 => 2.6.1-1)
Warning: run-parts: ignoring package upgrade (4.8.6-1 => 4.8.6.1-1)
Warning: s-nail: ignoring package upgrade (14.9.11-2 => 14.9.11-3)
Warning: sddm-kcm: ignoring package upgrade (5.14.5-2 => 5.15.0-1)
Warning: shared-mime-info: ignoring package upgrade (1.10-1 => 1.12-1)
Warning: signon-kwallet-extension: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: solid: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: sonnet: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: spectacle: ignoring package upgrade (18.12.1-1 => 18.12.2-1)
Warning: speexdsp: ignoring package upgrade (1.2rc3-3 => 1.2rc3-4)
Warning: sqlite: ignoring package upgrade (3.26.0-2 => 3.27.1-1)
Warning: syntax-highlighting: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: systemd: ignoring package upgrade (239.303+really+239.6-1 => 241.159-1)
Warning: systemd-sysvcompat: ignoring package upgrade (239.303+really+239.6-1 => 241.159-1)
Warning: systemsettings: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: taglib: ignoring package upgrade (1.11.1-2 => 1.11.1-3)
Warning: texlive-bibtexextra: ignoring package upgrade (2018.49283-1 => 2018.50004-1)
Warning: texlive-bin: ignoring package upgrade (2018.48691-5 => 2018.48691-6)
Warning: texlive-core: ignoring package upgrade (2018.49285-1 => 2018.50036-1)
Warning: texlive-fontsextra: ignoring package upgrade (2018.49197-1 => 2018.50019-1)
Warning: texlive-humanities: ignoring package upgrade (2018.49287-1 => 2018.49792-1)
Warning: texlive-langextra: ignoring package upgrade (2018.49258-1 => 2018.49428-1)
Warning: texlive-latexextra: ignoring package upgrade (2018.49282-1 => 2018.50031-1)
Warning: texlive-pictures: ignoring package upgrade (2018.49201-1 => 2018.50020-1)
Warning: texlive-publishers: ignoring package upgrade (2018.49284-1 => 2018.50030-1)
Warning: texlive-science: ignoring package upgrade (2018.49286-1 => 2018.50013-1)
Warning: threadweaver: ignoring package upgrade (5.54.0-1 => 5.55.0-1)
Warning: unrar: ignoring package upgrade (1:5.6.8-1 => 1:5.7.1-1)
Warning: user-manager: ignoring package upgrade (5.14.5-1 => 5.15.0-1)
Warning: virtualbox: ignoring package upgrade (6.0.2-1 => 6.0.4-1)
Warning: virtualbox-ext-vnc: ignoring package upgrade (6.0.2-1 => 6.0.4-1)
Warning: virtualbox-guest-iso: ignoring package upgrade (6.0.2-1 => 6.0.4-1)
Warning: vlc: ignoring package upgrade (3.0.6-1 => 3.0.6-3)
Warning: vpnc: ignoring package upgrade (0.5.3.svn550-3 => 1:0.5.3.r454.r67-1)
Warning: vulkan-icd-loader: ignoring package upgrade (1.1.96+3009+32d33e965-1 => 1.1.99+3022+e1eafa18e-1)
Warning: webkit2gtk: ignoring package upgrade (2.22.5-1 => 2.22.6-1)
Warning: wget: ignoring package upgrade (1.20.1-2 => 1.20.1-3)
Warning: wine-staging: ignoring package upgrade (4.0-2 => 4.2-1)
Warning: x265: ignoring package upgrade (2.9-1 => 3.0-1)
Warning: xapian-core: ignoring package upgrade (1:1.4.9-1 => 1:1.4.10-1)
Warning: xdg-desktop-portal: ignoring package upgrade (1.1.1-2 => 1.2.0-2)
Warning: xdg-desktop-portal-gtk: ignoring package upgrade (1.1.1-1 => 1.2.0-1)
Warning: xdg-user-dirs: ignoring package upgrade (0.17-1 => 0.17-2)
Warning: xf86-input-libinput: ignoring package upgrade (0.28.1-1 => 0.28.2-1)
Warning: xkeyboard-config: ignoring package upgrade (2.25-1 => 2.26-2)
Warning: xterm: ignoring package upgrade (343-1 => 344-1)
Warning: zsh: ignoring package upgrade (5.6.2-1 => 5.7.1-1)

I think these two problems aren’t related, but all was good before this update and suddenly I’m getting all these warnings and errors. Why is almost every single package locked?

I took a look at my pacman.conf for ignored packages, but apparently there are none:

#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives
#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
CacheDir = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg      = pacman glibc manjaro-system
# If upgrades are available for these packages they will be asked for first
SyncFirst    = manjaro-system archlinux-keyring manjaro-keyring
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto
# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =
#NoUpgrade   =
#NoExtract   =
# Misc options
#UseSyslog
#Color
#TotalDownload
# We cannot check disk space from within a chroot environment
CheckSpace
#VerbosePkgLists
# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required
# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Manjaro Linux
# packagers with `pacman-key --populate archlinux manjaro`.
#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#
# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.
[core]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist
[extra]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist
[community]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist
# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.
[multilib]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist
# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

Many thanks!


#2

Try clearing out your cache first , logout , go to tty , Ctrl , Alt , F2 and run the update using sudo pacman -Syyuu


#3

Please check this post. It has already been discussed.


#4

Yup , you’re right , my brain is on hold this morning . I’m hoping the OP has read the update announcement and updates from tty as suggested as well .


#5

Thanks for answering, folks.

Unfortunately, nothing worked out.

I tried removing pacman’s cache and updating through the tty2.
I tried refreshing the keys.
I tried running jonathos’s suggestions as well, getting:

gpg: refreshing 129 keys from hkp://pgp.mit.edu
gpg: key FCF3C8CB5CF9C8D4: 1 signature not checked due to a missing key
gpg: key FCF3C8CB5CF9C8D4: "Alexander Rødseth <rodseth@gmail.com>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
gpg: keyserver refresh failed: No keyserver available
==> ERROR: A specified local key could not be updated from a keyserver.

and even the “nuclear option” didn’t do the trick. Every time i ran pacman -Syyuu from the tty, with no user logged in to the graphical interface.


#6

Try

$ sudo pamac upgrade -a

#8

No deal, unfortunately

==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required
Authenticating as:
Password:
==== AUTHENTICATION COMPLETE ====
Synchronizing package databases...
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Warning: could not fully load metadata for package kwayland-5.54.0-1
Error: Failed to prepare transaction: invalid or corrupted package

#9

You try it like in post #4, in tty?

Deinstall ? and install new if only this make problem. On unstable I have 5.55.0


#10

yes, logged out, went to tty and tried it out, with no luck. Thanks anyway, mate.


#11

I’m grasping at straws here but you could try sudo pacman-mirrors --fasttrack && sudo pacman -Syyu from tty
Just on the possibility that you’re repo is outdated .


#12

There’s an issue with your Internet connection and you can’t access hkp://pgp.mit.edu

Edit /etc/pacman.d/gnupg/gpg.conf and set

keyserver hkp://pool.sks-keyservers.net

If that one doesn’t work, try a different keyserver (I;ll let you do a search for some alternatives).


Unable to update or install anything
#13

Thanks for showing up, jonathon.

I got to connect to the given server getting the following feedback:

gpg: refreshing 129 keys from hkp://pool.sks-keyservers.net
gpg: key FCF3C8CB5CF9C8D4: 1 signature not checked due to a missing key
gpg: key FCF3C8CB5CF9C8D4: "Alexander Rødseth <rodseth@gmail.com>" not changed
gpg: key 9D893EC4DAAF9129: 129 signatures not checked due to missing keys
gpg: key 9D893EC4DAAF9129: "Bruno Pagani <bruno.pagani@ens-lyon.org>" not changed
gpg: key 2E89012331361F01: 3 signatures not checked due to missing keys
gpg: key 2E89012331361F01: "Evgeniy Alekseev <arcanis@archlinux.org>" not changed
gpg: key FC1B547C8D8172C8: 83 signatures not checked due to missing keys
gpg: key FC1B547C8D8172C8: "Levente Polyak (anthraxx) <levente@leventepolyak.net>" not changed
gpg: key 94657AB20F2A092B: 1 signature not checked due to a missing key
gpg: key 94657AB20F2A092B: "Andreas Radke <andyrtr@archlinux.org>" not changed
gpg: key F6B1610B3ECDBC9F: "Andrew Crerar <crerar@archlinux.org>" not changed
gpg: key B02854ED753E0F1F: 1 signature not checked due to a missing key
gpg: key B02854ED753E0F1F: "Anatol Pomozov <anatol.pomozov@gmail.com>" not changed
gpg: key AFF5D95098BC6FF5: 3 duplicate signatures removed
gpg: key AFF5D95098BC6FF5: 1 signature not checked due to a missing key
gpg: key AFF5D95098BC6FF5: 3 signatures reordered
gpg: key AFF5D95098BC6FF5: "Maxime Gauduin <alucryd@alucryd.xyz>" not changed
gpg: key F99FFE0FEAE999BD: 11 signatures not checked due to missing keys
gpg: key F99FFE0FEAE999BD: "Allan McRae <me@allanmcrae.com>" not changed
gpg: key 6BC26A17B9B7018A: 12 duplicate signatures removed
gpg: key 6BC26A17B9B7018A: 11 signatures not checked due to missing keys
gpg: key 6BC26A17B9B7018A: 12 signatures reordered
gpg: key 6BC26A17B9B7018A: "Alad Wenter <alad@archlinux.org>" not changed
gpg: key A06B49470F8E620A: 3 duplicate signatures removed
gpg: key A06B49470F8E620A: 3 signatures reordered
gpg: key A06B49470F8E620A: "Brett Cornwall <brett@i--b.com>" not changed
gpg: key 40F557B731496106: 2 signatures not checked due to missing keys
gpg: key 40F557B731496106: "Andrzej Giniewicz (giniu) <gginiu@gmail.com>" not changed
gpg: key 7EFD567D4C7EA887: 7 signatures not checked due to missing keys
gpg: key 7EFD567D4C7EA887: "Ionut Biru (Arch Linux Master Key) <ionut@master-key.archlinux.org>" not changed
gpg: key A04F9397CDFD6BB0: 5 signatures not checked due to missing keys
gpg: key A04F9397CDFD6BB0: "Dan McGee (Arch Linux Master Key) <dan@master-key.archlinux.org>" not changed
gpg: key 5184252D824B18E8: 11 signatures not checked due to missing keys
gpg: key 5184252D824B18E8: "Thomas Bächler (Arch Linux Master Key) <thomas@master-key.archlinux.org>" not changed
gpg: key 3348882F6AC6A4C2: 13 signatures not checked due to missing keys
gpg: key 3348882F6AC6A4C2: "Pierre Schmitz (Arch Linux Master Key) <pierre@master-key.archlinux.org>" not changed
gpg: key A88E23E377514E00: 9 signatures not checked due to missing keys
gpg: key A88E23E377514E00: "Florian Pritz (Arch Linux Master Key) <florian@master-key.archlinux.org>" not changed
gpg: key 9B729B06A680C281: 8 signatures not checked due to missing keys
gpg: key 9B729B06A680C281: "Bartłomiej Piotrowski (Arch Linux Master Key) <bpiotrowski@master-key.archlinux.org>" not changed
gpg: key D6D055F927843F1C: "Levente Polyak (Arch Linux Master Key) <anthraxx@master-key.archlinux.org>" not changed
gpg: key BA1DFB64FFF979E7: 13 signatures not checked due to missing keys
gpg: key BA1DFB64FFF979E7: "Allan McRae (Arch Linux Master Key) <allan@master-key.archlinux.org>" not changed
gpg: key 9C02FF419FECBE16: 356 signatures not checked due to missing keys
gpg: key 9C02FF419FECBE16: "Morten Linderud <morten@linderud.pw>" not changed
gpg: key 51E8B148A9999C34: 4 signatures not checked due to missing keys
gpg: key 51E8B148A9999C34: "Evangelos Foutras <evangelos@foutrelis.com>" not changed
gpg: key 46F633CBB0EB4BF2: 40 signatures not checked due to missing keys
gpg: key 46F633CBB0EB4BF2: "Filipe Laíns (FFY00) <lains@archlinux.org>" not changed
gpg: key 90CB3D62C13D4796: 4 signatures not checked due to missing keys
gpg: key 90CB3D62C13D4796: "Jiachen Yang <farseerfc@gmail.com>" not changed
gpg: key A6234074498E9CEE: 64 signatures not checked due to missing keys
gpg: key A6234074498E9CEE: "Christian Hesse (Arch Linux Package Signing) <arch@eworm.de>" not changed
gpg: key FCAC9CF5A6EE1209: 2 duplicate signatures removed
gpg: key FCAC9CF5A6EE1209: 2 signatures reordered
gpg: key FCAC9CF5A6EE1209: "Ivy F. Foster <i@escondida.tk>" not changed
gpg: key 84818A6819AF4A9B: 5 signatures not checked due to missing keys
gpg: key 84818A6819AF4A9B: "Eli Schwartz <eschwartz@archlinux.org>" not changed
gpg: key 54C28F4FF5A1A949: 13 signatures not checked due to missing keys
gpg: key 54C28F4FF5A1A949: "David Runge <dave@sleepmap.de>" not changed
gpg: key 1EB2638FF56C0C53: 5 duplicate signatures removed
gpg: key 1EB2638FF56C0C53: 23 signatures not checked due to missing keys
gpg: key 1EB2638FF56C0C53: 5 signatures reordered
gpg: key 1EB2638FF56C0C53: "Dave Reisner <d@falconindy.com>" not changed
gpg: key 5ED514A45BD5C938: 2 signatures not checked due to missing keys
gpg: key 5ED514A45BD5C938: "Gerardo Exequiel Pozzi <vmlinuz386@gmail.com>" not changed
gpg: key 019A7474297D8577: "Daniel Bermond <danielbermond@gmail.com>" not changed
gpg: key C91A9911192C187A: 20 signatures not checked due to missing keys
gpg: key C91A9911192C187A: "Daurnimator <quae@daurnimator.com>" not changed
gpg: key 5C2E46A0F53A76ED: 14 signatures not checked due to missing keys
gpg: key 5C2E46A0F53A76ED: "Dan McGee <dpmcgee@gmail.com>" not changed
gpg: key ED84945B35B2555C: "Robin Broda <robin@broda.me>" not changed
gpg: key 81A402D4F382BBBD: "Brad Fanella <cesura@archlinux.org>" not changed
gpg: key D53A0445B47A0DAB: 1 signature not checked due to a missing key
gpg: key D53A0445B47A0DAB: "Connor Behan <connor.behan@gmail.com>" not changed
gpg: key BBE43771487328A9: 27 signatures not checked due to missing keys
gpg: key BBE43771487328A9: "Bartlomiej Piotrowski <b@bpiotrowski.pl>" not changed
gpg: key 6D1655C14CE1C13E: 2 duplicate signatures removed
gpg: key 6D1655C14CE1C13E: 75 signatures not checked due to missing keys
gpg: key 6D1655C14CE1C13E: 1 bad signature
gpg: key 6D1655C14CE1C13E: 2 signatures reordered
gpg: key 6D1655C14CE1C13E: "Florian Pritz <bluewind@xinu.at>" not changed
gpg: key EEEEE2EEEE2EEEEE: 3 duplicate signatures removed
gpg: key EEEEE2EEEE2EEEEE: 36 signatures not checked due to missing keys
gpg: key EEEEE2EEEE2EEEEE: 3 signatures reordered
gpg: key EEEEE2EEEE2EEEEE: "Gaetan Bisson <gaetan@fenua.org>" not changed
gpg: key B61DBCE10901C163: 2 signatures not checked due to missing keys
gpg: key B61DBCE10901C163: "Balló György <ballogyor@gmail.com>" not changed
gpg: key 4AC5588F941C2A25: "Antonio Rojas <arojas@archlinux.org>" not changed
gpg: key 94DD2393DA2EE423: 1 signature not checked due to a missing key
gpg: key 94DD2393DA2EE423: "Massimiliano Torromeo (Personal non-work identity) <massimiliano.torromeo@gmail.com>" not changed
gpg: key 12C87A28FEAC6B20: 12 signatures not checked due to missing keys
gpg: key 12C87A28FEAC6B20: "Maxim Baz <pgp@maximbaz.com>" not changed
gpg: key A91764759326B440: 3 signatures not checked due to missing keys
gpg: key A91764759326B440: "Lukas Fleischer <lfleischer@lfos.de>" not changed
gpg: key 06096A6AD1CEDDAC: 1 duplicate signature removed
gpg: key 06096A6AD1CEDDAC: 4 signatures not checked due to missing keys
gpg: key 06096A6AD1CEDDAC: 1 signature reordered
gpg: key 06096A6AD1CEDDAC: "Laurent Carlier <lordheavym@gmail.com>" not changed
gpg: key 50FB9B273A9D0BB5: 6 signatures not checked due to missing keys
gpg: key 50FB9B273A9D0BB5: "Johannes Löthberg <johannes@kyriasis.com>" not changed
gpg: key 396E3E25BAB142C1: 1 signature not checked due to a missing key
gpg: key 396E3E25BAB142C1: "Kyle Keen <keenerd@gmail.com>" not changed
gpg: key 89AA27231C530226: 6 signatures not checked due to missing keys
gpg: key 89AA27231C530226: "Konstantin Gizdov <arch@kge.pw>" not changed
gpg: key A3D9562A589874AB: 2 signatures not checked due to missing keys
gpg: key A3D9562A589874AB: "Jürgen Hötzel <juergen@hoetzel.info>" not changed
gpg: key 332C9C40F40D2072: 4 signatures not checked due to missing keys
gpg: key 332C9C40F40D2072: "Jonathan Steel <mail@jsteel.org>" not changed
gpg: key 24E4CDB0013C2580: 1 signature not checked due to a missing key
gpg: key 24E4CDB0013C2580: "Jaroslav Lichtblau <svetlemodry@archlinux.org>" not changed
gpg: key 37E0AF1FDA48F373: 7 signatures not checked due to missing keys
gpg: key 37E0AF1FDA48F373: "Jerome Leclanche <jerome@leclan.ch>" not changed
gpg: key 976AC6FA3B94FA10: 1 signature not checked due to a missing key
gpg: key 976AC6FA3B94FA10: "Jan de Groot <info@jandegrootict.nl>" not changed
gpg: key C06086337C50773E: 4 signatures not checked due to missing keys
gpg: key C06086337C50773E: "Jelle van der Waa <jelle@vdwaa.nl>" not changed
gpg: key DB323392796CA067: 1 signature not checked due to a missing key
gpg: key DB323392796CA067: "Ike Devolder <ike.devolder@gmail.com>" not changed
gpg: key E8F18BA1615137BC: 6 signatures not checked due to missing keys
gpg: key E8F18BA1615137BC: "Ionut Biru <ibiru@archlinux.org>" not changed
gpg: key A5E9288C4FA415FA: 222 signatures not checked due to missing keys
gpg: key A5E9288C4FA415FA: "Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>" 5 new signatures
gpg: key DA6426DD215B37AD: 3 duplicate signatures removed
gpg: key DA6426DD215B37AD: 190 signatures not checked due to missing keys
gpg: key DA6426DD215B37AD: 3 signatures reordered
gpg: key DA6426DD215B37AD: "Guillaume ALAUX <guillaume@archlinux.org>" not changed
gpg: key F22FB1D78A77AEAB: 1 signature not checked due to a missing key
gpg: key F22FB1D78A77AEAB: "Giancarlo Razzolini (grazzolini) <grazzolini@archlinux.org>" not changed
gpg: key B7310AE5F04569AE: 13 signatures not checked due to missing keys
gpg: key B7310AE5F04569AE: "Giovanni Scafora <giovanni@archlinux.org>" not changed
gpg: key 786C63F330D7CB92: 771 signatures not checked due to missing keys
gpg: key 786C63F330D7CB92: "Felix Yan <felixonmars@archlinux.org>" not changed
gpg: key EB763B4E9DB887A6: 2 duplicate signatures removed
gpg: key EB763B4E9DB887A6: 2 signatures not checked due to missing keys
gpg: key EB763B4E9DB887A6: 2 signatures reordered
gpg: key EB763B4E9DB887A6: "Thore Bödecker <foxxx0@archlinux.org>" not changed
gpg: key 1F0CD4921ECAA030: 86 signatures not checked due to missing keys
gpg: key 1F0CD4921ECAA030: "Baptiste Jonglez <baptiste@bitsofnetworks.org>" not changed
gpg: key 3FDDD575826C5C30: "Chih-Hsuan Yen <yan12125@gmail.com>" not changed
gpg: key 1D1F0DC78F173680: 11 signatures not checked due to missing keys
gpg: key 1D1F0DC78F173680: "Xyne. (key #3) <xyne@archlinux.ca>" not changed
gpg: key 22E3B67B4A86FDE7: 12 signatures not checked due to missing keys
gpg: key 22E3B67B4A86FDE7: "Dan Printzell <me@vild.io>" not changed
gpg: key 771DF6627EDF681F: 8 signatures not checked due to missing keys
gpg: key 771DF6627EDF681F: "Tobias Powalowski <tobias.powalowski@googlemail.com>" not changed
gpg: key 284FC34C8E4B1A25: 7 signatures not checked due to missing keys
gpg: key 284FC34C8E4B1A25: 1 bad signature
gpg: key 284FC34C8E4B1A25: "Thomas Bächler <thomas@bchlr.de>" not changed
gpg: key C847B6AEB0544167: "Nicola Squartini <tensor5@gmail.com>" not changed
gpg: key 39E4B877E62EB915: 1 signature not checked due to a missing key
gpg: key 39E4B877E62EB915: "Sven-Hendrik Haase <svenstaro@gmail.com>" not changed
gpg: key 73B8ED52F1D357C1: 1 signature not checked due to a missing key
gpg: key 73B8ED52F1D357C1: "Lukas Jirkovsky <l.jirkovsky@gmail.com>" not changed
gpg: key 65C110C1EA433FC7: 4 signatures not checked due to missing keys
gpg: key 65C110C1EA433FC7: "Sergej Pupykin <arch@sergej.pp.ru>" not changed
gpg: key D21461E3DFE2060D: 4 signatures not checked due to missing keys
gpg: key D21461E3DFE2060D: "Christian Rebischke (Arch Linux Security Team-Member) <Chris.Rebischke@archlinux.org>" not changed
gpg: key 8DBD63B82072D77A: 8 duplicate signatures removed
gpg: key 8DBD63B82072D77A: 28 signatures not checked due to missing keys
gpg: key 8DBD63B82072D77A: 8 signatures reordered
gpg: key 8DBD63B82072D77A: "Sébastien Luttringer <seblu@seblu.net>" 9 new signatures
gpg: key 456C7A9B91B842AE: 1 signature not checked due to a missing key
gpg: key 456C7A9B91B842AE: "Jakob Gruber <jakob.gruber@gmail.com>" not changed
gpg: key 81AF739EC0711BF1: 1 signature not checked due to a missing key
gpg: key 81AF739EC0711BF1: "Rashif Rahman (Ray) <schiv@archlinux.org>" not changed
gpg: key 468F122CE8162295: 14 signatures not checked due to missing keys
gpg: key 468F122CE8162295: "Santiago Torres-Arias <santiago@archlinux.org>" not changed
gpg: key 426991CD8406FFF3: 1 signature not checked due to a missing key
gpg: key 426991CD8406FFF3: "Ronald van Haren <ronald@archlinux.org>" not changed
gpg: key 206CBC892D1493D2: 124 signatures not checked due to missing keys
gpg: key 206CBC892D1493D2: "Rémy Oudompheng <remy@archlinux.org>" not changed
gpg: key EA4F7B321A906AD9: "Daniel M. Capella <polyzen@archlinux.org>" not changed
gpg: key 7F2D434B9741E8AC: 19 signatures not checked due to missing keys
gpg: key 7F2D434B9741E8AC: 1 bad signature
gpg: key 7F2D434B9741E8AC: "Pierre Schmitz <pierre@archlinux.de>" not changed
gpg: key 51DAE9B7C1AE9161: 13 signatures not checked due to missing keys
gpg: key 51DAE9B7C1AE9161: "NicoHood <pgp@nicohood.de>" not changed
gpg: key B4360204B250F0D3: 92 signatures not checked due to missing keys
gpg: key B4360204B250F0D3: "Fabio Castelli <muflone@vbsimple.net>" not changed
gpg: key CF7037A4F27FB7DA: 3 signatures not checked due to missing keys
gpg: key CF7037A4F27FB7DA: "speps <speps@aur.archlinux.org>" not changed
gpg: key 3A726C6170E80477: 1 signature not checked due to a missing key
gpg: key 3A726C6170E80477: "Роман Кирилич (Roman Kyrylych) <roman@archlinux.org>" not changed
gpg: key 6D1A9E70E19DAA50: 1 duplicate signature removed
gpg: key 6D1A9E70E19DAA50: 135 signatures not checked due to missing keys
gpg: key 6D1A9E70E19DAA50: 1 signature reordered
gpg: key 6D1A9E70E19DAA50: "Peter Richard Lewis <pete@muddygoat.org>" not changed
gpg: key B9113D1ED21E1A55: 2 signatures not checked due to missing keys
gpg: key B9113D1ED21E1A55: "Kaiting Chen <kaitocracy@gmail.com>" not changed
gpg: key 5F946DED983D4366: 1 signature not checked due to a missing key
gpg: key 5F946DED983D4366: "Justin Davis (juster) <jrcd83@gmail.com>" not changed
gpg: key AF7EF7873CFD4BB6: 1 signature not checked due to a missing key
gpg: key AF7EF7873CFD4BB6: "Jonathan Conder <jonno.conder@gmail.com>" not changed
gpg: key 654B877A0864983E: 8 signatures not checked due to missing keys
gpg: key 654B877A0864983E: "Martin Wimpress (http://www.flexion.org) <martin@flexion.org>" not changed
gpg: key 59B3122E2FA915EC: 1 signature not checked due to a missing key
gpg: key 59B3122E2FA915EC: "Alexandre Filgueira <alexfilgueira@cinnarch.com>" not changed
gpg: key FCF2CB179205AC90: 1 signature not checked due to a missing key
gpg: key FCF2CB179205AC90: "Eric Belanger <eric@archlinux.org>" not changed
gpg: key 5FA5E5544F010D48: 15 signatures not checked due to missing keys
gpg: key 5FA5E5544F010D48: "Daniel Wallace (plangrid) <daniel.wallace@plangrid.com>" not changed
gpg: key F2DBB4931985A992: 1 signature not checked due to a missing key
gpg: key F2DBB4931985A992: "Dieter Plaetinck <dieter@plaetinck.be>" not changed
gpg: key 761FAD69BA06C6A9: 1 signature not checked due to a missing key
gpg: key 761FAD69BA06C6A9: "Dicebot <public@dicebot.lv>" not changed
gpg: key E613C09CB4440678: 1 signature not checked due to a missing key
gpg: key E613C09CB4440678: "Daniel Isenmann <daniel@archlinux.org>" not changed
gpg: key A001876699AD6E84: 6 signatures not checked due to missing keys
gpg: key A001876699AD6E84: "Gavin Marciniak-Bisesi <Daenyth@gmail.com>" not changed
gpg: key E2539214C6C11350: 1 signature not checked due to a missing key
gpg: key E2539214C6C11350: "Federico Cinelli <cinelli.federico@gmail.com>" not changed
gpg: key E6B456CAF15447D5: 4 signatures not checked due to missing keys
gpg: key E6B456CAF15447D5: "Federico Cinelli <cinelli@aur.archlinux.org>" not changed
gpg: key 7F2A16726521E06D: 5 signatures not checked due to missing keys
gpg: key 7F2A16726521E06D: "Christopher Brannon <chris@the-brannons.com>" not changed
gpg: 100 keys processed so far
gpg: key E62F853100F0D0F0: 89 signatures not checked due to missing keys
gpg: key E62F853100F0D0F0: "Gaetan Bisson <gaetan@fenua.org>" not changed
gpg: key 42A1DB15EC133BAD: 1 signature not checked due to a missing key
gpg: key 42A1DB15EC133BAD: "Angel Velásquez <angvp@archlinux.org>" not changed
gpg: key F3E1D5C5D30DB0AD: 348 signatures not checked due to missing keys
gpg: key F3E1D5C5D30DB0AD: "Andrea Scarpino <me@andreascarpino.it>" not changed
gpg: key 9BDCF497A4BBCC7F: "Pierre Neidhardt <mail@ambrevar.xyz>" not changed
gpg: key 9C08A255442FAFF0: "Jonathon Fernyhough <jonathon@manjaro.org>" not changed
gpg: key E3B3F44AC45EE0AA: "artoo-manjaro <artoo@manjaro.org>" not changed
gpg: key 7EC47C82A42D53A2: "kendell clark <kendell@manjaro.org>" not changed
gpg: key 8DB9F8C18DF53602: 1 signature not checked due to a missing key
gpg: key 8DB9F8C18DF53602: "Stefano Capitani <stefano@manjaro.org>" not changed
gpg: key DAD3B211663CA268: 31 signatures not checked due to missing keys
gpg: key DAD3B211663CA268: "Bernhard Landauer <oberon@manjaro.org>" not changed
gpg: key 62443D89B35859F8: 1 signature not checked due to a missing key
gpg: key 62443D89B35859F8: "artoo (manjaro.org) <flower_of_life@gmx.net>" not changed
gpg: key 137C934B5DCB998E: 1 signature not checked due to a missing key
gpg: key 137C934B5DCB998E: "artoo <flower_of_life@gmx.net>" not changed
gpg: key 2C089F09AC97B894: 1 signature not checked due to a missing key
gpg: key 2C089F09AC97B894: "Ramon Buldó <ramon@manjaro.org>" not changed
gpg: key 8934292D604F8BA2: 1 signature not checked due to a missing key
gpg: key 8934292D604F8BA2: "Alexandru Ianu <alexandru@manjaro.org>" not changed
gpg: key 2B80869C5C0102A6: 2 signatures not checked due to missing keys
gpg: key 2B80869C5C0102A6: "Rob McCathie <korrode@gmail.com>" not changed
gpg: key 363DFFFD59152F77: 1 signature not checked due to a missing key
gpg: key 363DFFFD59152F77: "Roland Singer (Manjaro Linux) <roland@manjaro.org>" not changed
gpg: key CAA6A59611C7F07E: 5 signatures not checked due to missing keys
gpg: key CAA6A59611C7F07E: "Philip Müller (Called Little) <philm@manjaro.org>" not changed
gpg: key 5BD96CC4247B52CC: 1 signature not checked due to a missing key
gpg: key 5BD96CC4247B52CC: "Guillaume Benoit (Guinux) <guillaume@manjaro.org>" not changed
gpg: key 5CED81B7C2E5C0D2: 1 signature not checked due to a missing key
gpg: key 5CED81B7C2E5C0D2: "Xyne. <xyne@archlinux.ca>" not changed
gpg: key 097D629E437520BD: 1 signature not checked due to a missing key
gpg: key 097D629E437520BD: "Vesa Kaihlavirta <vegai@iki.fi>" not changed
gpg: key 39E4F17F295AFBF4: 115 signatures not checked due to missing keys
gpg: key 39E4F17F295AFBF4: "Thorsten Töpper <atsutane@freethoughts.de>" not changed
gpg: key E711306E3C4F88BC: 3 signatures not checked due to missing keys
gpg: key E711306E3C4F88BC: "Timothy Redaelli <timothy.redaelli@gmail.com>" not changed
gpg: key C8880A6406361833: 5 signatures not checked due to missing keys
gpg: key C8880A6406361833: "Tom Gundersen <teg@jklm.no>" not changed
gpg: key F9E712E59AF5F22A: 9 signatures not checked due to missing keys
gpg: key F9E712E59AF5F22A: "Daniel Micay <danielmicay@gmail.com>" not changed
gpg: key 7FB1A3800C84C0A5: 1 signature not checked due to a missing key
gpg: key 7FB1A3800C84C0A5: "Thomas Dziedzic <gostrc@gmail.com>" not changed
gpg: key EA6836E1AB441196: 1 signature not checked due to a missing key
gpg: key EA6836E1AB441196: "Stéphane Gaudreault <stephane@archlinux.org>" not changed
gpg: key 1817DC63CD3B5DF5: 1 signature not checked due to a missing key
gpg: key 1817DC63CD3B5DF5: "Thanos Apostolou (manjaro maintainer) <thanos@manjaro.org>" not changed
gpg: key 8238651DDF5E0594: "Matti Hyttinen <matti@manjaro.org>" not changed
gpg: key 17C752B61B2F2E90: "Frede Hundewadt <fh@manjaro.org>" not changed
gpg: Total number processed: 128
gpg:              unchanged: 126
gpg:         new signatures: 14
gpg: key 1EB2638FF56C0C53: no user ID for key signature packet of class 10
gpg: key 1EB2638FF56C0C53: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: depth: 0  valid:   1  signed:  22  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1  valid:  22  signed:  83  trust: 0-, 0q, 0n, 22m, 0f, 0u
gpg: depth: 2  valid:  75  signed:  14  trust: 75-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2019-06-02

but then even after trying all the solutions from the cited topic I’m still getting the same errors:

:: Synchronizing package databases...
core                                             147,2 KiB   640K/s 00:00 [##########################################] 100%
extra                                           1842,9 KiB   494K/s 00:04 [##########################################] 100%
community                                          5,2 MiB   753K/s 00:07 [##########################################] 100%
multilib                                         185,5 KiB   697K/s 00:00 [##########################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
warning: could not fully load metadata for package kwayland-5.54.0-1
error: failed to prepare transaction (invalid or corrupted package)

#14

Good. You’re making progress.

However, it looks like you’re missing some output which says which package is “invalid or corrupted”

If you run pacman -Syu it should tell you, and then you can read:


#15

Apparently it is the kwayland package, isn’t it? I realized maybe the package was indeed corrupted and tried:

sudo pacman -Rdd kwayland:
warning: could not fully load metadata for package kwayland-5.54.0-1
Packages (1) kwayland-5.54.0-1
:: Do you want to remove these packages? [Y/n] y
:: Processing package changes...
(1/1) removing kwayland                                                    [##########################################] 100%
error: could not remove database entry kwayland-5.54.0-1

And indeed, the package seems to contain 0 bytes.

I remember sometime ago seeing the following everytime I ran pacman warning message:

/var/lib/pacman/local/kwayland-5.54.0-1/desc: No such file or directory

then I’ve just created the directory and it went on smoothly.


#16

It was in this case, but I’m slightly annoyed it says “warning” which normally means it’s not critical.

But anyhow - you got it fixed which is the main thing. :slight_smile:


#17

Actually sadly I didn’t, haha.

Right now, the warning is gone, but I can’t get to reinstall kwayland so I can get pacman working again.

I mean, the warning is gone:

/var/lib/pacman/local/kwayland-5.54.0-1/desc: No such file or directory

But the pacman error is not:

...
warning: could not fully load metadata for package kwayland-5.54.0-1
error: failed to prepare transaction (invalid or corrupted package)

As I showed in the last response, I’m not succeeding in removing kwayland to install it again, because I’m getting the following error when running pacman -Rdd:

error: could not remove database entry kwayland-5.54.0-1

#18

You can’t remove an entry which you’ve already removed.

So, try this:

sudo pacman-mirrors -f3
sudo pacman -Syyu
sudo pacman -U https://mirror.netzspielplatz.de/manjaro/packages/stable/extra/x86_64/kwayland-5.55.0-1-x86_64.pkg.tar.xz

#19

Hm, I’m not sure what is happening, because it seems to be installed somehow:

and trying what you suggested didn’t work out, unfortunately.


#20

In what way? Saying “it didn’t work” doesn’t tell anyone anything useful.

The stable repos have 5.55 so why are you stuck on 5.54?


#21

I’m sorry, I’ve forgot to send the feedback:

Typing ‘sudo pacman-mirrors -f3’ did work, however ‘sudo pacman -Syyu’ threw me the same old error:

error: failed to prepare transaction (invalid or corrupted package)

Oh, I didn’t know about this. I haven’t frozen the package or anything like that, so I would like to be updated in relation to the stable branch.