Update for PlayOnLinux fails because of pyasyncore

There is an update for playonlinux, but the installation fails:

Generiere Informationen zu playonlinux  ...
Überprüfe playonlinux Abhängigkeiten...
Klone python-pyasyncore Build-Dateien...
Generiere Informationen zu python-pyasyncore  ...
Überprüfe python-pyasyncore Abhängigkeiten...
Abhängigkeiten werden aufgelöst...
Interne Konflikte werden überprüft...

Erstelle python-pyasyncore...
==> Erstelle Paket: python-pyasyncore 1.0.4-1 (Mi 08 Mai 2024 15:59:45 CEST)
==> Prüfe Laufzeit-Abhängigkeiten...
==> Prüfe Buildtime-Abhängigkeiten...
==> Empfange Quellen...
  -> Aktualisiere das pyasyncore git Repo...
==> Überprüfe source Dateien mit sha256sums...
    pyasyncore ... NICHT GEFUNDEN

How to solve this?

AUR is not officially supported here, first of all have you made yourself familiar how to install an AUR package? Have you tried the manual method already? What branch are you on, AUR is more comatible to testing or unstabe branch.

In your case the file pyasyncore has not been found so best ask the AUR package maintainer for help. This has nothing to do with Manjaro.

I have just tested it - built the whole thing.

This is the only thing that yay (and pamac as well) do not handle easily.

You have to manually build python-pyasyncore

mkdir ./test
cd test
wget https://aur.archlinux.org/cgit/aur.git/snapshot/python-pyasyncore.tar.gz
tar -xzf python-pyasyncore.tar.gz
cd python-pyasyncore
makepkg -i

(better use just makepkg … without the -i option
and use pacman --asdeps -U packagename to install it)

Isn’t playonlinux just meant to ease installation and for ease of managing wine prefixes?
These will then still work - just new things can’t be installed if you don’t have playonlinux anymore.

But: you still have it - just not the newest version.

Thanks a lot, I made it successfully up to this step:

Now I’m in the directory .../test/python-pyasyncore/ having

[python-pyasyncore]$ ls -l
insgesamt 52
drwxr-xr-x 3 myname myname  4096  9. Mai 08:52 pkg
-rw-r--r-- 1 myname myname  991  9. Mai 08:51 PKGBUILD
drwxr-xr-x 7 myname myname  4096  9. Mai 08:52 pyasyncore
-rw-r--r-- 1 myname myname 36252  9. Mai 08:52 python-pyasyncore-1.0.4-1-any.pkg.tar.zst
drwxr-xr-x 3 myname myname  4096  9. Mai 08:52 src

Firing from here
pacman --asdeps -U python-pyasyncore # instead Of packagename
results in
Error: 'python-pyasyncore': could not find package
What did I wrong?

the package name is incomplete …
you want to target the package you just built - in the same directory

it is:

sudo pacman --asdeps -U python-pyasyncore-1.0.4-1-any.pkg.tar.zst

Sorry, obviously I had not enough coffee this morning …
Thanks again!

1 Like

You cannot install updpkgsums (if you want to do it at the moment) without having pyasyncore installed :grinning:

If you want to do: pacman -S pacman-contrib without having pyasyncore still installed, it fails…

All I know is:
I tried to build playonlinux.
With yay.
It failed because of pyasyncore failing to build.
The rest of the dependencies was built and installed fine.
Now just pyasyncore was missing …

Had it been present before - it would have been detected and used.
And the build would not have failed because of it.
(I just assume this now - as yay was trying to build it.
Why would it if it had been present already?)

I went to the AUR website and downloaded the snapshot from there.
unpacked it
tried to build it with makepkg - it failed again (something not found and or checksum or both, can’t remember)
This prompted me to use updpkgsum

Now you say I could not have used it had I not already had what I was just trying to build?
That makes no sense to me.

… and I just tested it -
removed python-pyasyncore and pacman-contrib - and playonlinux and it’s other dependencies as well
install pacman-contrib again
sudo pacman -S pacman-contrib

not a problem :man_shrugging:

Today pacman-contrib can be installed with success. So also your way to install python-pyasyncore !

Sorry @TJF, my experience was different: pyasyncore was definetely not installed on my system (I checked it with pamac) and the update for playonlinux failed with the checksum-error for pyasyncore. The I tried to install pyasyncore separately, same checksum-error here. Then I followed this procedure from @Nachlese (thanks again) and pyasyncore has been installed. After that, the update for playonlinux went fine.

1 Like


I think that’s a misunderstanding. I had the same problem yesterday. @Nachlese has described the manually working way. I tried the first part of the manual installation and failed due to missing “updpkgsums”. I wanted to continue here and wanted to install pacman-contrib for it. This was not possible yesterday. Today it is possible…

In any case, the way described as successful works!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.