Update failed: Failed to retrieve some files

Hi all

I have been using the pamac gui to update because I don’t want to upgrade the kernel beyond v5.15, based on difficulties I had with newer kernels in the past.

Today I cannot update my system. I clicked the pamac icon on seeing an update notification, as i usually do. This time I get “Failed to commit transaction” and “Failed to receive some files”.

In the terminal, on sudo pamac update:

Apply transaction ? [y/N] y
http://mirror.is.co.za/mirrors/manjaro.org/stable/community/x86_64/abseil-cpp-20230125.1-2-x86_64.pkg.tar.zst: Error 404
http://mirror.is.co.za/mirrors/manjaro.org/stable/community/x86_64/abseil-cpp-20230125.1-2-x86_64.pkg.tar.zst: Error 404
Error: Failed to commit transaction: failed to retrieve some files
[manj1@manT ~]$

Any advice would be greatly appreciated. Thank you.

Some time ago, [Community] and [Extra] were merged:
Steps to solve this:

Thank you, I will try and get back to you.

You should check the status of your mirror prior to updating.

As of 2023-07-10 17:02, your mirror had not synchronized:

Mirror Country Last sync Stable
mirror.is.co.za/mirrors/manjaro.org South Africa 05:46 x

Either update your mirrors (i.e. choose another one) or wait until the current one syncs.

Update: and 5 minutes later, it looks like it has synchronized:

Mirror Country Last sync Stable
mirror.is.co.za/mirrors/manjaro.org South Africa 00:06

Thank you to all who have given input.

So what I tried was sudo pacman -Syu.

This started a lengthy update process and all was fine until about 90% updated when suddenly the screen went blank except for a cursor. I was forced to restart but it seems I only had one kernel installed and now that is possibly gone. I can no longer access my Manjaro.

I am writing this from a live USB of Linux Mint. I am also trying to download a new Manjaro iso on the live USB installation and my plan is to do a full reinstall. There may , however, be another solution I am hoping somebody can suggest that will get my system running again.

Perhaps I can go via chroot to install another kernel? If so, could somebody please walk me through how to do that.

Thank you.

Update: I am on a live USB of Manjaro.

More specific:

When I try start up my PC, I get this message:

error: file /boot/vmlinux -5.15-x86.64 not found

error: you need to load the kernel first

I do see the kernel options but selecting the kernel takes me back to this message.

Any advice appreciated. Thank you.

You can try following this tutorial

1 Like

Hi Takakage

I did all those steps and now the PC goes straight to BIOS and i can’t get past it.

I wonder what is going on?

I am grateful to all who offer assistance. I hope brahma weighs in, as he has helped me many times in the past.

Okay, I need to get some sleep so i have to log out for now. Thank you, Takakage, and to all who have offered help. I will try again tomorrow to find a solution.

Update: I have done a complete reinstall and it seems to be up and running again. The only possible issue is a line about watchdog that flashes when I restart the PC and that I am sure wasn’t there previously. Otherwise I must assume a full reinstall has solved the problem.

If there are further issues, i will open a new post. Thank you for assistance to all.