Update degrades wifi performance

Hi,

Same issue here. Updating Manjaro system kills WiFi performance. The performance becomes bad very quickly, goes in bursts then drops to zero. Laptop plugged into wall power. This is the second laptop, on a different network, where I’ve found an update randomly kills wifi performance. Hoping to resolve otherwise will have to shift work machines to another distro. But I’ve enjoyed Manjaro so much.


Pre-update:
Download Speed: 57.6 Mbps

DISTRIB_ID=ManjaroLinux
DISTRIB_RELEASE=21.2.5
DISTRIB_CODENAME=Qonos
DISTRIB_DESCRIPTION="Manjaro Linux"
System:
  Host: black Kernel: 5.15.28-1-MANJARO x86_64 bits: 64
    Desktop: KDE Plasma 5.24.3 Distro: Manjaro Linux
Machine:
  Type: Laptop System: Acer product: Aspire VN7-791 v: V1.11
    serial: <superuser required>
  Mobo: Acer model: Aspire VN7-791 v: V1.11 serial: <superuser required>
    UEFI: Insyde v: 1.11 date: 01/09/2015
Battery:
  ID-1: BAT0 charge: 13.4 Wh (100.0%) condition: 13.4/52.5 Wh (25.5%)
CPU:
  Info: quad core Intel Core i7-4710HQ [MT MCP] speed (MHz): avg: 2131
    min/max: 800/3500
Graphics:
  Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915
    v: kernel
  Device-2: NVIDIA GM107M [GeForce GTX 860M] driver: nouveau v: kernel
  Device-3: Sunplus Innovation Laptop Integrated WebCam HD type: USB
    driver: uvcvideo
  Display: wayland server: X.org v: 1.21.1.3 with: Xwayland v: 22.1.0
    compositor: kwin_wayland driver: X: loaded: modesetting gpu: i915,nouveau
    resolution: 1920x1080
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2)
    v: 4.5 Mesa 21.3.7
Network:
  Device-1: Qualcomm Atheros AR9462 Wireless Network Adapter driver: ath9k
  Device-2: Broadcom NetLink BCM57780 Gigabit Ethernet PCIe driver: tg3
Drives:
  Local Storage: total: 1.02 TiB used: 233.93 GiB (22.4%)
Info:
  Processes: 254 Uptime: 4m Memory: 15.55 GiB used: 1.97 GiB (12.7%)
  Shell: Zsh inxi: 3.3.13

Post update (crda replaced with wireless-regdb and lots of other stuff):
Download Speed: same at first, but after reboot: sub 1Mbps

DISTRIB_ID=ManjaroLinux
DISTRIB_RELEASE=21.2.6
DISTRIB_CODENAME=Qonos
DISTRIB_DESCRIPTION="Manjaro Linux"
System:
  Host: black Kernel: 5.15.28-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.24.4 Distro: Manjaro Linux
Machine:
  Type: Laptop System: Acer product: Aspire VN7-791 v: V1.11
    serial: <superuser required>
  Mobo: Acer model: Aspire VN7-791 v: V1.11 serial: <superuser required>
    UEFI: Insyde v: 1.11 date: 01/09/2015
Battery:
  ID-1: BAT0 charge: 13.4 Wh (100.0%) condition: 13.4/52.5 Wh (25.5%)
CPU:
  Info: quad core Intel Core i7-4710HQ [MT MCP] speed (MHz): avg: 1257
    min/max: 800/3500
Graphics:
  Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915
    v: kernel
  Device-2: NVIDIA GM107M [GeForce GTX 860M] driver: nouveau v: kernel
  Device-3: Sunplus Innovation Laptop Integrated WebCam HD type: USB
    driver: uvcvideo
  Display: wayland server: X.org v: 1.21.1.3 with: Xwayland v: 22.1.1
    compositor: kwin_wayland driver: X: loaded: modesetting gpu: i915,nouveau
    resolution: 1920x1080
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2)
    v: 4.5 Mesa 21.3.8
Network:
  Device-1: Qualcomm Atheros AR9462 Wireless Network Adapter driver: ath9k
  Device-2: Broadcom NetLink BCM57780 Gigabit Ethernet PCIe driver: tg3
Drives:
  Local Storage: total: 1.02 TiB used: 235.91 GiB (22.6%)
Info:
  Processes: 261 Uptime: 19m Memory: 15.55 GiB used: 2.95 GiB (19.0%)
  Shell: Zsh inxi: 3.3.15

Updating with more wifi information (post update only)

Network:
  Device-1: Qualcomm Atheros AR9462 Wireless Network Adapter vendor: Foxconn
    driver: ath9k v: kernel pcie: speed: 2.5 GT/s lanes: 1 bus-ID: 07:00.0
    chip-ID: 168c:0034 class-ID: 0280
  IF: wlp7s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Broadcom NetLink BCM57780 Gigabit Ethernet PCIe
    vendor: Acer Incorporated ALI driver: tg3 v: kernel pcie: speed: 2.5 GT/s
    lanes: 1 port: N/A bus-ID: 08:00.0 chip-ID: 14e4:1692 class-ID: 0200
  IF: enp8s0 state: down mac: <filter>
  WAN IP: <filter>

Looking for any pointers to help, but it really seems to be from something in the 15-April update.