Update Broke Several Apps

Yesterday, I ran the update process on my daily driver laptop running Manjaro XFCE (21.1.0). Upon completing the updates (~2.1GB in total) I rebooted the machine. All seemed ok, initially. Until I tried to run VLC, which core dumps due to a seg fault. A few hours later, I found KRDC was exhibiting the same behavior. And this morning, I see notepadqq is also doing the same thing.

Here are the outputs:

ba@linuxlt01: ~ $ vlc [8:33:53]
VLC media player 3.0.16 Vetinari (revision 3.0.13-8-g41878ff4f2)
[00005652a5e43660] main libvlc: Running vlc with the default interface. Use ‘cvlc’ to use vlc without interface.
[1] 78460 segmentation fault (core dumped) vlc

ba@linuxlt01: ~ $ krdc [9:03:13]
[1] 78486 segmentation fault (core dumped) krdc

ba@linuxlt01: ~ $ notepadqq [9:03:35]
[1] 78506 segmentation fault (core dumped) notepadqq

At this point, I don’t know what is good and what is bad. I do not have the time to launch every app on my machine to find out.

So I’m looking to answer two questions:

  1. How do I fix the current situation
  2. How do I avoid this in the future? Updates are important, but not if they are going to kill my apps.

Any thoughts or assistance is appreciated.

The is a common denominator - the qt libraries.

I cannot reproduce the issue with notepadqq - haven’t tested vlc.

I saw another thread on ghostwriter - which is also using qt libs - which also dumps core - and that specific app also breaks on my system but not a big deal as I only checked to verify.

Screenshot testing notepadqq

I am also running a workstation on the Arch repos - and there is no issues with notepadqq on that either.

difficult question

sudo pacman -Syu

That is even more difficult - as there is no such thing as identical systems.

I have been using Arch based distribution for a very, very long time - and the past 5 years has been on Manjaro.

When I used Gnome and tested KDE I had recurring issues - but when I settled on som basic setup using Openbox window manager - I have very rarely issues and I was running my systems on unstable branch.

So I think it depends on how much you have customized your system theme-wise - I have seen - on XFCE not so much - but Gnome and KDE have a reputation for instablity with themes - and AUR builds.

At the moment I am running my primary workstation on Arch (testing) with Nvidia proprietary drivers and using the Manjaro packages for scripts and theming on Openbox - I have yet to encounter any severe issues.

I did re-install the qt5-base and then removed and re-installed vlc, but no joy.

Same version of pacman-mirrors:

ba@linuxlt01: ~ $ pacman-mirrors                                                                                                                              [9:07:12]
Pacman-mirrors version 4.21.5
Local mirror status for stable branch
Mirror #1   OK  02:55   United_States  https://mirrors.gigenet.com/manjaro/
Mirror #2   OK  00:55   United_States  https://mirror.math.princeton.edu/pub/manjaro/
Mirror #3   OK  00:54   United_States  https://mirror.dacentec.com/manjaro/
Mirror #4   OK  00:24   United_States  https://repo.ialab.dsu.edu/manjaro/
Mirror #5   OK  02:04   United_States  https://mirrors.ocf.berkeley.edu/manjaro/

I also can’t reproduce this issue.

I have vlc and notepadqq installed, and when I did the latest update, everything worked fine for me.

Ok, I’ve made some progress. Here is what I did:

Pull up the pacman history for the date I applied the updates, and did a search for qt. This yielded 5 packages:

upgraded qt5ct (1.2-1 → 1.3-1)
upgraded qt5-3d (5.15.2+kde+r25-1 → 5.15.2+kde+r32-1)
upgraded qt5-wayland (5.15.2+kde+r28-1 → 5.15.2+kde+r29-1)
upgraded poppler-qt5 (21.07.0-1 → 21.08.0-1)
upgraded kvantum-qt5 (0.19.0-1 → 0.20.1-1)

So I set about downgrading and testing. The first four yielded nothing, but downgrading kvantum-qt5 seems to have solved my issue. All three apps now launch.

As a precaution, I did add all of these packages to my IgnorePkg list. I’m not sure what the long term concerns are with this, but at least I’m working again.

Theming - one thing we usually don’t suspect as a cause for application malfunction.

I am using Kvantum on my system as well - v0.20.1 - so if an update to a theme providing app breaks apps then it is reasonable to believe the theme in use is causing it.

Now that you know it is kvantum-qt5 package - what if your update kvantum to v0.20.1 - then experiment with changing the themes to see it is all themes or just one theme?

It could - in theory at least - also be qt5ct - which also plays a part in qt theming.

I may give that a shot. The funny thing is I couldn’t care less about theming. That’s why I went XFCE. But obviously there are some defaults…