Unstable update breaks KDE


#1

Latest update breaks desktop and applications
Cannot update due to icu can't update due to breaking dependency with Manjaro-Settings-manager
#2

To be more precise… it’s qt5-base that still want the old ICU. Manjaro package is specific to manjaro… i don’t know why…


#3

I patched qt5base for an issue with opening applications. Arch don’t ship that yet. Will fix it in the next couple of days. I’m currently at my regular work.


MSM and ICU
#4

Looks like I jumped into testing branch in the last minute ;D. What a relief.


#5

I could update fine, if I ignored icu in the update.
It complained that MSM needs icu 62, so it would break that dependency if I updated icu.


#6

Which tool did let you ignore ICU and update the rest?


#7

sudo pacman -Syyu --ignore icu :stuck_out_tongue:

But I do have my fair share of apps that does not start anymore. :slight_smile:


#8

And - actually - it is not ICU but the Manjaro version of qt5-base which makes the noise.


#9

I uninstalled manjaro-settings-manager instead. Seemed less important than icu. I like the tool of course so I’ll be installing it again once it gets fixed


#10

I did this too, and now (as @fhdk predicted) my KDE/SDDM does not start when rebooting.
Gonna downgrade what I updated and reinstall what I removed to see if that fixes it.

EDIT: That did not work.
Had to switch to testing branch and pacman -Syyuu before my DE worked again.


#11

Is now sorted out …


MSM and ICU
#12

Alright, reinstalled manjaro-settings-manager, all good. Thanks @philm! May I ask why the limitation in icu version? Is it because it can have breaking changes?


#13

@philm My fresh KDE install when very well, thank you. I am now trying to find QtCreator, I am not having much luck. Do you, perhaps, know where I can find it.


#14
extra/qtcreator 4.7.2-1
    Lightweight, cross-platform integrated development environment

May not be installed by default, which IMO is the right decision.


#15

@sueridgepipe
It does not need to be installed until someone wants to use it. I used octopi and searched for ```
qtcreator 4.7.2-1


thank you

gary

#16

@sueridgepipe

I installed pamac, found it, and installed it. Thank you

gary


#17

Could have just used pacman, Pamac not needed …

sudo pacman -S qtcreator

You could have used pacman to search also …

$ pacman -Ss qtcreator
extra/qtcreator 4.7.2-1
    Lightweight, cross-platform integrated development environment

Or a more open ended search …

$ pacman -Ss creator
...
extra/qtcreator 4.7.2-1
    Lightweight, cross-platform integrated development environment
...

To search only installed packages …

pacman -Qs [search-term]

Lots of nifty things you can do …

https://wiki.archlinux.org/index.php/Pacman/Tips_and_tricks


closed #18