[Unstable Update] 2023-05-21 - Repository changes

Seems there was another toolchain update which needs a rebuild of all kernels again.This time cos of glibc 2.38. So dkms will be broken for a little longer …

I copy /etc/vconsole.conf.pacsave over /etc/vconsole.conf, it was my previous configuration for vconsole and regenerate mknitcpio.

Looks like its being looked at

1 Like

And an odd happening. I have no idea when this would have started occuring.
Dolphin > Devices Sidebar > Root Device > Properties
Displays an incorrect (and huge) device size.
Actually it begins blank, but if you hit calculate it returns 128.9 TiB on a 137 GiB partition.
Also note that all other references are normal, including the bottom of the same window.

1 Like

I think this is the known issue a long time ago.
The size of the Kernel file /proc/kcore should not be calculated because it is in RAM.

Screenshot_20230805_110332

9 years ago:

https://stackoverflow.com/questions/21170795/proc-kcore-file-is-huge

1 Like

:information_source: budgie-desktop >= 10.7.2-6 update requires manual intervention

When upgrading from budgie-desktop 10.7.2-5 to 10.7.2-6, the package mutter43 must be replaced with magpie-wm, which currently depends on mutter. As mutter43 conflicts with mutter, manual intervention is required to complete the upgrade.

First remove mutter43, then immediately perform the upgrade. Do not relog or reboot between these steps.

pacman -Rdd mutter43
pacman -Syu

Wondered why mpv starts to struggle with streaming video or audio after a while. Seems like glibc has a regression: FS#79300 : [glibc] 2.38 posix_memalign regression

Quite an old bug that sadly was never addressed …

1 Like

This issue was already reported 11 years ago. (2012-04-14)

https://bugs.kde.org/show_bug.cgi?id=298133

I wonder why KDE Dolphin can’t just ignore/exclude the RAM-directories /sys, /proc, /tmp and /run.
I know these RAM-directories run on some different RAM-filesystems: tmpfs, sysfs and proc.
they have nothing to do with hard disk.

The last comment makes it sound as if it was gone for a little while…
But yeah … I, too, am a bit surprised that something that seems so simple has apparently persisted for so long.

Libpamac now conflicts with Libpamac-aur-plugin can you fix this please?

2 Likes

For me, libpamac conflicts both with libpamac-aur-plugin and libpamac-appstream-plugin, I don’t know what is happening, may be they rolled back the changes.

I installed libpamac v11.6.0-0.3, and it seems Pamac (+AUR) works fine without needing libpamac-aur-plugin and libpamac-appstream-plugin

2 Likes

Both seem to be gone from the repos. Or rather, provided by libpamac.

Yes it appears to work, but I thought the whole point was not to be able to enable AUR with just a switch?

The split out was too early. Only the GTK4 UI seemed to be adopted to the changes made. GTK3 and CLI still depend on the libs. Hence we can’t introduce them as plugins just yet.

4 Likes

Today’s kernel update broke TPM initialization. Tested on 6.4 only, 6.1 probably also affected.

6.4 has several flaws, it’s better to check other kernels first.
fun fact, i compiled clear-linux-6.4-10 from aur that solved all problems i had with kernel 6.4 that was shipped with manjaro itself. i doubt but maybe the binary of the shipped 6.4 version has some issues with it’s compilation.

Anybody else experiencing strange artifacts on selected characters in firefox sometimes? Like all “o:s” or “n:s” gets corrupted (I think the letter is random), but if I mark the text with the cursor or mouse, it goes back to normal.
Might have seen it in other apps to, but mostly use web browser so here is where I def have observed it.
I think it came with the last or second last kernel update, but my nvidia drivers were installed in the same update, so hard to pinpoint.

I use Nvidia so I thought it was that first, but not sure.
I’m using 6.4, have not tried if it also shows on 6.1.

Maybe check which patches may created the regression for you: 6.4.11 « releases - kernel/git/stable/stable-queue.git - Linux kernel stable patch queue

TPM is one of MicroSOUR’s way to tie your hardware to your copy of WindBLOWS. With Linux there is no legitimate reason to have it enabled.

2 Likes